aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2016-11-16 00:33:20 +0000
committerMark Linimon <linimon@FreeBSD.org>2016-11-16 00:33:20 +0000
commit73d2818097455a888da772c16c623c9a64ac29c5 (patch)
tree9081a30fabfcfade229fe8346ea6c7f78b691df7 /devel
parent0d73fc690dac040400e519d6d3fdc0e9ee15e300 (diff)
downloadports-73d2818097455a888da772c16c623c9a64ac29c5.tar.gz
ports-73d2818097455a888da772c16c623c9a64ac29c5.zip
Mark as broken on various tier-2 archs.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=426195
Diffstat (limited to 'devel')
-rw-r--r--devel/bcc/Makefile2
-rw-r--r--devel/cherivis-devel/Makefile1
-rw-r--r--devel/clanlib22/Makefile5
-rw-r--r--devel/concurrencykit/Makefile2
-rw-r--r--devel/cxxtools/Makefile5
-rw-r--r--devel/dmucs/Makefile2
-rw-r--r--devel/git-merge-changelog/Makefile2
-rw-r--r--devel/godot/Makefile3
-rw-r--r--devel/kyra/Makefile2
-rw-r--r--devel/libbfd/Makefile4
-rw-r--r--devel/psptoolchain-binutils/Makefile2
-rw-r--r--devel/py-pyinstaller/Makefile3
-rw-r--r--devel/tex-libtexluajit/Makefile4
13 files changed, 35 insertions, 2 deletions
diff --git a/devel/bcc/Makefile b/devel/bcc/Makefile
index f5b89090a9ef..2c011aa12a5f 100644
--- a/devel/bcc/Makefile
+++ b/devel/bcc/Makefile
@@ -14,4 +14,6 @@ USES= uidfix
CONFLICTS= bin86-[0-9]* dev86-[0-9]*
+BROKEN_aarch64= Fails to link: error adding symbols: File in wrong format
+
.include <bsd.port.mk>
diff --git a/devel/cherivis-devel/Makefile b/devel/cherivis-devel/Makefile
index c45f0c66080f..fcc9abea8e93 100644
--- a/devel/cherivis-devel/Makefile
+++ b/devel/cherivis-devel/Makefile
@@ -11,6 +11,7 @@ COMMENT= Visualisation tool for CHERI / BERI streamtraces
LICENSE= MIT
BROKEN_FreeBSD_9= does not build on FreeBSD 9.x
+BROKEN_aarch64= does not compile: error: unexpected token in argument list
USES= gnustep
USE_GITHUB= yes
diff --git a/devel/clanlib22/Makefile b/devel/clanlib22/Makefile
index 75f3e98ab763..3fa4247acaae 100644
--- a/devel/clanlib22/Makefile
+++ b/devel/clanlib22/Makefile
@@ -6,8 +6,8 @@ PORTVERSION= 2.2.12
PORTREVISION= 7
CATEGORIES= devel
MASTER_SITES= http://www.clanlib.org/download/releases-2.0/
-DISTNAME= ClanLib-${PORTVERSION}
PKGNAMESUFFIX= 22
+DISTNAME= ClanLib-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Cross-platform game SDK
@@ -48,6 +48,9 @@ INSTALL_TARGET= install-strip
PLIST_SUB+= VER=${PORTVERSION:R} \
SHORT_VER=${PORTVERSION:R:R}${PORTVERSION:R:E}
+BROKEN_aarch64= Fails to configure: error: Requires SSE2 Support
+BROKEN_sparc64= Fails to configure: error: Requires SSE2 Support
+
post-patch:
@${REINPLACE_CMD} -e '/^extra_LIBS_clanSqlite/s|-ldl||g' \
${WRKSRC}/configure
diff --git a/devel/concurrencykit/Makefile b/devel/concurrencykit/Makefile
index 03ad7504466b..e169816551a0 100644
--- a/devel/concurrencykit/Makefile
+++ b/devel/concurrencykit/Makefile
@@ -15,6 +15,8 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= aarch64 amd64 armv6 i386 powerpc powerpc64 sparc64
+BROKEN_aarch64= Fails to configure: Detecting machine architecture...failed [unsupported]
+BROKEN_armv6= Fails to configure: Finding suitable compiler........failed [not found]
OPTIONS_DEFINE= RTM VMAPACK
OPTIONS_DEFAULT= VMAPACK
diff --git a/devel/cxxtools/Makefile b/devel/cxxtools/Makefile
index 8ea06ecca1c2..79ac4916ffa3 100644
--- a/devel/cxxtools/Makefile
+++ b/devel/cxxtools/Makefile
@@ -13,7 +13,10 @@ COMMENT= Collection of general-purpose C++ classes
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_sparc64= does not configure
+BROKEN_aarch64= does not configure: error: check for atomictype failed
+BROKEN_mips= does not configure: in section .data.rel.ro of csvdeserializer-test.o: defined in discarded section
+BROKEN_mips64= does not configure: in section .data.rel.ro of csvdeserializer-test.o: defined in discarded section
+BROKEN_sparc64= does not configure
USES= cpe iconv libtool localbase pathfix
CPE_VENDOR= tntnet
diff --git a/devel/dmucs/Makefile b/devel/dmucs/Makefile
index da2df627ad3e..1728969d93c0 100644
--- a/devel/dmucs/Makefile
+++ b/devel/dmucs/Makefile
@@ -15,4 +15,6 @@ USES= tar:bzip2
GNU_CONFIGURE= yes
PLIST_FILES= bin/dmucs bin/gethost bin/loadavg bin/monitor bin/remhost
+BROKEN_aarch64= Fails to compile: error: passing char * to parameter of incompatible type __builtin_va_list
+
.include <bsd.port.mk>
diff --git a/devel/git-merge-changelog/Makefile b/devel/git-merge-changelog/Makefile
index fa0b26b7df05..3bfc592b25c4 100644
--- a/devel/git-merge-changelog/Makefile
+++ b/devel/git-merge-changelog/Makefile
@@ -21,6 +21,8 @@ GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/${PORTNAME}
+BROKEN_aarch64= Fails to compile: error: bit-field _gl_verify_error_if_negative has negative width (-1)
+
.include <bsd.port.pre.mk>
GNULIB_DIR= ${LOCALBASE}/share/gnulib
diff --git a/devel/godot/Makefile b/devel/godot/Makefile
index 34ef12dbb361..89b8498b4343 100644
--- a/devel/godot/Makefile
+++ b/devel/godot/Makefile
@@ -62,6 +62,9 @@ PULSEAUDIO_MAKE_ARGS= pulseaudio=yes
GODOTFILE= ${PORTNAME}${PKGNAMESUFFIX}
PLIST_FILES= bin/${GODOTFILE}
+BROKEN_sparc64= Fails to compile: error: This platform cannot use safe refcount, compile with NO_THREADS or implement it
+BROKEN_aarch64= Fails to compile: error: This platform cannot use safe refcount, compile with NO_THREADS or implement it
+
.ifmake makesum
# Always include optional distfiles
.MAKEFLAGS: WITH="${OPTIONS_DEFINE}" OPTIONS_EXCLUDE=
diff --git a/devel/kyra/Makefile b/devel/kyra/Makefile
index 89abef8ade6f..bcd9c7c9158e 100644
--- a/devel/kyra/Makefile
+++ b/devel/kyra/Makefile
@@ -26,6 +26,8 @@ MAKE_ENV= MAKE_KYRA=RELEASE KYRA_OPENGL=YES
MAKE_ARGS= CC="${CC}" CXX="${CXX}" LD="${CXX}" \
RELEASE_CFLAGS="${CFLAGS}" RELEASE_CXXFLAGS="${CXXFLAGS}"
+BROKEN_aarch64= Fails to compile: error: invalid output constraint =A in asm
+
do-install:
.for i in encoder spriteed
(cd ${WRKSRC}/${i} && ${INSTALL_PROGRAM} kr${i} ${STAGEDIR}${PREFIX}/bin)
diff --git a/devel/libbfd/Makefile b/devel/libbfd/Makefile
index 1a3f93fc8585..847736061102 100644
--- a/devel/libbfd/Makefile
+++ b/devel/libbfd/Makefile
@@ -25,6 +25,10 @@ CONFIGURE_ARGS= --enable-install-libbfd \
CONFIGURE_TARGET=${ARCH:S/amd64/x86_64/}-portbld-${OPSYS:tl}${OSREL}
INFO= bfd
+BROKEN_aarch64= Fails to configure: machine aarch64-portbld not recognized
+BROKEN_armv64= Fails to configure: BFD does not support target armv6-portbld-freebsd12.0
+BROKEN_mips64= Fails to configure: BFD does not support target mips64-portbld-freebsd12.0
+
pre-configure:
# Configure and build pic version of libiberty
(cd ${WRKSRC}/../libiberty && \
diff --git a/devel/psptoolchain-binutils/Makefile b/devel/psptoolchain-binutils/Makefile
index 8a1c55b161bf..35bd68c3be48 100644
--- a/devel/psptoolchain-binutils/Makefile
+++ b/devel/psptoolchain-binutils/Makefile
@@ -12,6 +12,8 @@ PKGNAMEPREFIX= psptoolchain-
MAINTAINER= tphilipp@potion-studios.com
COMMENT= PlayStation Portable development toolchain ${PORTNAME}
+BROKEN_aarch64= Does not package: ansidecl.h: No such file or directory
+BROKEN_mips64= Does not package: ansidecl.h: No such file or directory
BROKEN_powerpc64= Does not build
USES= gmake tar:bzip2 libtool
diff --git a/devel/py-pyinstaller/Makefile b/devel/py-pyinstaller/Makefile
index 1f0c4f252856..1fafe0b43270 100644
--- a/devel/py-pyinstaller/Makefile
+++ b/devel/py-pyinstaller/Makefile
@@ -14,7 +14,10 @@ COMMENT= Program to create standalone executables from Python scripts
LICENSE= GPLv2
+BROKEN_aarch64= Does not compile: error: stb__testsize2_uinta declared as an array with a negative size
+BROKEN_mips64= Does not compile: cc1: error: unrecognized command line option "-m64
BROKEN_powerpc64= Does not build
+BROKEN_sparc64= Does not compile: error: size of array stb__testsize2_uinta is negative
OPTIONS_DEFINE= DOCS
diff --git a/devel/tex-libtexluajit/Makefile b/devel/tex-libtexluajit/Makefile
index 8fd183ee0c81..360abb763a45 100644
--- a/devel/tex-libtexluajit/Makefile
+++ b/devel/tex-libtexluajit/Makefile
@@ -14,7 +14,11 @@ COMMENT= LuaJIT library for TeXLive
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LuaJIT-2.0.3/COPYRIGHT
+BROKEN_aarch64= Does not configure: error: Sorry, can not preprocess lj_arch.h
+BROKEN_mips= Does not configure: error: Sorry, can not preprocess lj_arch.h
+BROKEN_mips64= Does not configure: error: Sorry, can not preprocess lj_arch.h
BROKEN_powerpc64= Does not build
+BROKEN_sparc64= Does not configure: error: Sorry, can not preprocess lj_arch.h
USES= tar:xz libtool pathfix pkgconfig
USE_LDCONFIG= yes