aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-08-12 16:20:36 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-08-12 16:20:36 +0000
commit7452ea67081df79c0cf72ebd7c388cccee795088 (patch)
treecdc6471c6bbd1a736966add64d645f07cff16779 /devel
parent2a8c1ce921294d6f3a1acb5d1d44f4ddb366157c (diff)
downloadports-7452ea67081df79c0cf72ebd7c388cccee795088.tar.gz
ports-7452ea67081df79c0cf72ebd7c388cccee795088.zip
Parse line as shell words.
WWW: https://github.com/mattn/go-shellwords PR: 211660 Submitted by: Sascha Holzleiter <sascha@root-login.org>
Notes
Notes: svn path=/head/; revision=420135
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/go-shellwords/Makefile20
-rw-r--r--devel/go-shellwords/distinfo3
-rw-r--r--devel/go-shellwords/pkg-descr3
-rw-r--r--devel/go-shellwords/pkg-plist6
5 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 322b2c4429b0..59f8ebf8d6aa 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -738,6 +738,7 @@
SUBDIR += go-protobuf
SUBDIR += go-raw
SUBDIR += go-runewidth
+ SUBDIR += go-shellwords
SUBDIR += go-slices
SUBDIR += go-sql-driver
SUBDIR += go-termbox
diff --git a/devel/go-shellwords/Makefile b/devel/go-shellwords/Makefile
new file mode 100644
index 000000000000..a2371ce01f2d
--- /dev/null
+++ b/devel/go-shellwords/Makefile
@@ -0,0 +1,20 @@
+# Created by: Sascha Holzleiter <sascha@root-login.org>
+# $FreeBSD$
+
+PORTNAME= go-shellwords
+PORTVERSION= 1.0.0
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+
+MAINTAINER= sascha@root-login.org
+COMMENT= Go library to parse line as shell words
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= mattn
+
+USES= go
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/go-shellwords/distinfo b/devel/go-shellwords/distinfo
new file mode 100644
index 000000000000..a8540f9c9072
--- /dev/null
+++ b/devel/go-shellwords/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470653849
+SHA256 (mattn-go-shellwords-v1.0.0_GH0.tar.gz) = c3dd9fff8f46a41c919e8aa2387fe0473d8a61037d66aff82bcd2bcb7826e188
+SIZE (mattn-go-shellwords-v1.0.0_GH0.tar.gz) = 2343
diff --git a/devel/go-shellwords/pkg-descr b/devel/go-shellwords/pkg-descr
new file mode 100644
index 000000000000..60ea54c169d2
--- /dev/null
+++ b/devel/go-shellwords/pkg-descr
@@ -0,0 +1,3 @@
+Parse line as shell words.
+
+WWW: https://github.com/mattn/go-shellwords
diff --git a/devel/go-shellwords/pkg-plist b/devel/go-shellwords/pkg-plist
new file mode 100644
index 000000000000..ea1f8c787b83
--- /dev/null
+++ b/devel/go-shellwords/pkg-plist
@@ -0,0 +1,6 @@
+%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/shellwords.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/shellwords_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/util_posix.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/util_windows.go