aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2014-07-14 15:28:23 +0000
committerTim Bishop <tdb@FreeBSD.org>2014-07-14 15:28:23 +0000
commit8162d3457d6aedd2195d38520cda9772a167d3f3 (patch)
tree4f4f3fd73976512b6addf18f7614fcf107bdacc0 /devel
parent40c71e39c45b99a32538491bc298c5b687b61094 (diff)
downloadports-8162d3457d6aedd2195d38520cda9772a167d3f3.tar.gz
ports-8162d3457d6aedd2195d38520cda9772a167d3f3.zip
- Update to 0.6
- Uses new libstatgrab API in devel/libstatgrab - Use PYDISTUTILS_AUTOPLIST to generate the pkg-plist
Notes
Notes: svn path=/head/; revision=361789
Diffstat (limited to 'devel')
-rw-r--r--devel/py-statgrab/Makefile6
-rw-r--r--devel/py-statgrab/distinfo4
-rw-r--r--devel/py-statgrab/files/patch-_statgrab.c11
-rw-r--r--devel/py-statgrab/files/patch-setup.py30
-rw-r--r--devel/py-statgrab/pkg-plist4
5 files changed, 5 insertions, 50 deletions
diff --git a/devel/py-statgrab/Makefile b/devel/py-statgrab/Makefile
index 4eef2aff9fb1..52fd82809a8d 100644
--- a/devel/py-statgrab/Makefile
+++ b/devel/py-statgrab/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= statgrab
-PORTVERSION= 0.5
+PORTVERSION= 0.6
CATEGORIES= devel python
MASTER_SITES= http://ftp.uk.i-scream.org/pub/i-scream/%SUBDIR%/ \
http://ftp.i-scream.org/pub/i-scream/%SUBDIR%/
@@ -13,11 +13,11 @@ DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= tdb@FreeBSD.org
COMMENT= Set of Python bindings for libstatgrab
-LIB_DEPENDS= libstatgrab0.so:${PORTSDIR}/devel/libstatgrab0
+LIB_DEPENDS= libstatgrab.so:${PORTSDIR}/devel/libstatgrab
USES= pkgconfig
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-PYDISTUTILS_PKGNAME= pystatgrab
+PYDISTUTILS_AUTOPLIST= yes
.include <bsd.port.mk>
diff --git a/devel/py-statgrab/distinfo b/devel/py-statgrab/distinfo
index 6fa397b4d01f..35f8233e3288 100644
--- a/devel/py-statgrab/distinfo
+++ b/devel/py-statgrab/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pystatgrab-0.5.tar.gz) = f6a0b4a2dca70f346b8bbbd705b8dc772dc4e8c7cde2b2b83c85eb65c4cfe1d8
-SIZE (pystatgrab-0.5.tar.gz) = 26867
+SHA256 (pystatgrab-0.6.tar.gz) = eee0a65e1084628008222223bafdbb3ce66dffd4aa03febb9e918e61ef0d08fe
+SIZE (pystatgrab-0.6.tar.gz) = 78763
diff --git a/devel/py-statgrab/files/patch-_statgrab.c b/devel/py-statgrab/files/patch-_statgrab.c
deleted file mode 100644
index 83323b5d054e..000000000000
--- a/devel/py-statgrab/files/patch-_statgrab.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./_statgrab.c.orig 2014-05-10 23:16:37.500760465 +0100
-+++ ./_statgrab.c 2007-07-13 23:28:28.000000000 +0100
-@@ -11,7 +11,7 @@
- #define __PYX_EXTERN_C extern
- #endif
- __PYX_EXTERN_C double pow(double, double);
--#include "statgrab.h"
-+#include "statgrab0.h"
-
-
- typedef struct {PyObject **p; char *s;} __Pyx_InternTabEntry; /*proto*/
diff --git a/devel/py-statgrab/files/patch-setup.py b/devel/py-statgrab/files/patch-setup.py
deleted file mode 100644
index 02f0cc60ad28..000000000000
--- a/devel/py-statgrab/files/patch-setup.py
+++ /dev/null
@@ -1,30 +0,0 @@
---- ./setup.py.orig 2014-05-10 23:15:23.105771349 +0100
-+++ ./setup.py 2014-05-10 23:16:18.509761277 +0100
-@@ -39,12 +39,12 @@
- sys.exit("Error, could not find pkg-config.")
-
- # test for libstatgrab presence using pkg-config
--if os.system("pkg-config --exists libstatgrab"):
-- sys.exit("Error, libstatgrab is not installed (according to pkg-config).")
-+if os.system("pkg-config --exists libstatgrab0"):
-+ sys.exit("Error, libstatgrab0 is not installed (according to pkg-config).")
-
- # test for libstatgrab version using pkg-config
--if os.system("pkg-config --atleast-version=%s libstatgrab" % LIBSTATGRAB):
-- sys.exit("Error, need at least libstatgrab version %s." % LIBSTATGRAB)
-+if os.system("pkg-config --atleast-version=%s libstatgrab0" % LIBSTATGRAB):
-+ sys.exit("Error, need at least libstatgrab0 version %s." % LIBSTATGRAB)
-
- # test for _statgrab.c, and try to generate if not found
- if not os.path.exists("_statgrab.c"):
-@@ -56,8 +56,8 @@
- sys.exit("Error, pyrexc failed to generate _statgrab.c")
-
- # get cflags and libs for libstatgrab
--cflags = getstatusoutput("pkg-config --cflags libstatgrab")
--libs = getstatusoutput("pkg-config --libs libstatgrab")
-+cflags = getstatusoutput("pkg-config --cflags libstatgrab0")
-+libs = getstatusoutput("pkg-config --libs libstatgrab0")
-
- if cflags[0] != 0:
- sys.exit("Failed to get cflags: " + cflags[1])
diff --git a/devel/py-statgrab/pkg-plist b/devel/py-statgrab/pkg-plist
deleted file mode 100644
index 5c2e3a1c5b35..000000000000
--- a/devel/py-statgrab/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-%%PYTHON_SITELIBDIR%%/_statgrab.so
-%%PYTHON_SITELIBDIR%%/statgrab.py
-%%PYTHON_SITELIBDIR%%/statgrab.pyc
-%%PYTHON_SITELIBDIR%%/statgrab.pyo