aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2022-06-27 20:11:11 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2022-06-27 20:13:45 +0000
commit85892d57d57f1707323be4bd40f677e446796641 (patch)
tree11e5b24151664de3a184c8b00c185e105da1204e /devel
parent2c1e8e65d5d3b5e28ff62e9d1083163d5eff820d (diff)
downloadports-85892d57d57f1707323be4bd40f677e446796641.tar.gz
ports-85892d57d57f1707323be4bd40f677e446796641.zip
devel/gitqlient: New port, a fancy Git viewer
The code is a fork of devel/qgit, but unrecognizable in its UI. I can't tell if I like it, yet: there's a lot more going on, and the UI doesn't follow the environment's theme / style.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gitqlient/Makefile35
-rw-r--r--devel/gitqlient/distinfo11
-rw-r--r--devel/gitqlient/pkg-descr12
-rw-r--r--devel/gitqlient/pkg-plist12
5 files changed, 71 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bdf24ec47967..816de8fab6cb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -880,6 +880,7 @@
SUBDIR += gitlist
SUBDIR += gitolite
SUBDIR += gitolite2
+ SUBDIR += gitqlient
SUBDIR += gittrac
SUBDIR += gitty
SUBDIR += gitui
diff --git a/devel/gitqlient/Makefile b/devel/gitqlient/Makefile
new file mode 100644
index 000000000000..ca06f736c3fc
--- /dev/null
+++ b/devel/gitqlient/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= gitqlient
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.5.0
+CATEGORIES= devel
+
+MAINTAINER= adridg@FreeBSD.org
+COMMENT= Graphical interface to git repositories
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= compiler:c++11-lang cpe qmake:outsource qt:5
+USE_GL+= gl
+USE_QT= core gui widgets \
+ buildtools_build
+
+USE_GITHUB= yes
+GH_ACCOUNT= francescmm
+GH_PROJECT= GitQlient \
+ QPinnableTabWidget:widget \
+ QLogger:logger \
+ AuxiliarCustomWidgets:aux \
+ git:git
+GH_TAGNAME= cc937794e910d0452f0c07b4961c6014a7358831:widget \
+ d1ed24e080521a239d5d5e2c2347fe211f0f3e4f:logger \
+ 835f538b4a79e4d6bb70eef37a32103e7b2a1fd1:aux \
+ b62750f4da4b133faff49e6f53950d659b18c948:git
+GH_SUBDIR= src/QPinnableTabWidget:widget \
+ src/QLogger:logger \
+ src/AuxiliarCustomWidgets:aux \
+ src/git:git
+
+QMAKE_SOURCE_PATH= ${WRKSRC}/GitQlient.pro
+
+.include <bsd.port.mk>
diff --git a/devel/gitqlient/distinfo b/devel/gitqlient/distinfo
new file mode 100644
index 000000000000..d49a12bf47a4
--- /dev/null
+++ b/devel/gitqlient/distinfo
@@ -0,0 +1,11 @@
+TIMESTAMP = 1656355646
+SHA256 (francescmm-GitQlient-v1.5.0_GH0.tar.gz) = 69850f3123ee2e9618c0061b7460d6ff39f0490cb9790745b1d80192069f90f8
+SIZE (francescmm-GitQlient-v1.5.0_GH0.tar.gz) = 4452568
+SHA256 (francescmm-QPinnableTabWidget-cc937794e910d0452f0c07b4961c6014a7358831_GH0.tar.gz) = b04d5d1e8060b845eea4b0b48d3d28a757db4d759c6538dc4371b59b8823f810
+SIZE (francescmm-QPinnableTabWidget-cc937794e910d0452f0c07b4961c6014a7358831_GH0.tar.gz) = 13299
+SHA256 (francescmm-QLogger-d1ed24e080521a239d5d5e2c2347fe211f0f3e4f_GH0.tar.gz) = e3f85938b7185c1ce34cd14f65bcc0d447ae73836f70c17113420b29de6e085f
+SIZE (francescmm-QLogger-d1ed24e080521a239d5d5e2c2347fe211f0f3e4f_GH0.tar.gz) = 20307
+SHA256 (francescmm-AuxiliarCustomWidgets-835f538b4a79e4d6bb70eef37a32103e7b2a1fd1_GH0.tar.gz) = 2127b389ed38446bb8bc3824dafb29db8813bb114ace83aa0d094876855aa127
+SIZE (francescmm-AuxiliarCustomWidgets-835f538b4a79e4d6bb70eef37a32103e7b2a1fd1_GH0.tar.gz) = 438731
+SHA256 (francescmm-git-b62750f4da4b133faff49e6f53950d659b18c948_GH0.tar.gz) = 19b64a7859af9e34d63a6fd84c320e978833e393be0deb93fffc6862787240be
+SIZE (francescmm-git-b62750f4da4b133faff49e6f53950d659b18c948_GH0.tar.gz) = 28824
diff --git a/devel/gitqlient/pkg-descr b/devel/gitqlient/pkg-descr
new file mode 100644
index 000000000000..b7538190cebf
--- /dev/null
+++ b/devel/gitqlient/pkg-descr
@@ -0,0 +1,12 @@
+GitQlient, pronounced as git+client is a multi-platform Git client.
+The original idea was to provide a GUI-oriented Git clientthat was
+easy to integrate with QtCreator. In addition, one goal was to
+modernize the old code that QGit is based on and provide a easy UI/UX
+that I was actually missing on other clients.
+
+- Visualisation and search of git history, branches, tags
+- Git operations such as commit, cherry-pick
+- Workflow support including pomodoro
+- Multiple repositories
+
+WWW: https://francescmm.github.io/GitQlient/
diff --git a/devel/gitqlient/pkg-plist b/devel/gitqlient/pkg-plist
new file mode 100644
index 000000000000..31afa4e6379a
--- /dev/null
+++ b/devel/gitqlient/pkg-plist
@@ -0,0 +1,12 @@
+bin/gitqlient
+share/applications/gitqlient.desktop
+share/icons/hicolor/128x128/apps/gitqlient.png
+share/icons/hicolor/16x16/apps/gitqlient.png
+share/icons/hicolor/24x24/apps/gitqlient.png
+share/icons/hicolor/256x256/apps/gitqlient.png
+share/icons/hicolor/32x32/apps/gitqlient.png
+share/icons/hicolor/48x48/apps/gitqlient.png
+share/icons/hicolor/512x512/apps/gitqlient.png
+share/icons/hicolor/64x64/apps/gitqlient.png
+share/icons/hicolor/96x96/apps/gitqlient.png
+share/icons/hicolor/scalable/apps/gitqlient.svg