aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-22 19:08:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-22 19:08:45 +0000
commit9238c2ebe5012d2276791c8b73e73d3d14855bcf (patch)
tree266617c5c834c2dff3ace05ad2e7cddaca327974 /devel
parent6bf2d1bd5da81d4bedb52fd493bcaf4d9f9907f8 (diff)
downloadports-9238c2ebe5012d2276791c8b73e73d3d14855bcf.tar.gz
ports-9238c2ebe5012d2276791c8b73e73d3d14855bcf.zip
Parse and format RFC3339 datetime strings
WWW: http://search.cpan.org/dist/DateTime-Format-RFC3339/ PR: ports/138048 Submitted by: Dan Rench <citric at cubicone.tmetic.com>
Notes
Notes: svn path=/head/; revision=240119
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-DateTime-Format-RFC3339/Makefile26
-rw-r--r--devel/p5-DateTime-Format-RFC3339/distinfo3
-rw-r--r--devel/p5-DateTime-Format-RFC3339/pkg-descr3
-rw-r--r--devel/p5-DateTime-Format-RFC3339/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6c479d3a1958..b9f1f4dcfebd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1276,6 +1276,7 @@
SUBDIR += p5-DateTime-Format-MySQL
SUBDIR += p5-DateTime-Format-Natural
SUBDIR += p5-DateTime-Format-Pg
+ SUBDIR += p5-DateTime-Format-RFC3339
SUBDIR += p5-DateTime-Format-Roman
SUBDIR += p5-DateTime-Format-SQLite
SUBDIR += p5-DateTime-Format-Strptime
diff --git a/devel/p5-DateTime-Format-RFC3339/Makefile b/devel/p5-DateTime-Format-RFC3339/Makefile
new file mode 100644
index 000000000000..d8a9e5b3e8cc
--- /dev/null
+++ b/devel/p5-DateTime-Format-RFC3339/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: p5-DateTime-Format-RFC3339
+# Date created: Fri Aug 21, 2009
+# Whom: Dan Rench <citric@cubicone.tmetic.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-RFC3339
+PORTVERSION= v1.0.1
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= citric@cubicone.tmetic.com
+COMMENT= Parse and format RFC3339 times
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/00//}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Format::RFC3339.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Format-RFC3339/distinfo b/devel/p5-DateTime-Format-RFC3339/distinfo
new file mode 100644
index 000000000000..1c2931ffdd20
--- /dev/null
+++ b/devel/p5-DateTime-Format-RFC3339/distinfo
@@ -0,0 +1,3 @@
+MD5 (DateTime-Format-RFC3339-v1.0.1.tar.gz) = 7aff1a07f0bd352dfd389cfea26fd669
+SHA256 (DateTime-Format-RFC3339-v1.0.1.tar.gz) = eef3b98918d994ac68f964009a0e005acb3bba3ec194e2e19ff19c219c3f7cec
+SIZE (DateTime-Format-RFC3339-v1.0.1.tar.gz) = 3329
diff --git a/devel/p5-DateTime-Format-RFC3339/pkg-descr b/devel/p5-DateTime-Format-RFC3339/pkg-descr
new file mode 100644
index 000000000000..a411cd84fa46
--- /dev/null
+++ b/devel/p5-DateTime-Format-RFC3339/pkg-descr
@@ -0,0 +1,3 @@
+Parse and format RFC3339 datetime strings
+
+WWW: http://search.cpan.org/dist/DateTime-Format-RFC3339/
diff --git a/devel/p5-DateTime-Format-RFC3339/pkg-plist b/devel/p5-DateTime-Format-RFC3339/pkg-plist
new file mode 100644
index 000000000000..baaeec8e5044
--- /dev/null
+++ b/devel/p5-DateTime-Format-RFC3339/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/DateTime/Format/RFC3339.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/RFC3339/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/RFC3339
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime
+@dirrmtry %%SITE_PERL%%/DateTime/Format
+@dirrmtry %%SITE_PERL%%/DateTime