aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-06-06 21:39:23 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-06-06 21:39:23 +0000
commit9c4a3eaedfd3714d478f08f42299c75d8d5e6cc5 (patch)
tree5f1ea4355a2b50d97046800b30105283161fa9f1 /devel
parent644fdc78bee90d543a3a9269a35fda1e59f6c15f (diff)
downloadports-9c4a3eaedfd3714d478f08f42299c75d8d5e6cc5.tar.gz
ports-9c4a3eaedfd3714d478f08f42299c75d8d5e6cc5.zip
Unbreak a bit
Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=356855
Diffstat (limited to 'devel')
-rw-r--r--devel/luajava/Makefile1
-rw-r--r--devel/luajava/files/patch-config14
2 files changed, 11 insertions, 4 deletions
diff --git a/devel/luajava/Makefile b/devel/luajava/Makefile
index a9f57b5a8c3c..11c983351c8b 100644
--- a/devel/luajava/Makefile
+++ b/devel/luajava/Makefile
@@ -31,6 +31,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LUA_DIR%%|${PREFIX}|' ${WRKSRC}/config
@${REINPLACE_CMD} -e 's|%%LUA_LIBDIR%%|${LUA_LIBDIR}|' ${WRKSRC}/config
@${REINPLACE_CMD} -e 's|%%LUA_INCDIR%%|${LUA_INCDIR}|' ${WRKSRC}/config
+ @${REINPLACE_CMD} -e 's|%%LUA_VER%%|${LUA_VER}|' ${WRKSRC}/config
@${REINPLACE_CMD} -e 's|%%JAVA_HOME%%|${JAVA_HOME}|' ${WRKSRC}/config
@${REINPLACE_CMD} -e 's|linux|freebsd|' ${WRKSRC}/config
diff --git a/devel/luajava/files/patch-config b/devel/luajava/files/patch-config
index 7de3bf9bc6d4..2f788a0e819e 100644
--- a/devel/luajava/files/patch-config
+++ b/devel/luajava/files/patch-config
@@ -1,6 +1,6 @@
---- config.orig 2014-05-24 01:20:21.775436051 +0800
-+++ config 2014-05-24 01:21:11.668434549 +0800
-@@ -1,9 +1,9 @@
+--- ./config.orig 2014-06-06 21:17:17.000000000 +0000
++++ ./config 2014-06-06 21:17:45.000000000 +0000
+@@ -1,14 +1,14 @@
#############################################################
#Linux/BSD/Mac
-LUA_DIR= /usr/local/share/lua/5.1.1
@@ -14,7 +14,13 @@
# For Mac OS, comment the above line and uncomment this one
#JDK=/Library/Java/Home
-@@ -23,13 +23,13 @@ LIB_OPTION= -shared
+ # Full path to Lua static library
+-LIB_LUA=$(LUA_LIBDIR)/liblua.a
++LIB_LUA=$(LUA_LIBDIR)/liblua-%%LUA_VER%%.a
+
+ #Linux/BSD
+ LIB_EXT= .so
+@@ -23,13 +23,13 @@
#LIB_OPTION= -dynamiclib -all_load
## On FreeBSD and Mac OS systems, the following line should be commented