aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-14 16:52:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-14 18:37:54 +0000
commita71501760818faf9d79d6b0fce046416504a5fb7 (patch)
treeb0815c8653856b929ad0573488a46b7550c61c92 /devel
parentb4c44944055c3af8e8510e9f1c20c334c47c9cf5 (diff)
downloadports-a71501760818faf9d79d6b0fce046416504a5fb7.tar.gz
ports-a71501760818faf9d79d6b0fce046416504a5fb7.zip
devel/py-homebase: New port: Platform independent access to user data folders
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-homebase/Makefile22
-rw-r--r--devel/py-homebase/distinfo3
-rw-r--r--devel/py-homebase/files/patch-test_test__homebase.py11
-rw-r--r--devel/py-homebase/pkg-descr4
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ea0ad601347c..daef2c61bec2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4597,6 +4597,7 @@
SUBDIR += py-hgtools
SUBDIR += py-hidraw
SUBDIR += py-holidays
+ SUBDIR += py-homebase
SUBDIR += py-http-prompt
SUBDIR += py-humanize
SUBDIR += py-hvac
diff --git a/devel/py-homebase/Makefile b/devel/py-homebase/Makefile
new file mode 100644
index 000000000000..74f33fd21321
--- /dev/null
+++ b/devel/py-homebase/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= homebase
+DISTVERSION= 1.0.1
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Platform independent access to user data folders
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python:3.7+
+USE_PYTHON= distutils cython autoplist unittest # many tests fail, see https://github.com/dwavesystems/homebase/issues/35
+
+USE_GITHUB= yes
+GH_ACCOUNT= dwavesystems
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-homebase/distinfo b/devel/py-homebase/distinfo
new file mode 100644
index 000000000000..0b990aea2dbd
--- /dev/null
+++ b/devel/py-homebase/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1660495132
+SHA256 (dwavesystems-homebase-1.0.1_GH0.tar.gz) = 48f5ad503e85f5d9a815aeb96a57eadc13230a646bd99418ab06879e2a91261e
+SIZE (dwavesystems-homebase-1.0.1_GH0.tar.gz) = 18185
diff --git a/devel/py-homebase/files/patch-test_test__homebase.py b/devel/py-homebase/files/patch-test_test__homebase.py
new file mode 100644
index 000000000000..e7cd89539d0b
--- /dev/null
+++ b/devel/py-homebase/files/patch-test_test__homebase.py
@@ -0,0 +1,11 @@
+--- test/test_homebase.py.orig 2022-08-14 16:40:47 UTC
++++ test/test_homebase.py
+@@ -667,7 +667,7 @@ class TestHomebaseVirtualEnv(TestHomebase):
+ sys.prefix = sys.base_prefix
+
+
+-@unittest.skipUnless(sys.platform.startswith('linux'), 'TestHomebaseLinuxXDG: Not Linux')
++@unittest.skipUnless(sys.platform.startswith('linux') or sys.platform.startswith('freebsd'), 'TestHomebaseLinuxXDG: Not Linux')
+ @unittest.skipIf('travis' in os.path.expanduser('~'), 'Skipping travis virtualenv tests for now.')
+ class TestHomebaseLinuxXDG(TestHomebase):
+
diff --git a/devel/py-homebase/pkg-descr b/devel/py-homebase/pkg-descr
new file mode 100644
index 000000000000..a09332708907
--- /dev/null
+++ b/devel/py-homebase/pkg-descr
@@ -0,0 +1,4 @@
+homebase provides a platform independent API for querying paths in which
+applications can write caches, data, configs, and other information.
+
+WWW: https://github.com/dwavesystems/homebase