aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-31 22:03:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-31 22:03:33 +0000
commitbf61e456737e5946247fbb1f8795d53e0942ff39 (patch)
treeb42cd3afa54ae287c6c199fc054a3b0d8e003d37 /devel
parentb489379b996577c403bada26e68e700de194a187 (diff)
downloadports-bf61e456737e5946247fbb1f8795d53e0942ff39.tar.gz
ports-bf61e456737e5946247fbb1f8795d53e0942ff39.zip
- Update to 0.2.1
PR: ports/67424 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=110563
Diffstat (limited to 'devel')
-rw-r--r--devel/phptags/Makefile6
-rw-r--r--devel/phptags/distinfo4
-rw-r--r--devel/phptags/files/patch-phptags.c64
-rw-r--r--devel/phptags/files/patch-src-phptags.cc10
4 files changed, 70 insertions, 14 deletions
diff --git a/devel/phptags/Makefile b/devel/phptags/Makefile
index c4418dc4d68c..387adccec437 100644
--- a/devel/phptags/Makefile
+++ b/devel/phptags/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= phptags
-PORTVERSION= 0.1
+PORTVERSION= 0.2.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,10 +18,12 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= phptags.1
-PLIST_FILES= bin/phptags
+PLIST_FILES= bin/phptags \
+ etc/phptags.conf.sample
PORTDOCS= AUTHORS TODO README ChangeLog INSTALL
post-install:
+ @${INSTALL_DATA} ${WRKSRC}/phptags.conf.sample ${PREFIX}/etc
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
diff --git a/devel/phptags/distinfo b/devel/phptags/distinfo
index 91115a171ac8..6177496b5bf2 100644
--- a/devel/phptags/distinfo
+++ b/devel/phptags/distinfo
@@ -1,2 +1,2 @@
-MD5 (phptags-0.1.tar.gz) = c7214263138710de76390de3291d8b54
-SIZE (phptags-0.1.tar.gz) = 141585
+MD5 (phptags-0.2.1.tar.gz) = 0e3557dae913e3e81fca7532e1684db9
+SIZE (phptags-0.2.1.tar.gz) = 149646
diff --git a/devel/phptags/files/patch-phptags.c b/devel/phptags/files/patch-phptags.c
new file mode 100644
index 000000000000..eedb15710ee7
--- /dev/null
+++ b/devel/phptags/files/patch-phptags.c
@@ -0,0 +1,64 @@
+--- src/phptags.c.orig Wed May 26 08:21:25 2004
++++ src/phptags.c Mon May 31 23:56:48 2004
+@@ -48,6 +48,9 @@
+ int i,
+ ch;
+
++ FILE *tmp_file;
++// char *line = malloc(255);
++
+ (void)read_config();
+
+ while ((ch = getopt(argc, argv, "cdf:hvV")) != -1) {
+@@ -84,9 +87,6 @@
+ if (verbose && (current_conf != "none"))
+ printf("Using config file: %s\n", current_conf);
+
+- FILE *tmp_file;
+-// char *line = malloc(255);
+-
+ tmp_file = fopen(tagsfile, "w+");
+
+ if ((int)tmp_file == NULL) {
+@@ -101,8 +101,8 @@
+ for (i = 0; i < argc; i++) {
+ char *m = malloc(256);
+ char *line;
+- line = m;
+ FILE *fd;
++ line = m;
+
+ fd = fopen(argv[i], "r");
+ if ((int)fd == NULL) {
+@@ -132,11 +132,13 @@
+ if (!commented) {
+ if (!strncmp("function ", line, 9)) {
+ /* foo bar.c /^function foo($bar)$/; */
++ int func_name_len;
++ char *func_name;
+ line+=9;
+ line[strlen(line) - 1] = '\0';
+
+- int func_name_len = strlen(line) - strlen(strstr(line, "("));
+- char *func_name = malloc(func_name_len);
++ func_name_len = strlen(line) - strlen(strstr(line, "("));
++ func_name = malloc(func_name_len);
+
+ (void)memmove(func_name, line, func_name_len);
+
+@@ -148,11 +150,13 @@
+
+ free(func_name);
+ } else if (!strncmp("class ", line, 6) && tag_classes == 1) {
++ int class_name_len;
++ char *class_name;
+ line+=6;
+ line[strlen(line) - 1] = '\0';
+
+- int class_name_len = strlen(line) - strlen(strstr(line, " "));
+- char *class_name = malloc(class_name_len);
++ class_name_len = strlen(line) - strlen(strstr(line, " "));
++ class_name = malloc(class_name_len);
+
+ (void)strncpy(class_name, line, class_name_len);
+
diff --git a/devel/phptags/files/patch-src-phptags.cc b/devel/phptags/files/patch-src-phptags.cc
deleted file mode 100644
index 4da40a81359b..000000000000
--- a/devel/phptags/files/patch-src-phptags.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/phptags.cc.orig Wed May 5 11:16:43 2004
-+++ src/phptags.cc Sun May 9 20:08:36 2004
-@@ -29,7 +29,6 @@
- #include <stdlib.h>
- #include <string.h>
- #include <ctype.h>
--#include <getopt.h>
- #include <unistd.h>
-
- #include "phptags.hh"