aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-24 18:30:36 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-24 18:30:36 +0000
commitc226d848e1389380e636e81e7a818561a6b765d6 (patch)
treedf2900d922330ff7282d51c04721a5315c34c046 /devel
parent4375a3aad1be1073d1d72cd2b730ee9e91a977a8 (diff)
downloadports-c226d848e1389380e636e81e7a818561a6b765d6.tar.gz
ports-c226d848e1389380e636e81e7a818561a6b765d6.zip
- Add missing tab in USES=pathfix
- Use !${PORT_OPTIONS:Mfoo} instead of empty(PORT_OPTIONS:Mfoo)
Notes
Notes: svn path=/head/; revision=325305
Diffstat (limited to 'devel')
-rw-r--r--devel/gflags/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/gflags/Makefile b/devel/gflags/Makefile
index a90be937f5f0..732e7aa5ceda 100644
--- a/devel/gflags/Makefile
+++ b/devel/gflags/Makefile
@@ -15,8 +15,8 @@ OPTIONS_DEFINE= DOCS
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
-USES= pathfix
USE_LDCONFIG= yes
+USES= pathfix
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README README_windows.txt \
designstyle.css gflags.html
@@ -28,7 +28,7 @@ post-patch:
-e 's|^\(docdir = \).*|\1${DOCSDIR}|' \
-e 's|^\(pkgconfigdir = \).*|\1$$(DESTDIR)$$(prefix)/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
-.if empty(PORT_OPTIONS:MDOCS)
+.if !${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e '/^install-data-am: / s| install-dist_docDATA||' ${WRKSRC}/Makefile.in
.endif