aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-12-01 08:01:52 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-12-01 08:01:52 +0000
commitcd957396e2742eac2c7bb717d7f08be01dc2be33 (patch)
tree79c6a65aeadda7b4d178d680e2e9a42df0953e5c /devel
parentc71ebcfa3810a7d3353de88981165bf96168f59b (diff)
downloadports-cd957396e2742eac2c7bb717d7f08be01dc2be33.tar.gz
ports-cd957396e2742eac2c7bb717d7f08be01dc2be33.zip
Fix gir generation when /usr/local is a symlink.
Reported by: dhw kib Obtained from: GNOME git
Notes
Notes: svn path=/head/; revision=245049
Diffstat (limited to 'devel')
-rw-r--r--devel/gobject-introspection/Makefile1
-rw-r--r--devel/gobject-introspection/files/patch-giscanner_giscannermodule.c19
2 files changed, 20 insertions, 0 deletions
diff --git a/devel/gobject-introspection/Makefile b/devel/gobject-introspection/Makefile
index 65c75bb77d53..ccd7ef57e390 100644
--- a/devel/gobject-introspection/Makefile
+++ b/devel/gobject-introspection/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gobject-introspection
PORTVERSION= 0.6.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/devel/gobject-introspection/files/patch-giscanner_giscannermodule.c b/devel/gobject-introspection/files/patch-giscanner_giscannermodule.c
new file mode 100644
index 000000000000..a1f7c79e55b7
--- /dev/null
+++ b/devel/gobject-introspection/files/patch-giscanner_giscannermodule.c
@@ -0,0 +1,19 @@
+--- giscanner/giscannermodule.c.orig 2009-12-01 02:49:21.000000000 -0500
++++ giscanner/giscannermodule.c 2009-12-01 02:49:34.000000000 -0500
+@@ -23,6 +23,7 @@
+ # include "config.h"
+ #endif
+ #include "sourcescanner.h"
++#include "grealpath.h"
+ #include <Python.h>
+
+ #ifdef _WIN32
+@@ -335,7 +336,7 @@ pygi_source_scanner_append_filename (PyG
+ return NULL;
+
+ self->scanner->filenames = g_list_append (self->scanner->filenames,
+- g_strdup (filename));
++ g_realpath (filename));
+
+ Py_INCREF (Py_None);
+ return Py_None;