aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 16:30:12 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 16:30:12 +0000
commitd575f386ddb378180ee682857ca71ac91f189043 (patch)
treea63feb788c21d4aad4bd39c04ed62536129e4d61 /devel
parenteaf473b08bcdfb2d239e5913bced388afbfe4299 (diff)
downloadports-d575f386ddb378180ee682857ca71ac91f189043.tar.gz
ports-d575f386ddb378180ee682857ca71ac91f189043.zip
devel/libx86: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'devel')
-rw-r--r--devel/libx86/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/devel/libx86/Makefile b/devel/libx86/Makefile
index e52e749f7af3..afcf96d05e8e 100644
--- a/devel/libx86/Makefile
+++ b/devel/libx86/Makefile
@@ -12,12 +12,21 @@ WWW= http://www.codon.org.uk/~mjg59/libx86/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-ALL_TARGET= default
-MAKE_ARGS= BACKEND=x86emu
ONLY_FOR_ARCHS= amd64 i386
-PLIST_FILES= include/libx86.h lib/libx86.a lib/libx86.so lib/libx86.so.1
-USE_LDCONFIG= yes
+
USES= gmake
+USE_LDCONFIG= yes
+
+MAKE_ARGS= BACKEND=x86emu
+ALL_TARGET= default
+
+PLIST_FILES= include/libx86.h lib/libx86.a lib/libx86.so lib/libx86.so.1
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
do-install:
${INSTALL_DATA} ${WRKSRC}/lrmi.h ${STAGEDIR}${PREFIX}/include/libx86.h