aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-08-25 22:38:47 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-08-25 22:38:47 +0000
commitd6a43fb81c52dbe1b6edfb8d83c0c34a2d3efc9f (patch)
treefb61fdc9099a3a4765b676440b9cae919e2445f0 /devel
parentc5c3b6820f5fb2d16b1afe3fc4c33fa242c94863 (diff)
downloadports-d6a43fb81c52dbe1b6edfb8d83c0c34a2d3efc9f.tar.gz
ports-d6a43fb81c52dbe1b6edfb8d83c0c34a2d3efc9f.zip
Add devel/vera++.
Vera++ is a programmable tool for verification, analysis and transformation of C++ source code. Vera++ is mainly an engine that parses C++ source files and presents the result of this parsing to scripts in the form of various collections - the scripts are actually performing the requested tasks. WWW: https://bitbucket.org/verateam/vera/wiki/Home PR: ports/181245 Submitted by: Cristiano Rolim Pereira <cristianorolim@outlook.com>
Notes
Notes: svn path=/head/; revision=325368
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/vera++/Makefile30
-rw-r--r--devel/vera++/distinfo4
-rw-r--r--devel/vera++/pkg-descr6
-rw-r--r--devel/vera++/pkg-plist48
5 files changed, 89 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bb3d7436e4ff..8b1b1476e262 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4441,6 +4441,7 @@
SUBDIR += valgrind-snapshot
SUBDIR += valide
SUBDIR += varconf
+ SUBDIR += vera++
SUBDIR += viewvc
SUBDIR += violet
SUBDIR += vstr
diff --git a/devel/vera++/Makefile b/devel/vera++/Makefile
new file mode 100644
index 000000000000..7192b7fb3530
--- /dev/null
+++ b/devel/vera++/Makefile
@@ -0,0 +1,30 @@
+# Created by: Cristiano Rolim Pereira <cristianorolim@outlook.com>
+# $FreeBSD$
+
+PORTNAME= vera++
+PORTVERSION= 1.2.1
+CATEGORIES= devel
+MASTER_SITES= https://bitbucket.org/verateam/vera/downloads/
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
+ ${PORTNAME}-${PORTVERSION}-doc.tar.gz
+
+MAINTAINER= cristianorolim@outlook.com
+COMMENT= Tool for verification of C++ source code
+
+BUILD_DEPENDS= boost-libs>=0:${PORTSDIR}/devel/boost-libs
+
+USE_TCL= yes
+USE_TK= yes
+USES= cmake:outsource
+
+FETCH_ARGS= -pRr
+
+CMAKE_ARGS+= -DTCL_INCLUDE_PATH=${TCL_INCLUDEDIR} \
+ -DTK_INCLUDE_PATH=${TK_INCLUDEDIR}
+
+MAN1= vera++.1
+
+post-install:
+ ${INSTALL_MAN} ${WRKDIR}/vera++.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/devel/vera++/distinfo b/devel/vera++/distinfo
new file mode 100644
index 000000000000..4ff7f4d729a7
--- /dev/null
+++ b/devel/vera++/distinfo
@@ -0,0 +1,4 @@
+SHA256 (vera++-1.2.1.tar.gz) = 99b123c8f6d0f4fe9ee90397c461179066a36ed0d598d95e015baf2d3b56956b
+SIZE (vera++-1.2.1.tar.gz) = 72539
+SHA256 (vera++-1.2.1-doc.tar.gz) = 0b3a94ce19812dac8726df5c6913dd5792ac28f0b38646c73ec4f9e2a5db0a1a
+SIZE (vera++-1.2.1-doc.tar.gz) = 29219
diff --git a/devel/vera++/pkg-descr b/devel/vera++/pkg-descr
new file mode 100644
index 000000000000..e59777837624
--- /dev/null
+++ b/devel/vera++/pkg-descr
@@ -0,0 +1,6 @@
+Vera++ is a programmable tool for verification, analysis and transformation
+of C++ source code. Vera++ is mainly an engine that parses C++ source files
+and presents the result of this parsing to scripts in the form of various
+collections - the scripts are actually performing the requested tasks.
+
+WWW: https://bitbucket.org/verateam/vera/wiki/Home
diff --git a/devel/vera++/pkg-plist b/devel/vera++/pkg-plist
new file mode 100644
index 000000000000..4f4bdcf070b9
--- /dev/null
+++ b/devel/vera++/pkg-plist
@@ -0,0 +1,48 @@
+bin/vera++
+lib/vera++/profiles/boost
+lib/vera++/profiles/default
+lib/vera++/profiles/full
+lib/vera++/scripts/rules/DUMP.tcl
+lib/vera++/scripts/rules/F001.tcl
+lib/vera++/scripts/rules/F002.tcl
+lib/vera++/scripts/rules/L001.tcl
+lib/vera++/scripts/rules/L002.tcl
+lib/vera++/scripts/rules/L003.tcl
+lib/vera++/scripts/rules/L004.tcl
+lib/vera++/scripts/rules/L005.tcl
+lib/vera++/scripts/rules/L006.tcl
+lib/vera++/scripts/rules/T001.tcl
+lib/vera++/scripts/rules/T002.tcl
+lib/vera++/scripts/rules/T003.tcl
+lib/vera++/scripts/rules/T004.tcl
+lib/vera++/scripts/rules/T005.tcl
+lib/vera++/scripts/rules/T006.tcl
+lib/vera++/scripts/rules/T007.tcl
+lib/vera++/scripts/rules/T008.tcl
+lib/vera++/scripts/rules/T009.tcl
+lib/vera++/scripts/rules/T010.tcl
+lib/vera++/scripts/rules/T011.tcl
+lib/vera++/scripts/rules/T012.tcl
+lib/vera++/scripts/rules/T013.tcl
+lib/vera++/scripts/rules/T014.tcl
+lib/vera++/scripts/rules/T015.tcl
+lib/vera++/scripts/rules/T016.tcl
+lib/vera++/scripts/rules/T017.tcl
+lib/vera++/scripts/rules/T018.tcl
+lib/vera++/scripts/rules/T019.tcl
+lib/vera++/scripts/transformations/move_includes.tcl
+lib/vera++/scripts/transformations/move_macros.tcl
+lib/vera++/scripts/transformations/move_namespace.tcl
+lib/vera++/scripts/transformations/to_lower.tcl
+lib/vera++/scripts/transformations/to_xml.tcl
+lib/vera++/scripts/transformations/to_xml2.tcl
+lib/vera++/scripts/transformations/trim_right.tcl
+lib/vera++/test_wrapper.cmake.in
+lib/vera++/use_vera++.cmake
+lib/vera++/vera++-config-version.cmake
+lib/vera++/vera++-config.cmake
+@dirrm lib/vera++/scripts/transformations
+@dirrm lib/vera++/scripts/rules
+@dirrm lib/vera++/scripts
+@dirrm lib/vera++/profiles
+@dirrm lib/vera++