aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-07-20 19:00:39 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-07-20 19:00:39 +0000
commite8d3513357966a87f0d72bb7929f725ac450abc7 (patch)
tree9437e7f11e0dcff90e15671f9e395eb22cf5cb6f /devel
parentefde9543a4dcd6b464498c19db7eec6fbec5c0c4 (diff)
downloadports-e8d3513357966a87f0d72bb7929f725ac450abc7.tar.gz
ports-e8d3513357966a87f0d72bb7929f725ac450abc7.zip
Add patch to make the port build with PyQt >= 4.11.
The PyQt4 update is coming soon, so let's prepare the ground for it.
Notes
Notes: svn path=/head/; revision=362348
Diffstat (limited to 'devel')
-rw-r--r--devel/py-pykde4/Makefile1
-rw-r--r--devel/py-pykde4/files/patch-git_1e9817f967
2 files changed, 68 insertions, 0 deletions
diff --git a/devel/py-pykde4/Makefile b/devel/py-pykde4/Makefile
index 7dfa141f48b0..1ce5f82b3dc1 100644
--- a/devel/py-pykde4/Makefile
+++ b/devel/py-pykde4/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pykde4
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde python
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/devel/py-pykde4/files/patch-git_1e9817f9 b/devel/py-pykde4/files/patch-git_1e9817f9
new file mode 100644
index 000000000000..3e99e9fd62ff
--- /dev/null
+++ b/devel/py-pykde4/files/patch-git_1e9817f9
@@ -0,0 +1,67 @@
+commit 1e9817f99b405a66199fe9f62de31d3870e3ad12
+Author: Luca Beltrame <lbeltrame@kde.org>
+Date: Fri Jun 20 11:08:31 2014 +0200
+
+ Fix building with PyQt >= 4.11
+
+ PyQt 4.11 adds new typedefs for GLuint, and these clash with the ones
+ defined in PyKDE4. Using a conditional in the sip file, the old
+ definitions are only kept if PyQt's version is lower than 4.11.
+
+ Checks have been added also for the Python 3 definitions.
+
+ CCMAIL: kde-packager@kde.org
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index cf133d7..5233da8 100644
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -113,15 +113,27 @@ set(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug)
+ # Use an extra option when compiling on Python 3.
+ if (PYTHON_VERSION_MAJOR GREATER 2)
+ if(PYQT4_VERSION STRGREATER "040904")
+- # Disable for newer PyQt
+- set(SIP_EXTRA_OPTIONS -P -g -x PyKDE_QVector)
++ # Disable for features in newer Qt
++ if (PYQT4_VERSION STRGREATER "040a04")
++ # GLuint + QVector (PyQt > 4.11)
++ set(SIP_EXTRA_OPTIONS -P -g -x PyKDE_QVector -x PyKDE_GLuint)
++ else ()
++ # QVector (PyQt < 4.11)
++ set(SIP_EXTRA_OPTIONS -P -g -x PyKDE_QVector)
++ endif ()
+ else ()
+ set(SIP_EXTRA_OPTIONS -g)
+ endif()
+ else (PYTHON_VERSION_MAJOR GREATER 2)
+ if(PYQT4_VERSION STRGREATER "040904")
+ # Disable for newer PyQt
+- set(SIP_EXTRA_OPTIONS -P -g -x PyKDE_QVector -x Py_v3)
++ if (PYQT4_VERSION STRGREATER "040a04")
++ # GLuint + QVector (PyQt > 4.11)
++ set(SIP_EXTRA_OPTIONS -P -g -x PyKDE_QVector -x Py_v3 -x PyKDE_GLuint)
++ else ()
++ # QVector (PyQt < 4.11)
++ set(SIP_EXTRA_OPTIONS -P -g -x PyKDE_QVector -x Py_v3)
++ endif ()
+ else ()
+ set(SIP_EXTRA_OPTIONS -g -x Py_v3)
+ endif()
+diff --git a/sip/plasma/glapplet.sip b/sip/plasma/glapplet.sip
+index ab35ccb..15dbd47 100644
+--- sip/plasma/glapplet.sip
++++ sip/plasma/glapplet.sip
+@@ -18,8 +18,13 @@
+ // 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+
+ //force
++
++%Feature PyKDE_GLuint
++
++%If (PyKDE_GLuint)
+ typedef unsigned int GLuint;
+ typedef unsigned int GLenum;
++%End
+
+ namespace Plasma
+ {