aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-31 21:40:57 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-31 21:40:57 +0000
commitfc9ec290237655fc33e31fe8cb0b1651ade6428f (patch)
tree8feec25e27163afdb204cd83c26c159f00ff2f98 /devel
parent43fc33f849e1dc883a91d89f9c1d2ff8cb4cefa7 (diff)
downloadports-fc9ec290237655fc33e31fe8cb0b1651ade6428f.tar.gz
ports-fc9ec290237655fc33e31fe8cb0b1651ade6428f.zip
- Update to 1.9
PR: ports/67425 Submitted by: michael johnson <ahze@ahze.net> (maintainer)
Notes
Notes: svn path=/head/; revision=110561
Diffstat (limited to 'devel')
-rw-r--r--devel/premake/Makefile2
-rw-r--r--devel/premake/distinfo4
-rw-r--r--devel/premake/files/patch-Premake.make40
-rw-r--r--devel/premake/files/patch-Src-posix.c19
4 files changed, 3 insertions, 62 deletions
diff --git a/devel/premake/Makefile b/devel/premake/Makefile
index 09024e27f7b8..b15e98e23451 100644
--- a/devel/premake/Makefile
+++ b/devel/premake/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= premake
-PORTVERSION= 1.7
+PORTVERSION= 1.9
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= premake
diff --git a/devel/premake/distinfo b/devel/premake/distinfo
index 3b562e1496d1..d168e068f5b9 100644
--- a/devel/premake/distinfo
+++ b/devel/premake/distinfo
@@ -1,2 +1,2 @@
-MD5 (premake-src-1.7.zip) = e018d8a3a42145530060b0043b530a3e
-SIZE (premake-src-1.7.zip) = 178976
+MD5 (premake-src-1.9.zip) = 6da1807dfeba1daa8e7edfa1e5d0b613
+SIZE (premake-src-1.9.zip) = 143061
diff --git a/devel/premake/files/patch-Premake.make b/devel/premake/files/patch-Premake.make
deleted file mode 100644
index ab381194eb18..000000000000
--- a/devel/premake/files/patch-Premake.make
+++ /dev/null
@@ -1,40 +0,0 @@
---- Premake.make.orig Mon Mar 29 18:33:15 2004
-+++ Premake.make Mon Mar 29 18:33:35 2004
-@@ -23,37 +23,21 @@
- -@if [ ! -d obj ]; then mkdir obj; fi
- @echo $(notdir $<)
- @$(CXX) $(CXXFLAGS) -MD -o $@ -c $<
-- @cp obj/$*.d obj/$*.P; \
-- sed -e 's/#.*//' -e 's/^[^:]*: *//' -e 's/ *\\$$//' \
-- -e '/^$$/ d' -e 's/$$/ :/' < obj/$*.d >> obj/$*.P; \
-- rm -f obj/$*.d
-
- obj/%.o : %.cpp
- -@if [ ! -d obj ]; then mkdir obj; fi
- @echo $(notdir $<)
- @$(CXX) $(CXXFLAGS) -MD -o $@ -c $<
-- @cp obj/$*.d obj/$*.P; \
-- sed -e 's/#.*//' -e 's/^[^:]*: *//' -e 's/ *\\$$//' \
-- -e '/^$$/ d' -e 's/$$/ :/' < obj/$*.d >> obj/$*.P; \
-- rm -f obj/$*.d
-
- obj/%.o : %.cxx
- -@if [ ! -d obj ]; then mkdir obj; fi
- @echo $(notdir $<)
- @$(CXX) $(CXXFLAGS) -MD -o $@ -c $<
-- @cp obj/$*.d obj/$*.P; \
-- sed -e 's/#.*//' -e 's/^[^:]*: *//' -e 's/ *\\$$//' \
-- -e '/^$$/ d' -e 's/$$/ :/' < obj/$*.d >> obj/$*.P; \
-- rm -f obj/$*.d
-
- obj/%.o : %.c
- -@if [ ! -d obj ]; then mkdir obj; fi
- @echo $(notdir $<)
- @$(CC) $(CFLAGS) -MD -o $@ -c $<
-- @cp obj/$*.d obj/$*.P; \
-- sed -e 's/#.*//' -e 's/^[^:]*: *//' -e 's/ *\\$$//' \
-- -e '/^$$/ d' -e 's/$$/ :/' < obj/$*.d >> obj/$*.P; \
-- rm -f obj/$*.d
-
- OBJECTS = \
- obj/premake.o \
diff --git a/devel/premake/files/patch-Src-posix.c b/devel/premake/files/patch-Src-posix.c
deleted file mode 100644
index f34c4c1993a6..000000000000
--- a/devel/premake/files/patch-Src-posix.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- Src/posix.c.orig Sat Mar 27 05:00:55 2004
-+++ Src/posix.c Tue Mar 30 02:47:55 2004
-@@ -89,13 +89,15 @@
-
- int plat_findLib(const char* lib, char* buffer, int size)
- {
-+ FILE* file;
-+
- if (findLib(lib, "/usr/lib"))
- {
- strcpy(buffer, "/usr/lib");
- return 1;
- }
-
-- FILE* file = fopen("/etc/ld.so.conf", "rt");
-+ file = fopen("/etc/ld.so.conf", "rt");
- if (file == NULL) return 0;
-
- while (!feof(file))