aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2019-03-18 06:05:22 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2019-03-18 06:05:22 +0000
commitff54e2e0eda3b70eda831b759323557b05e5663a (patch)
treede5365782c8b6e5959cf27a0f7a032a2457edfa1 /devel
parent3db7f4d3ba65822ed8172e9d24dc0d023d15100b (diff)
downloadports-ff54e2e0eda3b70eda831b759323557b05e5663a.tar.gz
ports-ff54e2e0eda3b70eda831b759323557b05e5663a.zip
* Updated to g20190314
* Added cleanup of *.pyc files on install/upgrade and removal The pyc cleanup is needed to completely remove all old files from the port when being removed. Old pyc files can also cause errors when YouCompleteMe start after an upgrade.
Notes
Notes: svn path=/head/; revision=496127
Diffstat (limited to 'devel')
-rw-r--r--devel/youcompleteme/Makefile16
-rw-r--r--devel/youcompleteme/distinfo14
-rw-r--r--devel/youcompleteme/files/pkg-deinstall.in4
-rw-r--r--devel/youcompleteme/files/pkg-install.in1
-rw-r--r--devel/youcompleteme/pkg-plist48
5 files changed, 54 insertions, 29 deletions
diff --git a/devel/youcompleteme/Makefile b/devel/youcompleteme/Makefile
index 36a57f636e56..b6c9abd07b61 100644
--- a/devel/youcompleteme/Makefile
+++ b/devel/youcompleteme/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= YouCompleteMe
-DISTVERSION= g20180819
-PORTREVISION= 1
+DISTVERSION= g20190314
CATEGORIES= devel
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -30,9 +29,9 @@ USES= cmake python
USE_PYTHON= flavors
USE_GITHUB= yes
GH_ACCOUNT= Valloric
-GH_TAGNAME= e018777
-GH_TUPLE= Valloric:ycmd:3869152:ycm/third_party/ycmd \
- micbou:regex:7ceefe5:ycmd5/third_party/ycmd/third_party/cregex
+GH_TAGNAME= 299f8e4
+GH_TUPLE= Valloric:ycmd:d0eba90:ycm/third_party/ycmd \
+ micbou:regex:d2ef9c4:ycmd5/third_party/ycmd/third_party/cregex
CMAKE_SOURCE_PATH+= ${WRKSRC}/third_party/ycmd/cpp
@@ -40,7 +39,8 @@ PLIST_SUB= VIMFILESDIR=share/vim/vimfiles \
YCMDDIR=share/vim/vimfiles/third_party/ycmd
SUB_FILES= pkg-message pkg-install pkg-deinstall
-SUB_LIST= VIMFILESDIR="${VIMFILESDIR}"
+SUB_LIST= VIMFILESDIR="${VIMFILESDIR}" \
+ FIND="${FIND}"
OPTIONS_DEFINE= C GO MONO RUST
OPTIONS_DEFAULT= C GO MONO RUST
@@ -51,8 +51,8 @@ GO_DESC= Go Semantic Completion Support
MONO_DESC= C\# Semantic Completion Support
RUST_DESC= Rust Semantic Completion Support
-C_CMAKE_ON= -DPATH_TO_LLVM_ROOT=${LOCALBASE}/llvm60
-C_LIB_DEPENDS= libclang.so:devel/llvm60
+C_CMAKE_ON= -DPATH_TO_LLVM_ROOT=${LOCALBASE}/llvm70
+C_LIB_DEPENDS= libclang.so:devel/llvm70
GO_RUN_DEPENDS= gocode:devel/go-gocode \
godef:devel/go-godef
diff --git a/devel/youcompleteme/distinfo b/devel/youcompleteme/distinfo
index abab95f8ec19..7f779f14fab0 100644
--- a/devel/youcompleteme/distinfo
+++ b/devel/youcompleteme/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1535906975
-SHA256 (Valloric-YouCompleteMe-g20180819-e018777_GH0.tar.gz) = ee456237838507b9a59fede99b0e5437467513b1c6c17b2e796d0c059e8ff4bf
-SIZE (Valloric-YouCompleteMe-g20180819-e018777_GH0.tar.gz) = 285684
-SHA256 (Valloric-ycmd-3869152_GH0.tar.gz) = c755c65b40caa69ecf4d734f7c5d6375b0850bf3794f39e4352ec9e060a0e2ab
-SIZE (Valloric-ycmd-3869152_GH0.tar.gz) = 3733056
-SHA256 (micbou-regex-7ceefe5_GH0.tar.gz) = d2f4bd6baf71180b86f72eb5bcc7f17e047b665353d18a9af47e014833d02be9
-SIZE (micbou-regex-7ceefe5_GH0.tar.gz) = 660277
+TIMESTAMP = 1552876103
+SHA256 (Valloric-YouCompleteMe-g20190314-299f8e4_GH0.tar.gz) = 367b35ab02d615da03285f929cf6c7c1d90778982b1f28d402647d1279a63400
+SIZE (Valloric-YouCompleteMe-g20190314-299f8e4_GH0.tar.gz) = 289525
+SHA256 (Valloric-ycmd-d0eba90_GH0.tar.gz) = 9568fa3200455d418d13007dd460ab349050e0b0b647c14c57ea7331ffde7dee
+SIZE (Valloric-ycmd-d0eba90_GH0.tar.gz) = 4544915
+SHA256 (micbou-regex-d2ef9c4_GH0.tar.gz) = 3d6df6a5e730d43ed7ce965b368ec305274ec6d5bea458a48beb94b96485c066
+SIZE (micbou-regex-d2ef9c4_GH0.tar.gz) = 674328
diff --git a/devel/youcompleteme/files/pkg-deinstall.in b/devel/youcompleteme/files/pkg-deinstall.in
index ca648ef8f160..1ee6847586f4 100644
--- a/devel/youcompleteme/files/pkg-deinstall.in
+++ b/devel/youcompleteme/files/pkg-deinstall.in
@@ -4,7 +4,11 @@
#
case $2 in
+ PRE-DEINSTALL)
+ %%FIND%% "%%VIMFILESDIR%%" -name "*.pyc" -delete
+ ;;
POST-DEINSTALL)
/bin/rm "%%VIMFILESDIR%%/doc/tags"
+ %%FIND%% "%%VIMFILESDIR%%" -name "*.pyc" -delete
;;
esac
diff --git a/devel/youcompleteme/files/pkg-install.in b/devel/youcompleteme/files/pkg-install.in
index 8dc7510bbacb..34c4bdf85bf6 100644
--- a/devel/youcompleteme/files/pkg-install.in
+++ b/devel/youcompleteme/files/pkg-install.in
@@ -6,5 +6,6 @@
case $2 in
POST-INSTALL)
%%PREFIX%%/bin/vim --noplugin -u NONE -U NONE --cmd ":helptags %%VIMFILESDIR%%/doc" --cmd ":q"
+ %%FIND%% "%%VIMFILESDIR%%" -name "*.pyc" -delete
;;
esac
diff --git a/devel/youcompleteme/pkg-plist b/devel/youcompleteme/pkg-plist
index 8da344ca3878..062cb275f43c 100644
--- a/devel/youcompleteme/pkg-plist
+++ b/devel/youcompleteme/pkg-plist
@@ -52,11 +52,12 @@
%%VIMFILESDIR%%/python/ycm/vimsupport.py
%%VIMFILESDIR%%/python/ycm/youcompleteme.py
%%YCMDDIR%%/CORE_VERSION
-%%YCMDDIR%%/clang_includes/include/Intrin.h
%%YCMDDIR%%/clang_includes/include/__clang_cuda_builtin_vars.h
%%YCMDDIR%%/clang_includes/include/__clang_cuda_cmath.h
%%YCMDDIR%%/clang_includes/include/__clang_cuda_complex_builtins.h
+%%YCMDDIR%%/clang_includes/include/__clang_cuda_device_functions.h
%%YCMDDIR%%/clang_includes/include/__clang_cuda_intrinsics.h
+%%YCMDDIR%%/clang_includes/include/__clang_cuda_libdevice_declares.h
%%YCMDDIR%%/clang_includes/include/__clang_cuda_math_forward_declares.h
%%YCMDDIR%%/clang_includes/include/__clang_cuda_runtime_wrapper.h
%%YCMDDIR%%/clang_includes/include/__stddef_max_align_t.h
@@ -95,6 +96,7 @@
%%YCMDDIR%%/clang_includes/include/bmi2intrin.h
%%YCMDDIR%%/clang_includes/include/bmiintrin.h
%%YCMDDIR%%/clang_includes/include/cetintrin.h
+%%YCMDDIR%%/clang_includes/include/cldemoteintrin.h
%%YCMDDIR%%/clang_includes/include/clflushoptintrin.h
%%YCMDDIR%%/clang_includes/include/clwbintrin.h
%%YCMDDIR%%/clang_includes/include/clzerointrin.h
@@ -113,7 +115,9 @@
%%YCMDDIR%%/clang_includes/include/htmxlintrin.h
%%YCMDDIR%%/clang_includes/include/ia32intrin.h
%%YCMDDIR%%/clang_includes/include/immintrin.h
+%%YCMDDIR%%/clang_includes/include/intrin.h
%%YCMDDIR%%/clang_includes/include/inttypes.h
+%%YCMDDIR%%/clang_includes/include/invpcidintrin.h
%%YCMDDIR%%/clang_includes/include/iso646.h
%%YCMDDIR%%/clang_includes/include/limits.h
%%YCMDDIR%%/clang_includes/include/lwpintrin.h
@@ -122,17 +126,21 @@
%%YCMDDIR%%/clang_includes/include/mm_malloc.h
%%YCMDDIR%%/clang_includes/include/mmintrin.h
%%YCMDDIR%%/clang_includes/include/module.modulemap
+%%YCMDDIR%%/clang_includes/include/movdirintrin.h
%%YCMDDIR%%/clang_includes/include/msa.h
%%YCMDDIR%%/clang_includes/include/mwaitxintrin.h
%%YCMDDIR%%/clang_includes/include/nmmintrin.h
%%YCMDDIR%%/clang_includes/include/opencl-c.h
+%%YCMDDIR%%/clang_includes/include/pconfigintrin.h
%%YCMDDIR%%/clang_includes/include/pkuintrin.h
%%YCMDDIR%%/clang_includes/include/pmmintrin.h
%%YCMDDIR%%/clang_includes/include/popcntintrin.h
%%YCMDDIR%%/clang_includes/include/prfchwintrin.h
+%%YCMDDIR%%/clang_includes/include/ptwriteintrin.h
%%YCMDDIR%%/clang_includes/include/rdseedintrin.h
%%YCMDDIR%%/clang_includes/include/rtmintrin.h
%%YCMDDIR%%/clang_includes/include/s390intrin.h
+%%YCMDDIR%%/clang_includes/include/sgxintrin.h
%%YCMDDIR%%/clang_includes/include/shaintrin.h
%%YCMDDIR%%/clang_includes/include/smmintrin.h
%%YCMDDIR%%/clang_includes/include/stdalign.h
@@ -151,6 +159,8 @@
%%YCMDDIR%%/clang_includes/include/varargs.h
%%YCMDDIR%%/clang_includes/include/vecintrin.h
%%YCMDDIR%%/clang_includes/include/vpclmulqdqintrin.h
+%%YCMDDIR%%/clang_includes/include/waitpkgintrin.h
+%%YCMDDIR%%/clang_includes/include/wbnoinvdintrin.h
%%YCMDDIR%%/clang_includes/include/wmmintrin.h
%%YCMDDIR%%/clang_includes/include/x86intrin.h
%%YCMDDIR%%/clang_includes/include/xmmintrin.h
@@ -301,8 +311,8 @@
%%YCMDDIR%%/cpp/BoostParts/boost/detail/container_fwd.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/detail/indirect_traits.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/detail/iterator.hpp
-%%YCMDDIR%%/cpp/BoostParts/boost/detail/no_exceptions_support.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/detail/scoped_enum_emulation.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/detail/select_type.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/detail/sp_typeinfo.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/detail/utf8_codecvt_facet.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/detail/utf8_codecvt_facet.ipp
@@ -363,14 +373,6 @@
%%YCMDDIR%%/cpp/BoostParts/boost/iterator/transform_iterator.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/limits.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/mem_fn.hpp
-%%YCMDDIR%%/cpp/BoostParts/boost/move/core.hpp
-%%YCMDDIR%%/cpp/BoostParts/boost/move/detail/config_begin.hpp
-%%YCMDDIR%%/cpp/BoostParts/boost/move/detail/config_end.hpp
-%%YCMDDIR%%/cpp/BoostParts/boost/move/detail/meta_utils.hpp
-%%YCMDDIR%%/cpp/BoostParts/boost/move/detail/meta_utils_core.hpp
-%%YCMDDIR%%/cpp/BoostParts/boost/move/detail/type_traits.hpp
-%%YCMDDIR%%/cpp/BoostParts/boost/move/detail/workaround.hpp
-%%YCMDDIR%%/cpp/BoostParts/boost/move/utility_core.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/mpl/always.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/mpl/and.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/mpl/apply.hpp
@@ -991,7 +993,6 @@
%%YCMDDIR%%/cpp/BoostParts/boost/mpl/void.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/mpl/void_fwd.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/next_prior.hpp
-%%YCMDDIR%%/cpp/BoostParts/boost/noncopyable.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/predef.h
%%YCMDDIR%%/cpp/BoostParts/boost/predef/architecture.h
%%YCMDDIR%%/cpp/BoostParts/boost/predef/architecture/alpha.h
@@ -1416,8 +1417,11 @@
%%YCMDDIR%%/cpp/BoostParts/boost/static_assert.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/system/api_config.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/system/config.hpp
-%%YCMDDIR%%/cpp/BoostParts/boost/system/detail/error_code.ipp
-%%YCMDDIR%%/cpp/BoostParts/boost/system/detail/local_free_on_destruction.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/system/detail/config.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/system/detail/generic_category.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/system/detail/std_interoperability.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/system/detail/system_category_posix.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/system/detail/system_category_win32.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/system/error_code.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/system/system_error.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/throw_exception.hpp
@@ -1442,12 +1446,19 @@
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/declval.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/config.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/has_binary_operator.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/is_function_cxx_03.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/is_function_cxx_11.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/is_function_msvc10_fix.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/is_function_ptr_helper.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/is_function_ptr_tester.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/is_likely_lambda.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/is_mem_fun_pointer_impl.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/is_mem_fun_pointer_tester.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/is_member_function_pointer_cxx_03.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/is_member_function_pointer_cxx_11.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/is_rvalue_reference_msvc10_fix.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/detail/yes_no_type.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/enable_if.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/function_traits.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/has_minus.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/has_minus_assign.hpp
@@ -1478,6 +1489,7 @@
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/is_lvalue_reference.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/is_member_function_pointer.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/is_member_pointer.hpp
+%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/is_noncopyable.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/is_pod.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/is_pointer.hpp
%%YCMDDIR%%/cpp/BoostParts/boost/type_traits/is_polymorphic.hpp
@@ -1544,7 +1556,6 @@
%%YCMDDIR%%/cpp/BoostParts/libs/regex/src/wc_regex_traits.cpp
%%YCMDDIR%%/cpp/BoostParts/libs/regex/src/wide_posix_api.cpp
%%YCMDDIR%%/cpp/BoostParts/libs/regex/src/winstances.cpp
-%%YCMDDIR%%/cpp/BoostParts/libs/system/src/error_code.cpp
%%YCMDDIR%%/cpp/CMakeLists.txt
%%YCMDDIR%%/cpp/llvm/include/clang-c/BuildSystem.h
%%YCMDDIR%%/cpp/llvm/include/clang-c/CXCompilationDatabase.h
@@ -1578,6 +1589,9 @@
%%YCMDDIR%%/cpp/pybind11/pybind11/pytypes.h
%%YCMDDIR%%/cpp/pybind11/pybind11/stl.h
%%YCMDDIR%%/cpp/pybind11/pybind11/stl_bind.h
+%%YCMDDIR%%/cpp/whereami/LICENSE.MIT
+%%YCMDDIR%%/cpp/whereami/whereami.c
+%%YCMDDIR%%/cpp/whereami/whereami.h
%%YCMDDIR%%/cpp/ycm/CMakeLists.txt
%%YCMDDIR%%/cpp/ycm/Candidate.cpp
%%YCMDDIR%%/cpp/ycm/Candidate.h
@@ -1600,6 +1614,7 @@
%%YCMDDIR%%/cpp/ycm/ClangCompleter/Diagnostic.h
%%YCMDDIR%%/cpp/ycm/ClangCompleter/Documentation.cpp
%%YCMDDIR%%/cpp/ycm/ClangCompleter/Documentation.h
+%%YCMDDIR%%/cpp/ycm/ClangCompleter/FixIt.h
%%YCMDDIR%%/cpp/ycm/ClangCompleter/Location.h
%%YCMDDIR%%/cpp/ycm/ClangCompleter/Range.cpp
%%YCMDDIR%%/cpp/ycm/ClangCompleter/Range.h
@@ -1721,12 +1736,14 @@
%%YCMDDIR%%/ycmd/completers/__init__.py
%%YCMDDIR%%/ycmd/completers/all/__init__.py
%%YCMDDIR%%/ycmd/completers/all/identifier_completer.py
+%%YCMDDIR%%/ycmd/completers/c/__init__.py
%%YCMDDIR%%/ycmd/completers/c/hook.py
%%YCMDDIR%%/ycmd/completers/completer.py
%%YCMDDIR%%/ycmd/completers/completer_utils.py
%%YCMDDIR%%/ycmd/completers/cpp/__init__.py
%%YCMDDIR%%/ycmd/completers/cpp/clang_completer.py
%%YCMDDIR%%/ycmd/completers/cpp/clang_helpers.py
+%%YCMDDIR%%/ycmd/completers/cpp/clangd_completer.py
%%YCMDDIR%%/ycmd/completers/cpp/ephemeral_values_set.py
%%YCMDDIR%%/ycmd/completers/cpp/flags.py
%%YCMDDIR%%/ycmd/completers/cpp/hook.py
@@ -1735,6 +1752,7 @@
%%YCMDDIR%%/ycmd/completers/cs/cs_completer.py
%%YCMDDIR%%/ycmd/completers/cs/hook.py
%%YCMDDIR%%/ycmd/completers/cs/solutiondetection.py
+%%YCMDDIR%%/ycmd/completers/cuda/__init__.py
%%YCMDDIR%%/ycmd/completers/cuda/hook.py
%%YCMDDIR%%/ycmd/completers/general/__init__.py
%%YCMDDIR%%/ycmd/completers/general/filename_completer.py
@@ -1753,7 +1771,9 @@
%%YCMDDIR%%/ycmd/completers/language_server/__init__.py
%%YCMDDIR%%/ycmd/completers/language_server/language_server_completer.py
%%YCMDDIR%%/ycmd/completers/language_server/language_server_protocol.py
+%%YCMDDIR%%/ycmd/completers/objc/__init__.py
%%YCMDDIR%%/ycmd/completers/objc/hook.py
+%%YCMDDIR%%/ycmd/completers/objcpp/__init__.py
%%YCMDDIR%%/ycmd/completers/objcpp/hook.py
%%YCMDDIR%%/ycmd/completers/python/__init__.py
%%YCMDDIR%%/ycmd/completers/python/hook.py