aboutsummaryrefslogtreecommitdiff
path: root/dns/bind-tools
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-04-24 13:17:03 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-04-24 13:17:03 +0000
commitf0886cc3f34902af16335020966e4a5f23ba1cde (patch)
tree0d089e894501267bcde6d2533da92e4b461ba35a /dns/bind-tools
parentae361266f4da8467de19f30b1db66c4a4196985d (diff)
downloadports-f0886cc3f34902af16335020966e4a5f23ba1cde.tar.gz
ports-f0886cc3f34902af16335020966e4a5f23ba1cde.zip
Readd dns/bind-tools.
This is done in a similar manner as the old bind-tools, but uses bind99 instead of bind97 as master port. Change bind99 to facilitate the bind-tools slave, in a simlar way as was done for bind97. Approved by: erwin (maintainer)
Notes
Notes: svn path=/head/; revision=316430
Diffstat (limited to 'dns/bind-tools')
-rw-r--r--dns/bind-tools/Makefile38
-rw-r--r--dns/bind-tools/pkg-descr4
-rw-r--r--dns/bind-tools/pkg-plist3
3 files changed, 45 insertions, 0 deletions
diff --git a/dns/bind-tools/Makefile b/dns/bind-tools/Makefile
new file mode 100644
index 000000000000..0be0e3cff2e9
--- /dev/null
+++ b/dns/bind-tools/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= bind-tools
+
+COMMENT= Command line tools from BIND: dig, host, and nslookup
+
+CONFIGURE_ARGS+= --disable-shared
+
+CONFLICTS+= bind99-9.9.*
+
+MASTERDIR= ${.CURDIR}/../../dns/bind99
+
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+BIND_TOOLS_SLAVE= YES
+
+MAN1= dig.1 host.1 nslookup.1
+
+post-patch:
+ @${MV} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.presed
+ @${SED} -e 's#^SUBDIRS.*#SUBDIRS = lib bin#' \
+ -e 's#isc-config.sh installdirs#installdirs#' \
+ -e 's#.*INSTALL.*isc-config.*##' \
+ -e 's#.*INSTALL.*bind.keys.*##' \
+ ${WRKSRC}/Makefile.in.presed > ${WRKSRC}/Makefile.in
+ @${MV} ${WRKSRC}/bin/Makefile.in ${WRKSRC}/bin/Makefile.in.presed
+ @${SED} -e 's#^SUBDIRS.*#SUBDIRS = dig#' \
+ -e 's#^ .*check confgen ##' \
+ ${WRKSRC}/bin/Makefile.in.presed > ${WRKSRC}/bin/Makefile.in
+
+do-install:
+.for file in dig host nslookup
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/dig/${file} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/bin/dig/${file}.1 ${MANPREFIX}/man/man1
+.endfor
+
+.include "${MASTERDIR}/Makefile"
diff --git a/dns/bind-tools/pkg-descr b/dns/bind-tools/pkg-descr
new file mode 100644
index 000000000000..c0f754e63a66
--- /dev/null
+++ b/dns/bind-tools/pkg-descr
@@ -0,0 +1,4 @@
+The user space command line tools from the latest version of BIND:
+ dig, host, and nslookup
+
+WWW: https://www.isc.org/software/bind
diff --git a/dns/bind-tools/pkg-plist b/dns/bind-tools/pkg-plist
new file mode 100644
index 000000000000..613de606e8a5
--- /dev/null
+++ b/dns/bind-tools/pkg-plist
@@ -0,0 +1,3 @@
+bin/dig
+bin/host
+bin/nslookup