aboutsummaryrefslogtreecommitdiff
path: root/dns/bind9-devel
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2021-05-17 08:37:58 +0000
committerMathieu Arnold <mat@FreeBSD.org>2021-05-17 08:51:12 +0000
commit98f6df463f7817d780a607681e426777c5f78b6a (patch)
tree23885a061213c6c4fdb5cf6ce0afe32988ef32e9 /dns/bind9-devel
parent05ed3e73e60a458293aee4c824fc8c792dd9517b (diff)
downloadports-98f6df463f7817d780a607681e426777c5f78b6a.tar.gz
ports-98f6df463f7817d780a607681e426777c5f78b6a.zip
Update to latest commit.
Diffstat (limited to 'dns/bind9-devel')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
3 files changed, 12 insertions, 12 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index fb319194177b..bad4940661ed 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -49,13 +49,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= autoreconf compiler:c11 cpe libedit libtool pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.17.12a0.2021.05.07
+ISCVERSION= 9.17.12a0.2021.05.17
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 0e920608334707a7c9ca34c80f9e70db33962305
+GL_COMMIT= d34672796cd8506a0c7f996619c5c38cd417c499
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 026ef9c173a6..1281333bee44 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620630970
-SHA256 (isc-projects-bind9-0e920608334707a7c9ca34c80f9e70db33962305_GL0.tar.gz) = f729bf64580cc54239eb36be5accae83514e9cc08287aa54bfdbee3c02df29db
-SIZE (isc-projects-bind9-0e920608334707a7c9ca34c80f9e70db33962305_GL0.tar.gz) = 6427374
+TIMESTAMP = 1621239390
+SHA256 (isc-projects-bind9-d34672796cd8506a0c7f996619c5c38cd417c499_GL0.tar.gz) = f8bc76fac46590c9410184a396695b1d67a85f3bc1df109df9f5b09f442a7f08
+SIZE (isc-projects-bind9-d34672796cd8506a0c7f996619c5c38cd417c499_GL0.tar.gz) = 6430469
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 6f0b0a092fa0..78fa470b3b18 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,8 +1,8 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2021-03-22 10:06:45 UTC
+--- bin/named/config.c.orig 2021-05-17 07:42:37 UTC
+++ bin/named/config.c
-@@ -181,6 +181,7 @@ options {\n\
+@@ -185,6 +185,7 @@ options {\n\
notify-source *;\n\
notify-source-v6 *;\n\
nsec3-test-zone no;\n\
@@ -10,7 +10,7 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2021-03-22 10:06:45 UTC
+--- bin/named/server.c.orig 2021-05-17 07:42:37 UTC
+++ bin/named/server.c
@@ -4456,6 +4456,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2021-03-22 10:06:45 UTC
+--- lib/dns/include/dns/view.h.orig 2021-05-17 07:42:37 UTC
+++ lib/dns/include/dns/view.h
@@ -154,6 +154,7 @@ struct dns_view {
bool requestnsid;
@@ -34,7 +34,7 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2021-03-22 10:06:45 UTC
+--- lib/dns/resolver.c.orig 2021-05-17 07:42:37 UTC
+++ lib/dns/resolver.c
@@ -6388,6 +6388,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
@@ -49,9 +49,9 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2021-03-22 10:06:45 UTC
+--- lib/isccfg/namedconf.c.orig 2021-05-17 07:42:37 UTC
+++ lib/isccfg/namedconf.c
-@@ -2024,6 +2024,7 @@ static cfg_clausedef_t view_clauses[] = {
+@@ -2028,6 +2028,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
{ "max-acache-size", NULL, CFG_CLAUSEFLAG_ANCIENT },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },