aboutsummaryrefslogtreecommitdiff
path: root/dns/bind9-dlz
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-01-16 16:40:30 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-01-16 16:40:30 +0000
commit3aafe20c325477139511b91ce60579cf12f84b2e (patch)
treea92e0c1ac0446b650e6a365b795d21b3d7a94dcc /dns/bind9-dlz
parente4fe032f4922da902fac9d6a21c0a3f2a5ec6c04 (diff)
downloadports-3aafe20c325477139511b91ce60579cf12f84b2e.tar.gz
ports-3aafe20c325477139511b91ce60579cf12f84b2e.zip
- set BINDDLZ_OPTIONS in Makefile
- clean up configure script - Filesystem-Driver default ON - new option: WITHOUT_POSTGRESQL_DRIVER - new option: WITHOUT_FILESYSTEM_DRIVER - new option: WITHOUT_OPENSSL - target describe for INDEX now with matching dependencies.
Notes
Notes: svn path=/head/; revision=73267
Diffstat (limited to 'dns/bind9-dlz')
-rw-r--r--dns/bind9-dlz/Makefile22
-rw-r--r--dns/bind9-dlz/files/configure.bind9-dlz11
2 files changed, 25 insertions, 8 deletions
diff --git a/dns/bind9-dlz/Makefile b/dns/bind9-dlz/Makefile
index e59212276486..3535355f5dbd 100644
--- a/dns/bind9-dlz/Makefile
+++ b/dns/bind9-dlz/Makefile
@@ -27,14 +27,24 @@ USE_SUBMAKE= YES
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps
+# use user config if possible
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
+.else
+.if defined(BATCH)
+# default package, can be configured in /etc/make.conf
+BINDDLZ_OPTIONS?= \"OpenSSL\" \"PostgreSQL\" \"FileSystem\"
+.endif
+# make INDEX match
+NO_DESCRIBE=yes
.endif
.if defined(WITH_POSTGRESQL_DRIVER)
+.if !defined(WITHOUT_POSTGRESQL_DRIVER)
LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-dlz-postgres
.endif
+.endif
.if defined(WITH_MYSQL_DRIVER)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
@@ -42,8 +52,10 @@ CONFIGURE_ARGS+= --with-dlz-mysql
.endif
.if defined(WITH_FILESYSTEM_DRIVER)
+.if !defined(WITHOUT_FILESYSTEM_DRIVER)
CONFIGURE_ARGS+= --with-dlz-filesystem
.endif
+.endif
.if defined(WITH_STUB_DRIVER)
CONFIGURE_ARGS+= --with-dlz-stub
@@ -163,9 +175,11 @@ post-clean:
.include <bsd.port.pre.mk>
.if defined(WITH_OPENSSL)
+.if !defined(WITHOUT_OPENSSL)
.include "${PORTSDIR}/security/openssl/Makefile.ssl"
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.endif
+.endif
.if ${OSVERSION} > 500030
CONFIGURE_ARGS+= --enable-threads
@@ -173,4 +187,12 @@ CONFIGURE_ARGS+= --enable-threads
CONFIGURE_ARGS+= --disable-threads
.endif
+.if defined(NO_DESCRIBE)
+describe:
+.if defined(BATCH)
+ @ ${SETENV} ${SCRIPTS_ENV} ${SH} ${FILESDIR}/configure.bind9-dlz
+.endif
+ @cd ${.CURDIR} && ${MAKE} ${__softMAKEFLAGS} BATCH=yes ${.TARGET}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/dns/bind9-dlz/files/configure.bind9-dlz b/dns/bind9-dlz/files/configure.bind9-dlz
index cf6e0b06b488..26e7a56cacc7 100644
--- a/dns/bind9-dlz/files/configure.bind9-dlz
+++ b/dns/bind9-dlz/files/configure.bind9-dlz
@@ -6,12 +6,8 @@ if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
fi
-if [ "${BATCH}" -o "${BINDDLZ_OPTIONS}" ]; then
- if [ "${BINDDLZ_OPTIONS}" ]; then
- set ${BINDDLZ_OPTIONS}
- else
- set \"OpenSSL\" \"PostgreSQL\" \"FileSystem\"
- fi
+if [ "${BINDDLZ_OPTIONS}" ]; then
+ set ${BINDDLZ_OPTIONS}
else
dialog --title "configuration options" --clear \
--checklist "\n\
@@ -19,7 +15,7 @@ Please select desired options:" -1 -1 5 \
OpenSSL "OpenSSL support" ON \
PostgreSQL "PostgreSQL driver" ON \
MySQL "MySQL driver" OFF \
-FileSystem "Filesystem driver" OFF \
+FileSystem "Filesystem driver" ON \
Stub "Stub driver" OFF \
2> /tmp/checklist.tmp.$$
@@ -50,7 +46,6 @@ while [ "$1" ]; do
;;
\"PostgreSQL\")
echo WITH_POSTGRESQL_DRIVER=YES
- WITH_POSTGRESQL_DRIVER=1
;;
\"MySQL\")
echo WITH_MYSQL_DRIVER=YES