aboutsummaryrefslogtreecommitdiff
path: root/dns/bind9
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2003-01-26 08:42:01 +0000
committerDoug Barton <dougb@FreeBSD.org>2003-01-26 08:42:01 +0000
commit5c2fc66d06f96846ccb4ce44cf1e9e4c4f7a4531 (patch)
treea962e2d69dfa676793fcbbbb60115aa98116207f /dns/bind9
parenta2fcaed56f53188cac42a7d4a6ddcfaae5323f3c (diff)
downloadports-5c2fc66d06f96846ccb4ce44cf1e9e4c4f7a4531.tar.gz
ports-5c2fc66d06f96846ccb4ce44cf1e9e4c4f7a4531.zip
Upgrade to 9.2.2rc1. This version has been available for several months, and
is widely considered to be more stable than 9.2.1. I would have preferred a -REL version, but better is better. * Clean up the Makefile a little * Just say no to threads * Add the PORT_REPLACES_BASE magic, similar to the bind8 port
Notes
Notes: svn path=/head/; revision=74024
Diffstat (limited to 'dns/bind9')
-rw-r--r--dns/bind9/Makefile46
-rw-r--r--dns/bind9/distinfo2
-rw-r--r--dns/bind9/pkg-plist4
3 files changed, 28 insertions, 24 deletions
diff --git a/dns/bind9/Makefile b/dns/bind9/Makefile
index fbb46ab32ded..9b53cb7f0caa 100644
--- a/dns/bind9/Makefile
+++ b/dns/bind9/Makefile
@@ -12,19 +12,21 @@
# release you can generally build it cleanly from the source - Doug
PORTNAME= bind9
-PORTVERSION= 9.2.1
+PORTVERSION= 9.2.2.rc1
CATEGORIES= net ipv6
MASTER_SITES= ${MASTER_SITE_ISC} \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/bind9/${ISCVERSION}/,}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
-DISTFILES= bind-9.2.1.tar.gz
+DISTFILES= bind-${ISCVERSION}.tar.gz
MAINTAINER= DougB@FreeBSD.org
-ISCVERSION= 9.2.1
+# ISC releases things like 9.2.2rc1, which our versioning doesn't like
+ISCVERSION= 9.2.2rc1
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps
+CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps --disable-threads \
+ --with-randomdev=/dev/random
.include <bsd.port.pre.mk>
@@ -33,12 +35,19 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.endif
-.if ${OSVERSION} > 500030
-CONFIGURE_ARGS+= --enable-threads
+.if defined(PORT_REPLACES_BASE_BIND9)
+PKGNAMESUFFIX= -base
+PREFIX= /usr
+BIND_DESTETC= /etc/namedb
+CONFIGURE_ARGS+= --prefix=${PREFIX} \
+ --sysconfdir=${BIND_DESTETC} \
+ --mandir=${MANPREFIX}/man
.else
-CONFIGURE_ARGS+= --disable-threads
+BIND_DESTETC= ${PREFIX}/etc
.endif
+PLIST_SUB= BIND_DESTETC="${BIND_DESTETC}"
+
MAN1= dig.1 host.1
MAN3= lwres.3 lwres_addr_parse.3 lwres_buffer.3 lwres_buffer_add.3 \
lwres_buffer_back.3 lwres_buffer_clear.3 lwres_buffer_first.3 \
@@ -79,29 +88,24 @@ MAN8= dnssec-keygen.8 dnssec-makekeyset.8 dnssec-signkey.8 dnssec-signzone.8 \
rndc-confgen.8 rndc.8
WRKSRC= ${WRKDIR}/bind-${ISCVERSION}
-DIR= ${WRKSRC}/bin/
post-patch:
.for FILE in check/named-checkconf.8 named/named.8 nsupdate/nsupdate.8 \
rndc/rndc.8
- @ ${MV} ${DIR}/${FILE} ${DIR}/${FILE}.Dist
- @ ${SED} -e 's#/etc/named.conf#${PREFIX}/etc/named.conf#g' \
- -e 's#/etc/rndc.conf#${PREFIX}/etc/rndc.conf#g' \
- ${DIR}/${FILE}.Dist > ${DIR}/${FILE}
+ @ ${MV} ${WRKSRC}/bin/${FILE} ${WRKSRC}/bin/${FILE}.Dist
+ @ ${SED} -e 's#/etc/named.conf#${BIND_DESTETC}/named.conf#g' \
+ -e 's#/etc/rndc.conf#${BIND_DESTETC}/rndc.conf#g' \
+ ${WRKSRC}/bin/${FILE}.Dist > ${WRKSRC}/bin/${FILE}
.endfor
post-install:
${INSTALL_DATA} ${WRKSRC}/bin/rndc/rndc.conf \
- ${PREFIX}/etc/rndc.conf.sample
-
+ ${BIND_DESTETC}/rndc.conf.sample
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/bind9/arm
- ${INSTALL_DATA} ${WRKSRC}/doc/arm/Bv9ARM*html \
- ${PREFIX}/share/doc/bind9/arm
- ${MKDIR} ${PREFIX}/share/doc/bind9/misc
- ${INSTALL_DATA} ${WRKSRC}/doc/misc/[a-z]* \
- ${PREFIX}/share/doc/bind9/misc
+ ${MKDIR} ${DOCSDIR}/arm ${DOCSDIR}/misc
+ ${INSTALL_DATA} ${WRKSRC}/doc/arm/Bv9ARM*html ${DOCSDIR}/arm
+ ${INSTALL_DATA} ${WRKSRC}/doc/misc/[a-z]* ${DOCSDIR}/misc
${CP} ${WRKSRC}/CHANGES ${WRKSRC}/COPYRIGHT ${WRKSRC}/FAQ \
- ${WRKSRC}/README ${PREFIX}/share/doc/bind9/
+ ${WRKSRC}/README ${DOCSDIR}/
.endif
.include <bsd.port.post.mk>
diff --git a/dns/bind9/distinfo b/dns/bind9/distinfo
index edb9529716ee..c8c9d2f6bbf6 100644
--- a/dns/bind9/distinfo
+++ b/dns/bind9/distinfo
@@ -1 +1 @@
-MD5 (bind-9.2.1.tar.gz) = 692cff6f44e006ce6984b2c286949dd1
+MD5 (bind-9.2.2rc1.tar.gz) = e591be8890c53845133577ac7e042fb6
diff --git a/dns/bind9/pkg-plist b/dns/bind9/pkg-plist
index 1ef1ebb36905..2d6955538cd3 100644
--- a/dns/bind9/pkg-plist
+++ b/dns/bind9/pkg-plist
@@ -3,7 +3,6 @@ bin/host
bin/isc-config.sh
bin/nslookup
bin/nsupdate
-etc/rndc.conf.sample
include/dns/a6.h
include/dns/acl.h
include/dns/adb.h
@@ -206,9 +205,10 @@ sbin/rndc-confgen
%%PORTDOCS%%@dirrm share/doc/bind9/arm
%%PORTDOCS%%@dirrm share/doc/bind9/misc
%%PORTDOCS%%@dirrm share/doc/bind9
+@unexec rm -f %%BIND_DESTETC%%/rndc.conf.sample
@dirrm include/dns
@dirrm include/dst
-@dirrm include/isc
+@unexec rmdir %D/include/isc 2>/dev/null || true
@dirrm include/isccc
@dirrm include/isccfg
@dirrm include/lwres