aboutsummaryrefslogtreecommitdiff
path: root/dns/c-ares
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-11-07 17:05:51 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-11-07 17:05:51 +0000
commit251a42417ac80c6de4ba902d7b3e6a17cb16066a (patch)
treefd3191e177968b307c38702f8ab87f63b7d58b8c /dns/c-ares
parent10254a2d7c3ef0bccbb88e4f7de2201b609b7da2 (diff)
downloadports-251a42417ac80c6de4ba902d7b3e6a17cb16066a.tar.gz
ports-251a42417ac80c6de4ba902d7b3e6a17cb16066a.zip
Build and install the shared c-ares library too, not just the static one.
This should help the build of libcurl on amd64, what with -fPIC and such. Reported by: girgen
Notes
Notes: svn path=/head/; revision=176727
Diffstat (limited to 'dns/c-ares')
-rw-r--r--dns/c-ares/Makefile10
-rw-r--r--dns/c-ares/pkg-plist2
2 files changed, 10 insertions, 2 deletions
diff --git a/dns/c-ares/Makefile b/dns/c-ares/Makefile
index 23b30c5432a9..3912a0af31c6 100644
--- a/dns/c-ares/Makefile
+++ b/dns/c-ares/Makefile
@@ -7,6 +7,7 @@
PORTNAME= c-ares
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://daniel.haxx.se/projects/c-ares/
@@ -15,10 +16,15 @@ COMMENT= An asynchronous DNS resolver library
CONFLICTS= ares-1.*
-GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+SHLIB_VER= 1
+
+MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
+PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
+
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
+CONFIGURE_ARGS= --mandir=${PREFIX}/man --enable-shared
MAN3= ares_cancel.3 \
ares_destroy.3 \
diff --git a/dns/c-ares/pkg-plist b/dns/c-ares/pkg-plist
index 4f37c6b212a1..629325014cb1 100644
--- a/dns/c-ares/pkg-plist
+++ b/dns/c-ares/pkg-plist
@@ -2,3 +2,5 @@ include/ares.h
include/ares_version.h
lib/libcares.a
lib/libcares.la
+lib/libcares.so
+lib/libcares.so.%%SHLIB_VER%%