aboutsummaryrefslogtreecommitdiff
path: root/dns/ddclient
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-01-04 01:47:21 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-01-04 01:47:21 +0000
commita7e522e2abc8dcf1f698a0567a16c75de638995f (patch)
treeccaaec33643868914f17cccad3be165964e3c778 /dns/ddclient
parent26078a1ecdd9b100cef3a899e63c1bb3f4b6f6ef (diff)
downloadports-a7e522e2abc8dcf1f698a0567a16c75de638995f.tar.gz
ports-a7e522e2abc8dcf1f698a0567a16c75de638995f.zip
- Add SSL to OPTIONS
- Do not force the user to run ddclient as a daemon PR: ports/163271 Submitted by: Rob Farmer <rfarmer@predatorlabs.net> (maintainer)
Notes
Notes: svn path=/head/; revision=288491
Diffstat (limited to 'dns/ddclient')
-rw-r--r--dns/ddclient/Makefile13
-rw-r--r--dns/ddclient/files/ddclient.in5
2 files changed, 13 insertions, 5 deletions
diff --git a/dns/ddclient/Makefile b/dns/ddclient/Makefile
index ef76fbcbc863..d327f32153a9 100644
--- a/dns/ddclient/Makefile
+++ b/dns/ddclient/Makefile
@@ -7,16 +7,13 @@
PORTNAME= ddclient
PORTVERSION= 3.8.1
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= rfarmer@predatorlabs.net
COMMENT= Update dynamic DNS entries
-.ifndef WITHOUT_SSL
-RUN_DEPENDS= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
-.endif
-
LICENSE= GPLv2
USE_BZIP2= yes
@@ -24,6 +21,14 @@ USE_PERL5_RUN= yes
NO_BUILD= yes
USE_RC_SUBR= ${PORTNAME}
+OPTIONS= SSL "Enable SSL support" ON
+
+.include <bsd.port.options.mk>
+
+.ifndef WITHOUT_SSL
+RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
+.endif
+
SUB_FILES= pkg-message ddclient_force
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/dns/ddclient/files/ddclient.in b/dns/ddclient/files/ddclient.in
index e0080afc9f34..45711c32c364 100644
--- a/dns/ddclient/files/ddclient.in
+++ b/dns/ddclient/files/ddclient.in
@@ -10,6 +10,9 @@
#
# ddclient_enable="YES"
#
+# By default, ddclient does not daemonize. To launch ddclient
+# as a daemon, add the -daemon 300 argument to ddclient_flags
+#
. /etc/rc.subr
@@ -22,6 +25,6 @@ required_files="%%PREFIX%%/etc/${name}.conf"
load_rc_config ${name}
: ${ddclient_enable="NO"}
-: ${ddclient_flags="-daemon 300"}
+: ${ddclient_flags=""}
run_rc_command "$1"