aboutsummaryrefslogtreecommitdiff
path: root/dns/dnscap/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-08 18:51:44 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-08 18:51:44 +0000
commit4421e9d0ef2604170a803694f5729d0dd29ad14b (patch)
treed943089f0ba3a30e5a4250f014a68048347a0008 /dns/dnscap/Makefile
parentee6b72e5ab42286f06b549f4295e415adbebb74e (diff)
downloadports-4421e9d0ef2604170a803694f5729d0dd29ad14b.tar.gz
ports-4421e9d0ef2604170a803694f5729d0dd29ad14b.zip
Use GitHub source instead of upstream-packaged tarball
Notes
Notes: svn path=/head/; revision=461257
Diffstat (limited to 'dns/dnscap/Makefile')
-rw-r--r--dns/dnscap/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/dns/dnscap/Makefile b/dns/dnscap/Makefile
index 0fcac211e3c3..31425db6885f 100644
--- a/dns/dnscap/Makefile
+++ b/dns/dnscap/Makefile
@@ -3,10 +3,9 @@
PORTNAME= dnscap
PORTVERSION= 1.8.0
+DISTVERSIONPREFIX= v
PORTEPOCH= 1
CATEGORIES= dns
-MASTER_SITES= https://www.dns-oarc.net/files/dnscap/ \
- LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= DNS network traffic capture utility
@@ -20,14 +19,18 @@ OPTIONS_DEFAULT=THREADS
CONFIGURE_ARGS= --enable-shared --enable-static
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= libtool
+USES= autoreconf libtool
+
+GH_ACCOUNT= DNS-OARC
+GH_TUPLE= DNS-OARC:pcap-thread:v3.1.0:pcap/src/pcap-thread
+USE_GITHUB= yes
THREADS_CONFIGURE_ENABLE= threads
post-patch-DOCS-off:
- @${REINPLACE_CMD} -e '/^install-data-am: / s| install-dist_docDATA||' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^install-data-am: / s| install-dist_docDATA||' ${WRKSRC}/Makefile.am
post-patch-DOCS-on:
- @${REINPLACE_CMD} -e '/^dist_doc_DATA = / s| LICENSE||' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^dist_doc_DATA = / s| LICENSE||' ${WRKSRC}/Makefile.am
.include <bsd.port.mk>