aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsdbq
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2022-09-15 09:38:54 +0000
committerDon Lewis <truckman@FreeBSD.org>2022-09-15 22:35:56 +0000
commitd0664ff412f5dbe5e904ce65709b2691351bc09f (patch)
tree64ce5f1a2688786b30e5ab601a6144a1e360216a /dns/dnsdbq
parentde1d38148e826258e5138d600b2a68964c8f2b05 (diff)
downloadports-d0664ff412f5dbe5e904ce65709b2691351bc09f.tar.gz
ports-d0664ff412f5dbe5e904ce65709b2691351bc09f.zip
dns/dnsdbq: Upgrade to version 2.6.4
* 2.6.1 - use 'zu' format string in deduper_dump() (#196) - ctype.h functions require int arguments. cygwin gcc enforces this. Update version to 2.6.1 * 2.6.2 - fix three memory leaks revealed by valgrind (#202) - see if we can remove the need for res_rcode() by changing the error path (#200) - use strtok_r() in preference to strsep(), for consistency and modernity (#203) - based on PR 204, refactor and comment for clarity (#205) * 2.6.3 - replace strtok_r() by new tokstr library - tokstr_h was a typo, thanks to codereview.stackexchange.com for finding it - attempt to work around gcc11 structure size checks (#207) - tokstr regions (#208) - Revised fix for issue 209: "error: unknown type ssize_t; did you mean _ssize_t?" (#211) - Can now build on Apple M1 processors by following the instructions (#212) - Clarify that not all macOS M1 machines have homebrew in the new /opt/homebrew location - Document again the HTTPS_PROXY environment variable * 2.6.4 - Issue 214: batch option parsing bug in tokstr library changes. (#215) Sponsored by: DomainTools
Diffstat (limited to 'dns/dnsdbq')
-rw-r--r--dns/dnsdbq/Makefile2
-rw-r--r--dns/dnsdbq/distinfo6
-rw-r--r--dns/dnsdbq/files/patch-Makefile29
-rw-r--r--dns/dnsdbq/files/patch-deduper.c22
4 files changed, 18 insertions, 41 deletions
diff --git a/dns/dnsdbq/Makefile b/dns/dnsdbq/Makefile
index 49ca677b9360..42aa073874b0 100644
--- a/dns/dnsdbq/Makefile
+++ b/dns/dnsdbq/Makefile
@@ -1,5 +1,5 @@
PORTNAME= dnsdbq
-PORTVERSION= 2.6.0
+PORTVERSION= 2.6.4
DISTVERSIONPREFIX= v
CATEGORIES= dns
diff --git a/dns/dnsdbq/distinfo b/dns/dnsdbq/distinfo
index ef7f557a88e9..8713851b4875 100644
--- a/dns/dnsdbq/distinfo
+++ b/dns/dnsdbq/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1637446719
-SHA256 (dnsdb-dnsdbq-v2.6.0_GH0.tar.gz) = 517f8cce434f4974a80838cd643eb84af7a0d0c4a3df4e18bf6b01a047e9e137
-SIZE (dnsdb-dnsdbq-v2.6.0_GH0.tar.gz) = 57394
+TIMESTAMP = 1663227292
+SHA256 (dnsdb-dnsdbq-v2.6.4_GH0.tar.gz) = e9ab9cdee298de948ef501c3213da4b1d208645302007ba132c8c6b6c5732f71
+SIZE (dnsdb-dnsdbq-v2.6.4_GH0.tar.gz) = 59241
diff --git a/dns/dnsdbq/files/patch-Makefile b/dns/dnsdbq/files/patch-Makefile
index 2567f38f9ba1..22b2d985c996 100644
--- a/dns/dnsdbq/files/patch-Makefile
+++ b/dns/dnsdbq/files/patch-Makefile
@@ -1,28 +1,27 @@
---- Makefile.orig 2021-02-18 00:40:10 UTC
+--- Makefile.orig 2022-08-05 00:08:56 UTC
+++ Makefile
-@@ -15,10 +15,10 @@
+@@ -15,7 +15,7 @@
#
- CURLINCL = `curl-config --cflags`
--JANSINCL = -I/usr/local/include
-+JANSINCL = -I$(LOCALBASE)/include
+ # Base directory for jansson header and libraries
+-JANSBASE=/usr/local
++JANSBASE=$(LOCALBASE)
+ # For macOS on M1, use this instead of the above line:
+ #JANSBASE=/opt/homebrew
- CURLLIBS = `[ ! -z "$$(curl-config --libs)" ] && curl-config --libs || curl-config --static-libs`
--JANSLIBS = -L/usr/local/lib -ljansson
-+JANSLIBS = -L$(LOCALBASE)/lib -ljansson
-
- CWARN =-W -Wall -Wextra -Wcast-qual -Wpointer-arith -Wwrite-strings \
- -Wmissing-prototypes -Wbad-function-cast -Wnested-externs \
-@@ -34,7 +34,7 @@ CDEBUG = -g -O3
+@@ -41,9 +41,9 @@ INCL= $(CURLINCL) $(JANSINCL)
+ CDEBUG = -g -O3
CFLAGS += $(CGPROF) $(CDEBUG) $(CWARN) $(CDEFS)
INCL= $(CURLINCL) $(JANSINCL)
- # freebsd requires that -lresolv _not_ be used here
-LIBS= $(CURLLIBS) $(JANSLIBS) -lresolv
++#LIBS= $(CURLLIBS) $(JANSLIBS) -lresolv
+ # For freebsd, it requires that -lresolv _not_ be used here, use this instead of the above line:
+-#LIBS= $(CURLLIBS) $(JANSLIBS)
+LIBS= $(CURLLIBS) $(JANSLIBS)
- #LIBS= $(CURLLIBS) $(JANSLIBS)
TOOL = dnsdbq
-@@ -48,12 +48,12 @@ TOOL_SRC = $(TOOL).c ns_ttl.c netio.c \
+ TOOL_OBJ = $(TOOL).o ns_ttl.o netio.o \
+@@ -58,12 +58,12 @@ install: all
all: $(TOOL)
install: all
diff --git a/dns/dnsdbq/files/patch-deduper.c b/dns/dnsdbq/files/patch-deduper.c
deleted file mode 100644
index a7447683873f..000000000000
--- a/dns/dnsdbq/files/patch-deduper.c
+++ /dev/null
@@ -1,22 +0,0 @@
-commit cbe42ddcb4f4e2b55365cd1d9c13c589957ccb6e
-Author: Sascha Steinbiss <satta@users.noreply.github.com>
-Date: Tue Nov 2 19:18:31 2021 +0100
-
- use 'zu' format string in deduper_dump() (#196)
-
- The use of 'lu' to format a size_t leads to build failures (via -Werror)
- on many architectures.
-
-diff --git deduper.c.orig deduper.c
-index 5300aea..a06b13e 100644
---- deduper.c.orig
-+++ deduper.c
-@@ -87,7 +87,7 @@ void
- deduper_dump(deduper_t me, FILE *out) {
- for (size_t bucket = 0; bucket < me->buckets; bucket++)
- if (me->chains[bucket] != NULL) {
-- fprintf(out, "[%lu]", bucket);
-+ fprintf(out, "[%zu]", bucket);
- for (chainlink_t chainlink = me->chains[bucket];
- chainlink != NULL;
- chainlink = chainlink->next)