aboutsummaryrefslogtreecommitdiff
path: root/dns/knot
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-03-17 12:44:20 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-03-17 12:44:20 +0000
commit518b7ede95425d12ccb3c6a0c020cdac9830fc15 (patch)
treeb3fc7b7ad5b27491bac3de604da9b298356839c5 /dns/knot
parent20354a2ec089d17d169d4cf8c749a5950ab1c7bc (diff)
downloadports-518b7ede95425d12ccb3c6a0c020cdac9830fc15.tar.gz
ports-518b7ede95425d12ccb3c6a0c020cdac9830fc15.zip
- Final patch
- Add back cat pkg-message - Add knot.full.conf to ETCDIR and pkg-plist - Bump PORTREVISON PR: ports/165798 Submitted by: Leo Vandewoestijne <freebsd@dns-lab.com> (maintainer) Approved by: Leo Vandewoestijne <freebsd@dns-lab.com> (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=293455
Diffstat (limited to 'dns/knot')
-rw-r--r--dns/knot/Makefile3
-rw-r--r--dns/knot/files/pkg-message.in10
-rw-r--r--dns/knot/pkg-plist3
3 files changed, 8 insertions, 8 deletions
diff --git a/dns/knot/Makefile b/dns/knot/Makefile
index 14f3e99dffc0..ebee4f8bd0cc 100644
--- a/dns/knot/Makefile
+++ b/dns/knot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= knot
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= dns ipv6
MASTER_SITES= http://public.nic.cz/files/knot-dns/ \
http://www.dns-lab.com/downloads/knot-dns/
@@ -38,6 +39,7 @@ PORTDOCS= AUTHORS ChangeLog CodingStyle COPYING \
post-install:
@${MKDIR} ${ETCDIR}
@${INSTALL_DATA} ${WRKSRC}/samples/knot.min.conf ${ETCDIR}
+ @${INSTALL_DATA} ${WRKSRC}/samples/knot.full.conf ${ETCDIR}
@if [ ! -f ${ETCDIR}/knot.conf ]; then \
${INSTALL_DATA} ${ETCDIR}/knot.min.conf ${ETCDIR}/knot.conf; \
fi
@@ -45,5 +47,6 @@ post-install:
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
+ @${CAT} ${WRKDIR}/pkg-message
.include <bsd.port.mk>
diff --git a/dns/knot/files/pkg-message.in b/dns/knot/files/pkg-message.in
index 72e230f77333..b52bad6f7de0 100644
--- a/dns/knot/files/pkg-message.in
+++ b/dns/knot/files/pkg-message.in
@@ -5,14 +5,10 @@
#
# ----- configure --------------------------------------------------
#
- $EDITOR %%PREFIX%%/etc/knot/knot.conf
+ $EDITOR %%ETCDIR%%/knot.conf
#
# For all option have a look at the contents of
-# %%PREFIX%%/etc/knot/knot.sample.conf
-#
-# For example, under "system" you might like to add
-# user "bind.bind";
-# to not have knotd run as root/wheel
+# %%PREFIX%%/etc/knot/knot.full.conf
#
# ----- prepare ----------------------------------------------------
#
@@ -23,7 +19,7 @@
#
# ----- startup ----------------------------------------------------
#
- %%PREFIX%%/etc/rc.d/knot start
+ %%PREFIX%%/etc/rc.d/knotd start
#
####################################################################
diff --git a/dns/knot/pkg-plist b/dns/knot/pkg-plist
index 9c61f22454a2..84ec9bd1232b 100644
--- a/dns/knot/pkg-plist
+++ b/dns/knot/pkg-plist
@@ -2,9 +2,11 @@
@stopdaemon knotd
%%ETCDIR%%/example.com.zone
@unexec if cmp -s %B/knot.min.conf %B/knot.conf; then rm -f %B/knot.conf; fi
+%%ETCDIR%%/knot.full.conf
%%ETCDIR%%/knot.min.conf
@exec [ -f %B/knot.conf ] || cp %B/%f %B/knot.conf
%%ETCDIR%%/knot.sample.conf
+@dirrmtry %%ETCDIR%%
libexec/knot-zcompile
libexec/unittests
libexec/unittests-libknot
@@ -13,4 +15,3 @@ libexec/unittests-xfr
libexec/unittests-zcompile
sbin/knotc
sbin/knotd
-@dirrmtry %%ETCDIR%%