aboutsummaryrefslogtreecommitdiff
path: root/dns/libnspsl
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-11-21 14:04:24 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-11-21 14:04:24 +0000
commit57ffef978c063f0db8f9b63782c2b8c9335dac44 (patch)
tree180c5880b98c8ea13e05e7ea6f90e4d4353004c4 /dns/libnspsl
parent5166401e18f62a7c4707c2da0cacee0fc7428473 (diff)
downloadports-57ffef978c063f0db8f9b63782c2b8c9335dac44.tar.gz
ports-57ffef978c063f0db8f9b63782c2b8c9335dac44.zip
Library to generate static code representation of the Public suffix list.
The public suffix list is a database of top level domain names. The database allows an application to determine if if a domain name requires an additional label to be valid. The principle use in a web browser is to restrict supercookies being set although it can also serve secondary purposes in the UI such as domain highlighting. WWW: http://www.netsurf-browser.org/
Notes
Notes: svn path=/head/; revision=426720
Diffstat (limited to 'dns/libnspsl')
-rw-r--r--dns/libnspsl/Makefile29
-rw-r--r--dns/libnspsl/distinfo3
-rw-r--r--dns/libnspsl/files/patch-Makefile13
-rw-r--r--dns/libnspsl/files/patch-libnspsl.pc.in10
-rw-r--r--dns/libnspsl/pkg-descr10
-rw-r--r--dns/libnspsl/pkg-plist5
6 files changed, 70 insertions, 0 deletions
diff --git a/dns/libnspsl/Makefile b/dns/libnspsl/Makefile
new file mode 100644
index 000000000000..8fd32eade583
--- /dev/null
+++ b/dns/libnspsl/Makefile
@@ -0,0 +1,29 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= libnspsl
+PORTVERSION= 0.1.0
+CATEGORIES= dns
+MASTER_SITES= http://download.netsurf-browser.org/libs/releases/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= NetSurf public suffix list handling
+
+LICENSE= MIT
+
+BUILD_DEPENDS= netsurf-buildsystem>=1.5:devel/netsurf-buildsystem
+
+USES= gmake
+USE_LDCONFIG= yes
+
+MAKE_ENV+= COMPONENT_TYPE="lib-shared"
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
+
+PLIST_SUB+= VERSION=${PORTVERSION}
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libnspsl.so*
+
+.include <bsd.port.mk>
diff --git a/dns/libnspsl/distinfo b/dns/libnspsl/distinfo
new file mode 100644
index 000000000000..ecf8e29494be
--- /dev/null
+++ b/dns/libnspsl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1479721220
+SHA256 (libnspsl-0.1.0-src.tar.gz) = be9030bdffa4135e95861465201e43f18f2cbba24555952aed7fa59b99ce6e74
+SIZE (libnspsl-0.1.0-src.tar.gz) = 299718
diff --git a/dns/libnspsl/files/patch-Makefile b/dns/libnspsl/files/patch-Makefile
new file mode 100644
index 000000000000..80c2236b11fd
--- /dev/null
+++ b/dns/libnspsl/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2016-11-19 10:09:21 UTC
++++ Makefile
+@@ -44,8 +44,8 @@ include $(NSBUILD)/Makefile.top
+ # Extra installation rules
+ I := /$(INCLUDEDIR)
+ INSTALL_ITEMS := $(INSTALL_ITEMS) $(I):include/nspsl.h
+-INSTALL_ITEMS := $(INSTALL_ITEMS) /$(LIBDIR)/pkgconfig:lib$(COMPONENT).pc.in
+-INSTALL_ITEMS := $(INSTALL_ITEMS) /$(LIBDIR):$(OUTPUT)
++INSTALL_ITEMS := $(INSTALL_ITEMS) /libdata/pkgconfig:lib$(COMPONENT).pc.in
++INSTALL_ITEMS := $(INSTALL_ITEMS) /lib:$(OUTPUT)
+
+ # obtain public suffix list database from upstream
+ public_suffix_list.dat:
diff --git a/dns/libnspsl/files/patch-libnspsl.pc.in b/dns/libnspsl/files/patch-libnspsl.pc.in
new file mode 100644
index 000000000000..3ea919a0ba9b
--- /dev/null
+++ b/dns/libnspsl/files/patch-libnspsl.pc.in
@@ -0,0 +1,10 @@
+--- libnspsl.pc.in.orig 2016-11-19 10:09:21 UTC
++++ libnspsl.pc.in
+@@ -1,6 +1,6 @@
+ prefix=PREFIX
+ exec_prefix=${prefix}
+-libdir=${exec_prefix}/LIBDIR
++libdir=${exec_prefix}/lib
+ includedir=${prefix}/INCLUDEDIR
+
+ Name: libnspsl
diff --git a/dns/libnspsl/pkg-descr b/dns/libnspsl/pkg-descr
new file mode 100644
index 000000000000..351ace8d6464
--- /dev/null
+++ b/dns/libnspsl/pkg-descr
@@ -0,0 +1,10 @@
+Library to generate static code representation of the Public suffix list.
+The public suffix list is a database of top level domain names. The database
+allows an application to determine if if a domain name requires an additional
+label to be valid.
+
+The principle use in a web browser is to restrict supercookies being set
+although it can also serve secondary purposes in the UI such as domain
+highlighting.
+
+WWW: http://www.netsurf-browser.org/
diff --git a/dns/libnspsl/pkg-plist b/dns/libnspsl/pkg-plist
new file mode 100644
index 000000000000..63c59282a5b4
--- /dev/null
+++ b/dns/libnspsl/pkg-plist
@@ -0,0 +1,5 @@
+include/nspsl.h
+lib/libnspsl.so
+lib/libnspsl.so.0
+lib/libnspsl.so.%%VERSION%%
+libdata/pkgconfig/libnspsl.pc