aboutsummaryrefslogtreecommitdiff
path: root/dns/mydns-ng/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2009-03-29 11:56:20 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2009-03-29 11:56:20 +0000
commitd46356e7f4afe4b380da37932d4a0315f451084c (patch)
tree631fa69e02019a7d89d694a28e931fa70f27e96f /dns/mydns-ng/Makefile
parent5cee286b76787e0788da143519547b2978b1aa0e (diff)
downloadports-d46356e7f4afe4b380da37932d4a0315f451084c.tar.gz
ports-d46356e7f4afe4b380da37932d4a0315f451084c.zip
- Add MyDNS-ng, a Next Generation DNS Server for sql based DNS services
PR: ports/132963 Submitted by: Hung-Yi Chen <gaod AT hychen.org>
Notes
Notes: svn path=/head/; revision=231241
Diffstat (limited to 'dns/mydns-ng/Makefile')
-rw-r--r--dns/mydns-ng/Makefile42
1 files changed, 21 insertions, 21 deletions
diff --git a/dns/mydns-ng/Makefile b/dns/mydns-ng/Makefile
index d4d5f7a51059..d20d03dee3a4 100644
--- a/dns/mydns-ng/Makefile
+++ b/dns/mydns-ng/Makefile
@@ -5,21 +5,22 @@
# $FreeBSD$
#
-PORTNAME= mydns
-PORTVERSION= 1.1.0
-PORTREVISION= 3
+PORTNAME= mydns-ng
+PORTVERSION= 1.2.8.27
CATEGORIES= dns databases
-MASTER_SITES= http://mydns.bboy.net/download/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= mydns-ng
+DISTNAME= mydns-${PORTVERSION}
-MAINTAINER= ale@FreeBSD.org
-COMMENT= DNS server designed to utilize the MySQL database
+MAINTAINER= gaod@hychen.org
+COMMENT= A Next Generation DNS Server for sql based DNS services
+WRKSRC= ${WRKDIR}/mydns-${PORTVERSION:R}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc
USE_ICONV= yes
-USE_BZIP2= yes
-USE_RC_SUBR= mydns.sh
+USE_RC_SUBR= mydns
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -30,12 +31,19 @@ MAN8= mydns.8 mydnscheck.8 mydnsexport.8 mydnsimport.8 mydnsptrconvert.8 mydns-
DOCS= AUTHORS COPYING ChangeLog NEWS QUICKSTART.mysql QUICKSTART.postgres README TODO
+OPTIONS= PGSQL "Build with PostgreSQL backend instead of MySQL" OFF \
+ ALIAS "Enable server side aliases" ON \
+ OPENSSL "Enable OpenSSL (if MySQL is linked with OpenSSL)" OFF \
+ NLS "Native Language Support with gettext" OFF
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_ALIAS)
CONFIGURE_ARGS+=--enable-alias
.endif
.if defined(WITH_OPENSSL)
-USE_OPENSSL= yes
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+=--with-openssl \
--with-openssl-include=${OPENSSLINC} \
--with-openssl-lib=${OPENSSLLIB}
@@ -46,7 +54,7 @@ USE_PGSQL= yes
CONFIGURE_ARGS+=--without-mysql \
--with-pgsql-include=${LOCALBASE}/include \
--with-pgsql-lib=${LOCALBASE}/lib
-PKGNAMESUFFIX= -pg
+PKGNAMESUFFIX= -pgsql
.else
CONFIGURE_ARGS+=--without-pgsql \
--with-mysql-include=${LOCALBASE}/include/mysql \
@@ -55,7 +63,8 @@ PKGNAMESUFFIX= -mysql
USE_MYSQL= yes
.endif
-.if !defined(WITHOUT_NLS)
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--with-included-gettext
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -63,15 +72,6 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-pre-fetch:
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_PGSQL=yes Build with PostgreSQL support"
- @${ECHO} " WITH_ALIAS=yes Enable server side aliases"
- @${ECHO} " WITH_OPENSSL=yes Enable OpenSSL (needed if MySQL is linked with OpenSSL)"
- @${ECHO} ""
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/contrib
@@ -86,4 +86,4 @@ post-install:
@${PREFIX}/sbin/mydns --dump-config >${PREFIX}/etc/mydns.conf.sample
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>