aboutsummaryrefslogtreecommitdiff
path: root/dns/mydns/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-08-21 16:41:12 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-08-21 16:41:12 +0000
commit6554b6934a233b14434b62233920df7ddf0906af (patch)
treeb535522ded385791fa57a83ed460bc1467aa2788 /dns/mydns/Makefile
parent411e705cb2bf1c01f0eb60c437ba210eaac5a2f2 (diff)
downloadports-6554b6934a233b14434b62233920df7ddf0906af.tar.gz
ports-6554b6934a233b14434b62233920df7ddf0906af.zip
Update to 0.9.13
PR: 55083 Submitted by: Alex Dupre <sysadmin@alexdupre.com> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=87456
Diffstat (limited to 'dns/mydns/Makefile')
-rw-r--r--dns/mydns/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/dns/mydns/Makefile b/dns/mydns/Makefile
index a7a3478443ad..05a1d5c16f7d 100644
--- a/dns/mydns/Makefile
+++ b/dns/mydns/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= mydns
-PORTVERSION= 0.9.10
-PORTREVISION= 1
+PORTVERSION= 0.9.13
+PORTREVISION= 0
CATEGORIES= net databases
MASTER_SITES= http://mydns.bboy.net/download/
@@ -23,10 +23,11 @@ USE_LIBTOOL= yes
USE_BZIP2= yes
USE_REINPLACE= yes
+INFO= mydns
MAN5= mydns.conf.5
-MAN8= mydns.8 mydnscheck.8 mydnsexport.8 mydnsimport.8
+MAN8= mydns.8 mydnscheck.8 mydnsexport.8 mydnsimport.8 mydns-conf.8
-DOCS= AUTHORS COPYING ChangeLog NEWS QUICKSTART README TODO
+DOCS= AUTHORS COPYING ChangeLog NEWS QUICKSTART.mysql QUICKSTART.postgres README TODO
.include <bsd.port.pre.mk>
@@ -39,6 +40,8 @@ CONFIGURE_ARGS+=--without-pgsql
PKGNAMESUFFIX= -mysql
.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.10)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+.elif exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.14)
+LIB_DEPENDS+= mysqlclient.14:${PORTSDIR}/databases/mysql41-client
.else
LIB_DEPENDS+= mysqlclient.12:${PORTSDIR}/databases/mysql40-client
.endif
@@ -53,7 +56,7 @@ post-install:
.for f in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
.endfor
- @${INSTALL_DATA} ${WRKSRC}/contrib/admin.php ${DOCSDIR}/contrib/
+ @${INSTALL_DATA} ${WRKSRC}/contrib/*.php ${DOCSDIR}/contrib/
@${INSTALL_DATA} ${WRKSRC}/contrib/README ${DOCSDIR}/contrib/
.endif
@${PREFIX}/sbin/mydns --dump-config >${PREFIX}/etc/mydns.conf.sample