aboutsummaryrefslogtreecommitdiff
path: root/dns/mydns/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-17 10:00:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-17 10:00:16 +0000
commitba89762e0ab6da2e5cbd0fce4d87f7d43746e58c (patch)
treec4ae3a6f9210743ac5035d2cc1c42ddbe4dfa7c4 /dns/mydns/Makefile
parent929cb938af926f9819d46d51ed92a332c26d04dc (diff)
downloadports-ba89762e0ab6da2e5cbd0fce4d87f7d43746e58c.tar.gz
ports-ba89762e0ab6da2e5cbd0fce4d87f7d43746e58c.zip
- Update to 0.10.1
- Give maintainership to submitter PR: ports/60289 Submitted by: Alex Dupre <sysadmin@alexdupre.com> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=96032
Diffstat (limited to 'dns/mydns/Makefile')
-rw-r--r--dns/mydns/Makefile21
1 files changed, 6 insertions, 15 deletions
diff --git a/dns/mydns/Makefile b/dns/mydns/Makefile
index 538a9eeb493a..b4c9918403bb 100644
--- a/dns/mydns/Makefile
+++ b/dns/mydns/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= mydns
-PORTVERSION= 0.10.0
-PORTREVISION= 3
+PORTVERSION= 0.10.1
CATEGORIES= dns databases
MASTER_SITES= http://mydns.bboy.net/download/
-MAINTAINER= simond@irrelevant.org
+MAINTAINER= sysadmin@alexdupre.com
COMMENT= DNS server designed to utilize the MySQL database
LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
@@ -28,8 +27,6 @@ MAN8= mydns.8 mydnscheck.8 mydnsexport.8 mydnsimport.8 mydns-conf.8
DOCS= AUTHORS COPYING ChangeLog NEWS QUICKSTART.mysql QUICKSTART.postgres README TODO
-.include <bsd.port.pre.mk>
-
.if defined (WITH_ALIAS)
CONFIGURE_ARGS+=--enable-alias
.endif
@@ -39,19 +36,13 @@ CONFIGURE_ARGS+=--with-openssl
.endif
.if defined (WITH_PGSQL)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql-client
CONFIGURE_ARGS+=--without-mysql
PKGNAMESUFFIX= -pg
.else
CONFIGURE_ARGS+=--without-pgsql
PKGNAMESUFFIX= -mysql
-.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.10)
-LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-.elif exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.14)
-LIB_DEPENDS+= mysqlclient.14:${PORTSDIR}/databases/mysql41-client
-.else
-LIB_DEPENDS+= mysqlclient.12:${PORTSDIR}/databases/mysql40-client
-.endif
+USE_MYSQL= yes
.endif
pre-fetch:
@@ -60,7 +51,7 @@ pre-fetch:
@${ECHO} ""
@${ECHO} " WITH_PGSQL=yes Build with PostgreSQL support"
@${ECHO} " WITH_ALIAS=yes Enable server side aliases"
- @${ECHO} " WITH_OPENSSL=yes Enable OpenSSL (needed if MySQL is linked with OpenSSL"
+ @${ECHO} " WITH_OPENSSL=yes Enable OpenSSL (needed if MySQL is linked with OpenSSL)"
@${ECHO} ""
post-install:
@@ -78,4 +69,4 @@ post-install:
@${PREFIX}/sbin/mydns --dump-config >${PREFIX}/etc/mydns.conf.sample
@${SED} -e 's,%%%PREFIX%%%,${PREFIX},g' ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>