aboutsummaryrefslogtreecommitdiff
path: root/dns/noip
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2009-11-17 20:56:28 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2009-11-17 20:56:28 +0000
commitbfcec71ece7e7e68f13c1d68b97c569e8fec76c1 (patch)
tree7b9f94d66d742acadb661509b058f3851bd0536e /dns/noip
parent20ab0348978c9607289fb0afbc35a204dcb1155e (diff)
downloadports-bfcec71ece7e7e68f13c1d68b97c569e8fec76c1.tar.gz
ports-bfcec71ece7e7e68f13c1d68b97c569e8fec76c1.zip
- Update to 2.1.9
- Take maintainership PR: 140643 Approved by: kay.abendroth@raxion.net (maintainer)
Notes
Notes: svn path=/head/; revision=244401
Diffstat (limited to 'dns/noip')
-rw-r--r--dns/noip/Makefile8
-rw-r--r--dns/noip/distinfo6
-rw-r--r--dns/noip/files/patch-Makefile36
-rw-r--r--dns/noip/files/patch-noip2.c27
4 files changed, 40 insertions, 37 deletions
diff --git a/dns/noip/Makefile b/dns/noip/Makefile
index 347dcc69ba12..2bc6087fb79b 100644
--- a/dns/noip/Makefile
+++ b/dns/noip/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= noip
-PORTVERSION= 2.1.7
-PORTREVISION= 2
+PORTVERSION= 2.1.9
CATEGORIES= dns
-MASTER_SITES= http://www.no-ip.com/client/linux/
+MASTER_SITES= http://www.no-ip.com/client/linux/ \
+ CRITICAL
-MAINTAINER= kay.abendroth@raxion.net
+MAINTAINER= ehaupt@FreeBSD.org
COMMENT= No-IP.com's dynamic DNS update client
ALL_TARGET= noip2
diff --git a/dns/noip/distinfo b/dns/noip/distinfo
index 20cb1e887d4e..7a2ce7ea7a51 100644
--- a/dns/noip/distinfo
+++ b/dns/noip/distinfo
@@ -1,3 +1,3 @@
-MD5 (noip-2.1.7.tar.gz) = 7b6b64c08708c2b147c375dda074a8dc
-SHA256 (noip-2.1.7.tar.gz) = 1105a23cb0a957c4b1e7c47bd9bfed00f1a089bdddd2a69f69bf4f8047f7a237
-SIZE (noip-2.1.7.tar.gz) = 147640
+MD5 (noip-2.1.9.tar.gz) = eed8e9ef9edfb7ddc36e187de867fe64
+SHA256 (noip-2.1.9.tar.gz) = 86ad0a6362263a33f59a658d1b1ce428e255556ddad0d062aa0ee4b7f412f98a
+SIZE (noip-2.1.9.tar.gz) = 152995
diff --git a/dns/noip/files/patch-Makefile b/dns/noip/files/patch-Makefile
index 6e2a312f68e3..e1b1c0917eb3 100644
--- a/dns/noip/files/patch-Makefile
+++ b/dns/noip/files/patch-Makefile
@@ -1,31 +1,31 @@
---- Makefile.orig 2007-08-11 20:35:34.000000000 +0200
-+++ Makefile 2007-12-24 12:18:38.000000000 +0100
-@@ -1,13 +1,13 @@
+--- Makefile.orig 2009-11-17 20:19:54.000000000 +0100
++++ Makefile 2009-11-17 20:22:51.000000000 +0100
+@@ -1,8 +1,8 @@
TGT=noip2
-CC=gcc
-+MYCC=${CC}
++CC?=gcc
+ PKG=noip-2.1.tgz
-PREFIX=/usr/local
--CONFDIR=${PREFIX}/etc
--BINDIR=${PREFIX}/bin
-+MYPREFIX=${PREFIX}
-+MYCONFDIR=${PREFIX}/etc
-+MYBINDIR=${PREFIX}/bin
++PREFIX?=/usr/local
+ CONFDIR=${PREFIX}/etc
+ BINDIR=${PREFIX}/bin
- # these defines are for Linux
--LIBS=
--ARCH=linux
-+#LIBS=
-+#ARCH=linux
+@@ -11,7 +11,7 @@
+ ARCH=linux
# for Mac OS X and BSD systems that have getifaddr(), uncomment the next line
- #ARCH=bsd_with_getifaddrs
-@@ -21,7 +21,7 @@
+-#ARCH=bsd_with_getifaddrs
++ARCH=bsd_with_getifaddrs
+
+ # for early BSD systems without getifaddrs(), uncomment the next line
+ #ARCH=bsd
+@@ -22,7 +22,7 @@
# ARCH=sun
${TGT}: Makefile ${TGT}.c
-- ${CC} -Wall -g -O2 -D${ARCH} -DPREFIX=\"${PREFIX}\" ${TGT}.c -o ${TGT} ${LIBS}
-+ ${MYCC} ${CFLAGS} -Dbsd_with_getifaddrs -DPREFIX=\"${MYPREFIX}\" ${TGT}.c -o ${TGT} ${LIBS}
+- ${CC} -Wall -g -D${ARCH} -DPREFIX=\"${PREFIX}\" ${TGT}.c -o ${TGT} ${LIBS}
++ ${CC} -Wall -D${ARCH} -DPREFIX=\"${PREFIX}\" ${TGT}.c -o ${TGT} ${LIBS}
install: ${TGT}
if [ ! -d ${BINDIR} ]; then mkdir -p ${BINDIR};fi
diff --git a/dns/noip/files/patch-noip2.c b/dns/noip/files/patch-noip2.c
index ad0fe024bb59..62399450912a 100644
--- a/dns/noip/files/patch-noip2.c
+++ b/dns/noip/files/patch-noip2.c
@@ -1,15 +1,15 @@
---- noip2.c.orig 2007-08-27 23:54:19.000000000 +0200
-+++ noip2.c 2007-12-24 12:25:18.000000000 +0100
-@@ -185,7 +185,7 @@
+--- noip2.c.orig 2009-11-17 20:23:40.000000000 +0100
++++ noip2.c 2009-11-17 20:27:45.000000000 +0100
+@@ -198,7 +198,7 @@
#define CLIENT_IP_PORT 8245
- #define VERSION "2.1.7"
+ #define VERSION "2.1.9"
-#define USER_AGENT "User-Agent: Linux-DUC/"VERSION
+#define USER_AGENT "User-Agent: FreeBSD-DUC/"VERSION
#define SETTING_SCRIPT "settings.php?"
#define USTRNG "username="
#define PWDSTRNG "&pass="
-@@ -292,7 +292,7 @@
+@@ -308,7 +308,7 @@
#define CMSG21 "Please select the Internet interface from this list.\n"
#define CMSG22 "By typing the number associated with it."
#define CMSG23 "Too many network devices. Limit is %d"
@@ -18,7 +18,7 @@
#define CMSG25 "Can't create config file (%s)"
#define CMSG25a "Re-run noip, adding '-c configfilename' as a parameter."
#define CMSG26 "Can't rename config file (%s)"
-@@ -502,7 +502,7 @@
+@@ -525,7 +525,7 @@
fprintf(stderr, "[ -d][ -D pid]");
#endif
fprintf(stderr, "[ -i addr][ -S][ -M][ -h]");
@@ -27,7 +27,7 @@
fprintf(stderr, "Options: -C create configuration data\n");
fprintf(stderr, " -F force NAT off\n");
fprintf(stderr, " -Y select all hosts/groups\n");
-@@ -2119,17 +2119,12 @@
+@@ -2316,17 +2316,14 @@
dq = (unsigned char *)devs; // point at name list
for (ifa = ifap; ifa; ifa = ifa->ifa_next) {
if (ifa->ifa_addr->sa_family == AF_LINK) {
@@ -40,12 +40,15 @@
- || ifd->ifi_type == IFT_BRIDGE
- || ifd->ifi_type == IFT_OTHER
- || ifd->ifi_type == IFT_GIF)
-+ if (ifd->ifi_type == IFT_OTHER
-+ || ifd->ifi_type == IFT_GIF
-+ || ifd->ifi_type == IFT_LOOP
-+ || ifd->ifi_type == IFT_FAITH)
- continue;
+- continue;
-#endif
++
++ if (ifd->ifi_type == IFT_OTHER
++ || ifd->ifi_type == IFT_GIF
++ || ifd->ifi_type == IFT_LOOP
++ || ifd->ifi_type == IFT_FAITH)
++ continue;
++
q = dq; // add new name into list
p = ifa->ifa_name;
devnum++;