aboutsummaryrefslogtreecommitdiff
path: root/dns/nsd
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2017-04-29 20:39:23 +0000
committerKurt Jaeger <pi@FreeBSD.org>2017-04-29 20:39:23 +0000
commit4206804e2c2bfbc7b56b28db3273a87a45e8b858 (patch)
treee196c9abf2c35386e58a9b81a54b6fcc772bc67b /dns/nsd
parent834171938d96496c56fa045d95d30be173ebd38d (diff)
downloadports-4206804e2c2bfbc7b56b28db3273a87a45e8b858.tar.gz
ports-4206804e2c2bfbc7b56b28db3273a87a45e8b858.zip
dns/nsd: update 4.1.15 -> 4.1.16
features: - zone parser can parse acronyms for algorithms ED25519 and ED448. - Fix 1243: Option to make NSD emit really minimal responses, minimal-responses: yes in nsd.conf. bug fixes: - Calculate new udb index after growing the array, fix from Chaofeng Liu. - Fix missing _t to _type conversion for disable-radix-tree option. - Printout serial error with hint it may be too big. - Fix 1228: OpenSSL include is not guarded with HAVE_SSL - Patch for expire state in multi-master when masters includes broken master, from Manabu Sonoda. - minor manpage fix. PR: 218873 Submitted by: jaap@NLnetLabs.nl (maintainer)
Notes
Notes: svn path=/head/; revision=439774
Diffstat (limited to 'dns/nsd')
-rw-r--r--dns/nsd/Makefile2
-rw-r--r--dns/nsd/distinfo6
-rw-r--r--dns/nsd/files/patch-query.c20
3 files changed, 4 insertions, 24 deletions
diff --git a/dns/nsd/Makefile b/dns/nsd/Makefile
index 40bf7f1591e7..82f7ffa26201 100644
--- a/dns/nsd/Makefile
+++ b/dns/nsd/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nsd
-PORTVERSION= 4.1.15
+PORTVERSION= 4.1.16
CATEGORIES= dns ipv6
MASTER_SITES= http://www.nlnetlabs.nl/downloads/nsd/ \
ftp://ftp.rhnet.is/pub/nsd/
diff --git a/dns/nsd/distinfo b/dns/nsd/distinfo
index 5d6de1e02c9c..db702dde0309 100644
--- a/dns/nsd/distinfo
+++ b/dns/nsd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1487325750
-SHA256 (nsd-4.1.15.tar.gz) = 494a862cfcd26a525a4bf06306eb7ab0387b34678ac6d37767507438e3a23a4b
-SIZE (nsd-4.1.15.tar.gz) = 1087383
+TIMESTAMP = 1493107885
+SHA256 (nsd-4.1.16.tar.gz) = 7f8367ad23cc5cddffa885e7e2f549123c8b4123db9726df41d99f255d6baab2
+SIZE (nsd-4.1.16.tar.gz) = 1088633
diff --git a/dns/nsd/files/patch-query.c b/dns/nsd/files/patch-query.c
deleted file mode 100644
index 467aea23c4b2..000000000000
--- a/dns/nsd/files/patch-query.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- query.c.orig 2017-03-09 14:53:32 UTC
-+++ query.c
-@@ -664,7 +664,7 @@ add_additional_rrsets(struct query *quer
- temp->rnode = NULL;
- temp->dname = additional->dname;
- #else
-- memcpy(&temp->node, &additional->node, sizeof(rbnode_t));
-+ memcpy(&temp->node, &additional->node, sizeof(rbnode_type));
- temp->node.parent = NULL;
- #endif
- temp->number = additional->number;
-@@ -1113,7 +1113,7 @@ answer_authoritative(struct nsd *nsd,
- match->rnode = NULL;
- match->dname = wildcard_child->dname;
- #else
-- memcpy(&match->node, &wildcard_child->node, sizeof(rbnode_t));
-+ memcpy(&match->node, &wildcard_child->node, sizeof(rbnode_type));
- match->node.parent = NULL;
- #endif
- match->parent = closest_encloser;