aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-Net-DNS/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-07-19 16:36:24 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-07-19 16:36:24 +0000
commitd0eef3a2f275f07b2a65a91de0b43757e230b7cc (patch)
treedf13300e6ac00f2d15f7227679996d090b8623f4 /dns/p5-Net-DNS/Makefile
parent02c9b71743ac99c4dec1346688fcae5cc9f3242e (diff)
downloadports-d0eef3a2f275f07b2a65a91de0b43757e230b7cc.tar.gz
ports-d0eef3a2f275f07b2a65a91de0b43757e230b7cc.zip
- Update to 1.01
- Update LICENSE - Update *_DEPENDS - Add GOST options - Add NO_ARCH Changes: http://search.cpan.org/dist/Net-DNS/Changes
Notes
Notes: svn path=/head/; revision=392514
Diffstat (limited to 'dns/p5-Net-DNS/Makefile')
-rw-r--r--dns/p5-Net-DNS/Makefile30
1 files changed, 15 insertions, 15 deletions
diff --git a/dns/p5-Net-DNS/Makefile b/dns/p5-Net-DNS/Makefile
index 9641967c1774..027fe371bfb0 100644
--- a/dns/p5-Net-DNS/Makefile
+++ b/dns/p5-Net-DNS/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= Net-DNS
-PORTVERSION= 0.83
-PORTREVISION= 1
+PORTVERSION= 1.01
CATEGORIES= dns net perl5 ipv6
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,29 +10,30 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 interface to the DNS resolver, and dynamic updates
-LICENSE= ART10 GPLv1
-LICENSE_COMB= dual
+LICENSE= MIT
-BUILD_DEPENDS= p5-Digest-HMAC>=1.01:${PORTSDIR}/security/p5-Digest-HMAC
+BUILD_DEPENDS= p5-Digest-HMAC>=1.03:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-MIME-Base32>=1.01:${PORTSDIR}/converters/p5-MIME-Base32
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Digest-BubbleBabble>=0:${PORTSDIR}/security/p5-Digest-BubbleBabble \
p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod
-OPTIONS_DEFINE= IDN IPV6 SSHFP
+OPTIONS_DEFINE= GOST IDN IPV6 SSHFP
+GOST_DESC= GOST support
SSHFP_DESC= SSH2 Fingerprint support
CONFIGURE_ARGS= --no-IPv6-tests --no-online-tests
+NO_ARCH= yes
USES= perl5
USE_PERL5= configure
-IDN_BUILD_DEPENDS= p5-Net-LibIDN>=0:${PORTSDIR}/dns/p5-Net-LibIDN
-IDN_RUN_DEPENDS= p5-Net-LibIDN>=0:${PORTSDIR}/dns/p5-Net-LibIDN
-IPV6_BUILD_DEPENDS= p5-IO-Socket-INET6>=0:${PORTSDIR}/net/p5-IO-Socket-INET6
-IPV6_RUN_DEPENDS= p5-IO-Socket-INET6>=0:${PORTSDIR}/net/p5-IO-Socket-INET6
-SSHFP_BUILD_DEPENDS= p5-Digest-BubbleBabble>=0:${PORTSDIR}/security/p5-Digest-BubbleBabble
-SSHFP_RUN_DEPENDS= p5-Digest-BubbleBabble>=0:${PORTSDIR}/security/p5-Digest-BubbleBabble
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Net/DNS/DNS.so
+GOST_BUILD_DEPENDS= p5-Digest-GOST>=0.06:${PORTSDIR}/security/p5-Digest-GOST
+GOST_RUN_DEPENDS= p5-Digest-GOST>=0.06:${PORTSDIR}/security/p5-Digest-GOST
+IDN_BUILD_DEPENDS= p5-Net-LibIDN>=0.12:${PORTSDIR}/dns/p5-Net-LibIDN
+IDN_RUN_DEPENDS= p5-Net-LibIDN>=0.12:${PORTSDIR}/dns/p5-Net-LibIDN
+IPV6_BUILD_DEPENDS= p5-IO-Socket-INET6>=2.01:${PORTSDIR}/net/p5-IO-Socket-INET6
+IPV6_RUN_DEPENDS= p5-IO-Socket-INET6>=2.01:${PORTSDIR}/net/p5-IO-Socket-INET6
+SSHFP_BUILD_DEPENDS= p5-Digest-BubbleBabble>=0.01:${PORTSDIR}/security/p5-Digest-BubbleBabble
+SSHFP_RUN_DEPENDS= p5-Digest-BubbleBabble>=0.01:${PORTSDIR}/security/p5-Digest-BubbleBabble
.include <bsd.port.mk>