aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-POE-Component-Client-DNS-Recursive
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-02-29 04:41:15 +0000
committerSteve Wills <swills@FreeBSD.org>2012-02-29 04:41:15 +0000
commit4db0639e545eb1414284a7732b53d95dd94b32b8 (patch)
treef2b68278131b32bfe4eb9b865cba54858fbb9e44 /dns/p5-POE-Component-Client-DNS-Recursive
parent67f976393558dfef28afe7615233d7fccf97e541 (diff)
downloadports-4db0639e545eb1414284a7732b53d95dd94b32b8.tar.gz
ports-4db0639e545eb1414284a7732b53d95dd94b32b8.zip
A recursive DNS client for POE
Notes
Notes: svn path=/head/; revision=292415
Diffstat (limited to 'dns/p5-POE-Component-Client-DNS-Recursive')
-rw-r--r--dns/p5-POE-Component-Client-DNS-Recursive/Makefile27
-rw-r--r--dns/p5-POE-Component-Client-DNS-Recursive/distinfo2
-rw-r--r--dns/p5-POE-Component-Client-DNS-Recursive/pkg-descr3
-rw-r--r--dns/p5-POE-Component-Client-DNS-Recursive/pkg-plist7
4 files changed, 39 insertions, 0 deletions
diff --git a/dns/p5-POE-Component-Client-DNS-Recursive/Makefile b/dns/p5-POE-Component-Client-DNS-Recursive/Makefile
new file mode 100644
index 000000000000..feda0c8681a9
--- /dev/null
+++ b/dns/p5-POE-Component-Client-DNS-Recursive/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-POE-Component-Client-DNS-Recursive
+# Date created: 2012-02-28
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Client-DNS-Recursive
+PORTVERSION= 1.02
+CATEGORIES= dns perl5
+MASTER_SITES= CPAN
+#MASTER_SITE_SUBDIR= CPAN:BINGOS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A recursive DNS client for POE
+
+BUILD_DEPENDS= p5-POE>=1.004:${PORTSDIR}/devel/p5-POE \
+ p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-Net-IP-Minimal>=0:${PORTSDIR}/net/p5-Net-IP-Minimal
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Client::DNS::Recursive.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-POE-Component-Client-DNS-Recursive/distinfo b/dns/p5-POE-Component-Client-DNS-Recursive/distinfo
new file mode 100644
index 000000000000..468392f67200
--- /dev/null
+++ b/dns/p5-POE-Component-Client-DNS-Recursive/distinfo
@@ -0,0 +1,2 @@
+SHA256 (POE-Component-Client-DNS-Recursive-1.02.tar.gz) = 35bf9a4e317afd7faab93ec29e18f350cc4baaeaf2ebbbcd744105a7b4bb162c
+SIZE (POE-Component-Client-DNS-Recursive-1.02.tar.gz) = 17057
diff --git a/dns/p5-POE-Component-Client-DNS-Recursive/pkg-descr b/dns/p5-POE-Component-Client-DNS-Recursive/pkg-descr
new file mode 100644
index 000000000000..afb854be0762
--- /dev/null
+++ b/dns/p5-POE-Component-Client-DNS-Recursive/pkg-descr
@@ -0,0 +1,3 @@
+A recursive DNS client for POE
+
+WWW: http://search.cpan.org/dist/POE-Component-Client-DNS-Recursive/
diff --git a/dns/p5-POE-Component-Client-DNS-Recursive/pkg-plist b/dns/p5-POE-Component-Client-DNS-Recursive/pkg-plist
new file mode 100644
index 000000000000..bd9503b31234
--- /dev/null
+++ b/dns/p5-POE-Component-Client-DNS-Recursive/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/POE/Component/Client/DNS/Recursive.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/DNS/Recursive/.packlist
+@dirrmtry %%SITE_PERL%%/POE/Component/Client/DNS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/DNS/Recursive
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/DNS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component