aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-08-08 12:38:59 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-08-08 12:38:59 +0000
commitb196076da06c53b033e80207a929e8aa91545324 (patch)
treeb80518c51925c745f1eb68352b2e0b78cb79e7c7 /dns/powerdns
parent6f6409c077d05055c50caa18cdd674cfe09626d9 (diff)
downloadports-b196076da06c53b033e80207a929e8aa91545324.tar.gz
ports-b196076da06c53b033e80207a929e8aa91545324.zip
- Update to 3.0
PR: ports/159349 Submitted by: Ralf van der Enden <tremere@cainites.net> (maintainer)
Notes
Notes: svn path=/head/; revision=279206
Diffstat (limited to 'dns/powerdns')
-rw-r--r--dns/powerdns/Makefile73
-rw-r--r--dns/powerdns/distinfo4
-rw-r--r--dns/powerdns/files/pdns.conf104
-rw-r--r--dns/powerdns/files/pdns.in2
-rw-r--r--dns/powerdns/files/tables-mssql_or_sybase.sql56
-rw-r--r--dns/powerdns/files/tables-mysql.sql57
-rw-r--r--dns/powerdns/files/tables-pgsql.sql57
-rw-r--r--dns/powerdns/files/tables-sqlite.sql51
-rw-r--r--dns/powerdns/pkg-plist14
9 files changed, 169 insertions, 249 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 98fabec6c8ce..f2b08e10539a 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= powerdns
-PORTVERSION= 2.9.22
-PORTREVISION= 2
+PORTVERSION= 3.0
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/ \
http://mirrors.evolva.ro/powerdns.com/releases/
@@ -17,7 +16,12 @@ MAINTAINER= tremere@cainites.net
COMMENT= An advanced DNS server with multiple backends including SQL
BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost-jam \
- ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+ ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs \
+ ${LOCALBASE}/lib/libcryptopp.a:${PORTSDIR}/security/cryptopp
+LIB_DEPENDS= botan.0:${PORTSDIR}/security/botan
+
+USE_LUA= 5.1
+LUA_COMPS= lua
CONFLICTS= powerdns-devel-[0-9]*
@@ -27,10 +31,12 @@ USE_AUTOTOOLS= libtool
USE_LDCONFIG= YES
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --with-modules="pipe" \
- --with-dynmodules="${CONFIGURE_MODULES}" \
- --sysconfdir="${PREFIX}/etc/pdns" \
-# --enable-debug
+CONFIGURE_ARGS= --with-modules="" \
+ --with-dynmodules="pipe ${CONFIGURE_MODULES}" \
+ --sysconfdir="${PREFIX}/etc/pdns" \
+ --with-boost="${LOCALBASE}" \
+ --enable-botan1.8 \
+ --enable-cryptopp
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
CURDIR2="${.CURDIR}" \
MKDIR="${MKDIR}" \
@@ -41,11 +47,14 @@ MAN8= pdns_control.8 pdns_server.8 zone2sql.8
SUB_FILES= pkg-message
OPTIONS= PGSQL "PostgreSQL backend" on \
+ PGSQL_LOCAL "RUN_DEPEND on PostgreSQL" off \
MYSQL "MySQL backend" off \
+ MYSQL_LOCAL "RUN_DEPEND on MySQL server" off \
SQLITE "SQLite 2 backend" off \
SQLITE3 "SQLite 3 backend" off \
OPENDBX "OpenDBX backend" off \
OPENLDAP "OpenLDAP backend" off \
+ OPENLDAP_LOCAL "RUN_DEPEND on OpenLDAP server" off \
GEO "Geo backend" off
.include <bsd.port.pre.mk>
@@ -65,32 +74,59 @@ BROKEN= choose only one SQLite backend version
.if defined(WITH_PGSQL)
USE_PGSQL?= YES
-CONFIGURE_MODULES+= "gpgsql"
CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}
+CONFIGURE_MODULES+= "gpgsql"
PLIST_SUB+= WITHPGSQL=""
.else
-CONFIGURE_ARGS+= --disable-pgsql
+CONFIGURE_ARGS+= --without-pgsql
PLIST_SUB+= WITHPGSQL="@comment "
.endif
.if defined(WITH_MYSQL)
USE_MYSQL?= YES
+CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
CONFIGURE_MODULES+= "gmysql"
-CXXFLAGS+= -I${LOCALBASE}/include/mysql
-LDFLAGS+= -L${LOCALBASE}/lib/mysql
+#CXXFLAGS+= -I${LOCALBASE}/include/mysql
+#LDFLAGS+= -L${LOCALBASE}/lib/mysql
PLIST_SUB+= WITHMYSQL=""
.else
-CONFIGURE_ARGS+= --disable-mysql
+CONFIGURE_ARGS+= --without-mysql
PLIST_SUB+= WITHMYSQL="@comment "
.endif
+.if defined(WITH_OPENDBX) || defined(WITH_PGSQL)
+. if defined(WITH_PGSQL_LOCAL)
+USE_PGSQL?= YES
+RUN_DEPENDS+= postgresql-server>=0:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
+SUB_LIST+= PGSQL=postgresql
+. else
+SUB_LIST+= PGSQL=
+. endif
+.endif
+.if defined(WITH_OPENDBX) || defined(WITH_MYSQL)
+. if defined(WITH_MYSQL_LOCAL)
+USE_MYSQL?= YES
+RUN_DEPENDS+= mysql-server>=0:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
+SUB_LIST+= MYSQL=mysql
+. else
+SUB_LIST+= MYSQL=
+. endif
+.endif
+
.if defined(WITH_OPENLDAP)
USE_OPENLDAP?= YES
CONFIGURE_MODULES+= "ldap"
CXXFLAGS+= -L${LOCALBASE}/lib -DLDAP_DEPRECATED=1
PLIST_SUB+= WITHOPENLDAP=""
+. if defined(WITH_OPENLDAP_LOCAL)
+RUN_DEPENDS+= openldap-server>=0:${PORTSDIR}/net/openldap${WANT_OPENLDAP_VER}-server
+SUB_LIST+= SLAPD=slapd
+. else
+SUB_LIST+= SLAPD=
+. endif
.else
PLIST_SUB+= WITHOPENLDAP="@comment "
+SUB_LIST+= SLAPD=
.endif
.if defined(WITH_SQLITE)
@@ -118,8 +154,8 @@ CXXFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB+= WITHOPENDBX="@comment "
.endif
-.if defined(WITH_OPENLDAP)
post-patch:
+.if defined(WITH_OPENLDAP)
${REINPLACE_CMD} -e 's;-I. ;-I. -I${LOCALBASE}/include ;' \
-e 's;la_LDFLAGS =;la_LDFLAGS = -L${LOCALBASE}/lib;' \
${WRKSRC}/modules/ldapbackend/Makefile.in
@@ -128,20 +164,27 @@ post-patch:
${WRKSRC}/pdns/Makefile.in
.endif
.if defined(WITH_PGSQL)
-pre-configure:
@${REINPLACE_CMD} -E -e 's;(PGSQL_inc_check="\$$withval/include/pgsql)";\1 \$$withval/include";' \
${WRKSRC}/configure
.endif
+
post-install:
.if !exists(${PREFIX}/etc/pdns/pdns.conf)
${INSTALL_DATA} ${PREFIX}/etc/pdns/pdns.conf-dist ${PREFIX}/etc/pdns/pdns.conf
.endif
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
-.for i in pdns.conf tables-mssql_or_sybase.sql tables-mysql.sql tables-pgsql.sql tables-sqlite.sql
+.for i in pdns.conf
${INSTALL_DATA} ${FILESDIR}/$i ${EXAMPLESDIR}/
.endfor
.endif
+.for j in libgpgsqlbackend.so libgmysqlbackend.so libgsqlitebackend.so \
+ libgsqlite3backend.so libldapbackend.so libopendbxbackend.so \
+ libgeobackend.so libpipebackend.so
+ @if ([ -f ${PREFIX}/lib/$j ] && [ ! -f ${PREFIX}/lib/$j.0 ]); then \
+ ${LN} -sf ${PREFIX}/lib/$j ${PREFIX}/lib/$j.0; \
+ fi
+.endfor
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/dns/powerdns/distinfo b/dns/powerdns/distinfo
index 153870ad847a..095591994a61 100644
--- a/dns/powerdns/distinfo
+++ b/dns/powerdns/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pdns-2.9.22.tar.gz) = 7c03da01c2cbd8bbe897180bc3bd50ca8cfaa63ada94dc6b29f7745b82e17525
-SIZE (pdns-2.9.22.tar.gz) = 1072257
+SHA256 (pdns-3.0.tar.gz) = a468b24b35c2595cc81119c3c8f2db4bd3566266431853e7d6be5930f692b0a2
+SIZE (pdns-3.0.tar.gz) = 1202795
diff --git a/dns/powerdns/files/pdns.conf b/dns/powerdns/files/pdns.conf
index c539c38c2b81..07616949a456 100644
--- a/dns/powerdns/files/pdns.conf
+++ b/dns/powerdns/files/pdns.conf
@@ -29,7 +29,7 @@
#ldap-secret (default "")
#ldap-method (default "simple")
#ldap-filter-axfr (default "(:target:)" )
-ldap-filter-lookup (default "(:target:)" )
+#ldap-filter-lookup (default "(:target:)" )
# OpenDBX (check http://www.linuxnetworks.de for more information)
#launch=opendbx
@@ -44,7 +44,7 @@ ldap-filter-lookup (default "(:target:)" )
#################################
# allow-axfr-ips Allow zonetransfers only to these subnets
#
-# allow-axfr-ips=0.0.0.0/0
+# allow-axfr-ips=0.0.0.0/0,::/0
#################################
# allow-recursion List of subnets that are allowed to recurse
@@ -69,7 +69,7 @@ ldap-filter-lookup (default "(:target:)" )
#################################
# config-dir Location of configuration directory (pdns.conf)
#
-# config-dir=/usr/local/etc
+# config-dir=/usr/local/etc/pdns
#################################
# config-name Name of this virtual configuration - will rename the binary image
@@ -117,6 +117,21 @@ ldap-filter-lookup (default "(:target:)" )
# do-ipv6-additional-processing=no
#################################
+# edns-subnet-option-number EDNS option number to use
+#
+# edns-subnet-option-number=20730
+
+#################################
+# edns-subnet-processing If we should act on EDNS Subnet options
+#
+# edns-subnet-processing=no
+
+#################################
+# entropy-source If set, read entropy from this file
+#
+# entropy-source=/dev/urandom
+
+#################################
# fancy-records Process URL and MBOXFW records
#
# fancy-records=no
@@ -162,12 +177,17 @@ ldap-filter-lookup (default "(:target:)" )
# log-dns-details=
#################################
+# log-dns-queries If PDNS should log all incoming DNS queries
+#
+# log-dns-queries=no
+
+#################################
# log-failed-updates If PDNS should log failed update requests
#
# log-failed-updates=
#################################
-# logfile Logfile to use
+# logfile Logfile to use (Windows only)
#
# logfile=pdns.log
@@ -187,6 +207,11 @@ ldap-filter-lookup (default "(:target:)" )
# master=no
#################################
+# max-cache-entries Maximum number of cache entries
+#
+# max-cache-entries=1000000
+
+#################################
# max-queue-length Maximum queuelength before considering situation lost
#
# max-queue-length=5000
@@ -217,6 +242,16 @@ ldap-filter-lookup (default "(:target:)" )
# out-of-zone-additional-processing=yes
#################################
+# overload-queue-length Maximum queuelength moving to packetcache only
+#
+# overload-queue-length=0
+
+#################################
+# per-zone-axfr-acls When set, backends that implement it perform per-zone AXFL ACL checks
+#
+# per-zone-axfr-acls=off
+
+#################################
# pipebackend-abi-version Version of the pipe backend ABI
#
# pipebackend-abi-version=1
@@ -229,7 +264,12 @@ ldap-filter-lookup (default "(:target:)" )
#################################
# query-local-address Source IP address for sending queries
#
-# query-local-address=
+# query-local-address=0.0.0.0
+
+#################################
+# query-local-address6 Source IPv6 address for sending queries
+#
+# query-local-address6=::
#################################
# query-logging Hint backends that queries should be logged
@@ -242,6 +282,11 @@ ldap-filter-lookup (default "(:target:)" )
# queue-limit=1500
#################################
+# receiver-threads Default number of Distributor (backend) threads to start
+#
+# receiver-threads=1
+
+#################################
# recursive-cache-ttl Seconds to store packets in the PacketCache
#
# recursive-cache-ttl=10
@@ -252,11 +297,21 @@ ldap-filter-lookup (default "(:target:)" )
# recursor=no
#################################
+# retrieval-threads Number of AXFR-retrieval threads for slave operation
+#
+# retrieval-threads=2
+
+#################################
# send-root-referral Send out old-fashioned root-referral instead of ServFail in case of no authority
#
# send-root-referral=no
#################################
+# server-id Returned when queried for 'server.id' TXT or NSID, defaults to hostname
+#
+# server-id=
+
+#################################
# setgid If set, change group id to this gid for more security
#
# setgid=
@@ -267,6 +322,11 @@ ldap-filter-lookup (default "(:target:)" )
# setuid=
#################################
+# signing-threads Default number of signer threads to start
+#
+# signing-threads=3
+
+#################################
# skip-cname Do not perform CNAME indirection for each query
#
# skip-cname=no
@@ -282,6 +342,11 @@ ldap-filter-lookup (default "(:target:)" )
# slave-cycle-interval=60
#################################
+# slave-renotify If we should send out notifications for slaved updates
+#
+# slave-renotify=no
+
+#################################
# smtpredirector Our smtpredir MX host
#
# smtpredirector=a.misconfigured.powerdns.smtp.server
@@ -322,12 +387,37 @@ ldap-filter-lookup (default "(:target:)" )
# strict-rfc-axfrs=no
#################################
+# tcp-control-address If set, PowerDNS can be controlled over TCP on this address
+#
+# tcp-control-address=
+
+#################################
+# tcp-control-port If set, PowerDNS can be controlled over TCP on this address
+#
+# tcp-control-port=53000
+
+#################################
+# tcp-control-range If set, remote control of PowerDNS is possible over these networks only
+#
+# tcp-control-range=127.0.0.0/8, 10.0.0.0/8, 192.168.0.0/16, 172.16.0.0/12, ::1/128, fe80::/10
+
+#################################
+# tcp-control-secret If set, PowerDNS can be controlled over TCP after passing this secret
+#
+# tcp-control-secret=
+
+#################################
+# trusted-notification-proxy IP address of incoming notification proxy
+#
+# trusted-notification-proxy=
+
+#################################
# urlredirector Where we send hosts to that need to be url redirected
#
# urlredirector=127.0.0.1
#################################
-# use-logfile Use a log file
+# use-logfile Use a log file (Windows only)
#
# use-logfile=no
@@ -370,3 +460,5 @@ ldap-filter-lookup (default "(:target:)" )
# wildcards Honor wildcards in the database
#
# wildcards=
+
+
diff --git a/dns/powerdns/files/pdns.in b/dns/powerdns/files/pdns.in
index 164f222c13e8..5d4e241c4e81 100644
--- a/dns/powerdns/files/pdns.in
+++ b/dns/powerdns/files/pdns.in
@@ -4,7 +4,7 @@
#
# PROVIDE: pdns_server
-# REQUIRE: DAEMON
+# REQUIRE: DAEMON %%MYSQL%% %%PGSQL%% %%SLAPD%%
# KEYWORD: shutdown
#
diff --git a/dns/powerdns/files/tables-mssql_or_sybase.sql b/dns/powerdns/files/tables-mssql_or_sybase.sql
deleted file mode 100644
index 5b815186cfee..000000000000
--- a/dns/powerdns/files/tables-mssql_or_sybase.sql
+++ /dev/null
@@ -1,56 +0,0 @@
-SET quoted_identifier ON;
-
-
-CREATE TABLE "domains" (
- "id" INTEGER NOT NULL IDENTITY,
- "name" VARCHAR(255) NOT NULL,
- "type" VARCHAR(6) NOT NULL,
- "master" VARCHAR(40) DEFAULT '' NOT NULL,
- "account" VARCHAR(40) DEFAULT '' NOT NULL,
- "notified_serial" INTEGER NULL,
- "last_check" INTEGER NULL,
- "status" CHAR(1) DEFAULT 'A' NOT NULL,
-CONSTRAINT "pk_domains_id"
- PRIMARY KEY ("id"),
-CONSTRAINT "unq_domains_name"
- UNIQUE ("name")
-);
-
-CREATE INDEX "idx_domains_status_type" ON "domains" ("status","type");
-
-
-
-CREATE TABLE "records" (
- "id" INTEGER NOT NULL IDENTITY,
- "domain_id" INTEGER NOT NULL,
- "name" VARCHAR(255) NOT NULL,
- "type" VARCHAR(6) NOT NULL,
- "ttl" INTEGER NULL,
- "prio" INTEGER NULL,
- "content" VARCHAR(255) NOT NULL,
- "change_date" INTEGER NULL,
-CONSTRAINT "pk_records_id"
- PRIMARY KEY ("id"),
-CONSTRAINT "fk_records_domainid"
- FOREIGN KEY ("domain_id")
- REFERENCES "domains" ("id")
-);
-
-CREATE INDEX "idx_records_name_type" ON "records" ("name","type");
-CREATE INDEX "idx_records_type" ON "records" ("type");
-
-
-
-CREATE TABLE "supermasters" (
- "ip" VARCHAR(40) NOT NULL,
- "nameserver" VARCHAR(255) NOT NULL,
- "account" VARCHAR(40) DEFAULT '' NOT NULL
-);
-
-CREATE INDEX "idx_smip_smns" ON "supermasters" ("ip","nameserver");
-
-
-
-GRANT SELECT ON "supermasters" TO "powerdns";
-GRANT ALL ON "domains" TO "powerdns";
-GRANT ALL ON "records" TO "powerdns";
diff --git a/dns/powerdns/files/tables-mysql.sql b/dns/powerdns/files/tables-mysql.sql
deleted file mode 100644
index c57d45c1dee1..000000000000
--- a/dns/powerdns/files/tables-mysql.sql
+++ /dev/null
@@ -1,57 +0,0 @@
-SET SESSION sql_mode='ANSI';
-
-CREATE TABLE "domains" (
- "id" INTEGER NOT NULL AUTO_INCREMENT,
- "name" VARCHAR(255) NOT NULL,
- "type" VARCHAR(6) NOT NULL,
- "master" VARCHAR(40) NOT NULL DEFAULT '',
- "account" VARCHAR(40) NOT NULL DEFAULT '',
- "notified_serial" INTEGER DEFAULT NULL,
- "last_check" INTEGER DEFAULT NULL,
- "status" CHAR(1) NOT NULL DEFAULT 'A',
-CONSTRAINT "pk_domains_id"
- PRIMARY KEY ("id"),
-CONSTRAINT "unq_domains_name"
- UNIQUE ("name")
-) type=InnoDB;
-
-CREATE INDEX "idx_domains_status_type" ON "domains" ("status","type");
-
-
-
-CREATE TABLE "records" (
- "id" INTEGER NOT NULL AUTO_INCREMENT,
- "domain_id" INTEGER NOT NULL,
- "name" VARCHAR(255) NOT NULL,
- "type" VARCHAR(6) NOT NULL,
- "ttl" INTEGER DEFAULT NULL,
- "prio" INTEGER DEFAULT NULL,
- "content" VARCHAR(255) NOT NULL,
- "change_date" INTEGER DEFAULT NULL,
-CONSTRAINT "pk_records_id"
- PRIMARY KEY ("id"),
-CONSTRAINT "fk_records_domainid"
- FOREIGN KEY ("domain_id")
- REFERENCES "domains" ("id")
- ON UPDATE CASCADE
- ON DELETE CASCADE
-) type=InnoDB;
-
-CREATE INDEX "idx_records_name_type" ON "records" ("name","type");
-CREATE INDEX "idx_records_type" ON "records" ("type");
-
-
-
-CREATE TABLE "supermasters" (
- "ip" VARCHAR(40) NOT NULL,
- "nameserver" VARCHAR(255) NOT NULL,
- "account" VARCHAR(40) NOT NULL DEFAULT ''
-);
-
-CREATE INDEX "idx_smip_smns" ON "supermasters" ("ip","nameserver");
-
-
-
-GRANT SELECT ON "supermasters" TO "powerdns";
-GRANT ALL ON "domains" TO "powerdns";
-GRANT ALL ON "records" TO "powerdns";
diff --git a/dns/powerdns/files/tables-pgsql.sql b/dns/powerdns/files/tables-pgsql.sql
deleted file mode 100644
index 5d8afcb7032c..000000000000
--- a/dns/powerdns/files/tables-pgsql.sql
+++ /dev/null
@@ -1,57 +0,0 @@
-CREATE TABLE "domains" (
- "id" SERIAL NOT NULL,
- "name" VARCHAR(255) NOT NULL,
- "type" VARCHAR(6) NOT NULL,
- "master" VARCHAR(40) NOT NULL DEFAULT '',
- "account" VARCHAR(40) NOT NULL DEFAULT '',
- "notified_serial" INTEGER DEFAULT NULL,
- "last_check" INTEGER DEFAULT NULL,
- "status" CHAR(1) NOT NULL DEFAULT 'A',
-CONSTRAINT "pk_domains_id"
- PRIMARY KEY ("id"),
-CONSTRAINT "unq_domains_name"
- UNIQUE ("name")
-);
-
-CREATE INDEX "idx_domains_status_type" ON "domains" ("status","type");
-
-
-
-CREATE TABLE "records" (
- "id" SERIAL NOT NULL,
- "domain_id" INTEGER NOT NULL,
- "name" VARCHAR(255) NOT NULL,
- "type" VARCHAR(6) NOT NULL,
- "ttl" INTEGER DEFAULT NULL,
- "prio" INTEGER DEFAULT NULL,
- "content" VARCHAR(255) NOT NULL,
- "change_date" INTEGER DEFAULT NULL,
-CONSTRAINT "pk_records_id"
- PRIMARY KEY ("id"),
-CONSTRAINT "fk_records_domainid"
- FOREIGN KEY ("domain_id")
- REFERENCES domains ("id")
- ON UPDATE CASCADE
- ON DELETE CASCADE
-);
-
-CREATE INDEX "idx_records_name_type" ON "records" ("name","type");
-CREATE INDEX "idx_records_type" ON "records" ("type");
-
-
-
-CREATE TABLE "supermasters" (
- "ip" VARCHAR(40) NOT NULL,
- "nameserver" VARCHAR(255) NOT NULL,
- "account" VARCHAR(40) NOT NULL DEFAULT ''
-);
-
-CREATE INDEX "idx_smaster_ip_ns" ON "supermasters" ("ip","nameserver");
-
-
-
-GRANT SELECT ON "supermasters" TO "powerdns";
-GRANT ALL ON "domains" TO "powerdns";
-GRANT ALL ON "domains_id_seq" TO "powerdns";
-GRANT ALL ON "records" TO "powerdns";
-GRANT ALL ON "records_id_seq" TO "powerdns";
diff --git a/dns/powerdns/files/tables-sqlite.sql b/dns/powerdns/files/tables-sqlite.sql
deleted file mode 100644
index 0491ac280d7f..000000000000
--- a/dns/powerdns/files/tables-sqlite.sql
+++ /dev/null
@@ -1,51 +0,0 @@
-CREATE TABLE "domains" (
- "id" INTEGER NOT NULL PRIMARY KEY AUTOINCREMENT,
- "name" VARCHAR(255) NOT NULL,
- "type" VARCHAR(6) NOT NULL,
- "master" VARCHAR(40) NOT NULL DEFAULT '',
- "account" VARCHAR(40) NOT NULL DEFAULT '',
- "notified_serial" INTEGER DEFAULT NULL,
- "last_check" INTEGER DEFAULT NULL,
- "status" CHAR(1) NOT NULL DEFAULT 'A',
-CONSTRAINT "unq_domains_name"
- UNIQUE ("name")
-);
-
-CREATE INDEX "idx_domains_status_type" ON "domains" ("status","type");
-
-
-
-CREATE TABLE "records" (
- "id" INTEGER NOT NULL PRIMARY KEY AUTOINCREMENT,
- "domain_id" INTEGER NOT NULL,
- "name" VARCHAR(255) NOT NULL,
- "type" VARCHAR(6) NOT NULL,
- "ttl" INTEGER DEFAULT NULL,
- "prio" INTEGER DEFAULT NULL,
- "content" VARCHAR(255) NOT NULL,
- "change_date" INTEGER DEFAULT NULL,
-CONSTRAINT "fk_records_domainid"
- FOREIGN KEY ("domain_id")
- REFERENCES "domains" ("id")
- ON UPDATE CASCADE
- ON DELETE CASCADE
-);
-
-CREATE INDEX "idx_records_name_type" ON "records" ("name","type");
-CREATE INDEX "idx_records_type" ON "records" ("type");
-
-
-
-CREATE TABLE "supermasters" (
- "ip" VARCHAR(40) NOT NULL,
- "nameserver" VARCHAR(255) NOT NULL,
- "account" VARCHAR(40) NOT NULL DEFAULT ''
-);
-
-CREATE INDEX "idx_smip_smns" ON "supermasters" ("ip","nameserver");
-
-
-
-GRANT SELECT ON "supermasters" TO "powerdns";
-GRANT ALL ON "domains" TO "powerdns";
-GRANT ALL ON "records" TO "powerdns";
diff --git a/dns/powerdns/pkg-plist b/dns/powerdns/pkg-plist
index 0e8924a86aed..4010385c1030 100644
--- a/dns/powerdns/pkg-plist
+++ b/dns/powerdns/pkg-plist
@@ -1,38 +1,44 @@
+bin/dnsreplay
bin/pdns_control
+bin/pdnssec
bin/zone2ldap
bin/zone2sql
sbin/pdns_server
%%WITHPGSQL%%lib/libgpgsqlbackend.a
%%WITHPGSQL%%lib/libgpgsqlbackend.la
%%WITHPGSQL%%lib/libgpgsqlbackend.so
+%%WITHPGSQL%%lib/libgpgsqlbackend.so.0
%%WITHMYSQL%%lib/libgmysqlbackend.a
%%WITHMYSQL%%lib/libgmysqlbackend.la
%%WITHMYSQL%%lib/libgmysqlbackend.so
+%%WITHMYSQL%%lib/libgmysqlbackend.so.0
%%WITHSQLITE%%lib/libgsqlitebackend.a
%%WITHSQLITE%%lib/libgsqlitebackend.la
%%WITHSQLITE%%lib/libgsqlitebackend.so
+%%WITHSQLITE%%lib/libgsqlitebackend.so.0
%%WITHSQLITE3%%lib/libgsqlite3backend.a
%%WITHSQLITE3%%lib/libgsqlite3backend.la
%%WITHSQLITE3%%lib/libgsqlite3backend.so
+%%WITHSQLITE3%%lib/libgsqlite3backend.so.0
%%WITHOPENLDAP%%lib/libldapbackend.a
%%WITHOPENLDAP%%lib/libldapbackend.la
%%WITHOPENLDAP%%lib/libldapbackend.so
+%%WITHOPENLDAP%%lib/libldapbackend.so.0
%%WITHOPENDBX%%lib/libopendbxbackend.a
%%WITHOPENDBX%%lib/libopendbxbackend.la
%%WITHOPENDBX%%lib/libopendbxbackend.so
+%%WITHOPENDBX%%lib/libopendbxbackend.so.0
%%WITHGEO%%lib/libgeobackend.a
%%WITHGEO%%lib/libgeobackend.la
%%WITHGEO%%lib/libgeobackend.so
+%%WITHGEO%%lib/libgeobackend.so.0
lib/libpipebackend.a
lib/libpipebackend.la
lib/libpipebackend.so
+lib/libpipebackend.so.0
@unexec if cmp -s %D/etc/pdns/pdns.conf %D/etc/pdns/pdns.conf-dist; then rm -f %D/etc/pdns/pdns.conf; fi
etc/pdns/pdns.conf-dist
@exec [ -f %B/pdns.conf ] || cp %B/%f %B/pdns.conf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pdns.conf
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tables-mssql_or_sybase.sql
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tables-mysql.sql
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tables-pgsql.sql
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tables-sqlite.sql
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrmtry etc/pdns