aboutsummaryrefslogtreecommitdiff
path: root/dns/py-dns-lexicon
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2023-06-14 22:00:28 +0000
committerRene Ladan <rene@FreeBSD.org>2023-06-27 19:34:34 +0000
commit3d9a815d9c5acbb71f4bb07738bdeab4879feacb (patch)
treeeb093f22197a2c68a88dd2372ec1922c3f6d3c10 /dns/py-dns-lexicon
parentc58ef91e06e8edc4fd8579837f1453b562da3fbb (diff)
downloadports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.tar.gz
ports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.zip
all: remove explicit versions in USES=python for "3.x+"
The logic in USES=python will automatically convert this to 3.8+ by itself. Adjust two ports that only had Python 3.7 mentioned but build fine on Python 3.8 too. finance/quickfix: mark BROKEN with PYTHON libtool: compile: c++ -DHAVE_CONFIG_H -I. -I../.. -I -I. -I.. -I../.. -I../C++ -DLIBICONV_PLUG -DPYTHON_MAJOR_VERSION=3 -Wno-unused-variable -Wno-maybe-uninitialized -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong -fno-strict-aliasing -DLIBICONV_PLUG -Wall -ansi -Wno-unused-command-line-argument -Wpointer-arith -Wwrite-strings -Wno-overloaded-virtual -Wno-deprecated-declarations -Wno-deprecated -std=c++0x -MT _quickfix_la-QuickfixPython.lo -MD -MP -MF .deps/_quickfix_la-QuickfixPython.Tpo -c QuickfixPython.cpp -fPIC -DPIC -o .libs/_quickfix_la-QuickfixPython.o warning: unknown warning option '-Wno-maybe-uninitialized'; did you mean '-Wno-uninitialized'? [-Wunknown-warning-option] QuickfixPython.cpp:175:11: fatal error: 'Python.h' file not found ^~~~~~~~~~ 1 warning and 1 error generated. Reviewed by: portmgr, vishwin, yuri Differential Revision: <https://reviews.freebsd.org/D40568>
Diffstat (limited to 'dns/py-dns-lexicon')
-rw-r--r--dns/py-dns-lexicon/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/dns/py-dns-lexicon/Makefile b/dns/py-dns-lexicon/Makefile
index 7f1851f453c8..e384f7ff9bc2 100644
--- a/dns/py-dns-lexicon/Makefile
+++ b/dns/py-dns-lexicon/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4:www/py-beautifulsoup@${PY_F
${PYTHON_PKGNAMEPREFIX}requests>=2:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tldextract>=2:dns/py-tldextract@${PY_FLAVOR}
-USES= python:3.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes