aboutsummaryrefslogtreecommitdiff
path: root/dns/validns/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-06-27 14:24:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-06-27 14:24:00 +0000
commit744303fc31b2d73cb7a80d1875590e62e01412e1 (patch)
tree7d0728bfcfbd8961abde4b9c3f8d064172129315 /dns/validns/Makefile
parent2877a7e1d717b79e419f53185a5b61c2ee14d9f3 (diff)
downloadports-744303fc31b2d73cb7a80d1875590e62e01412e1.tar.gz
ports-744303fc31b2d73cb7a80d1875590e62e01412e1.zip
- Update to 0.8
- Use ports SSL PR: 190703
Notes
Notes: svn path=/head/; revision=359539
Diffstat (limited to 'dns/validns/Makefile')
-rw-r--r--dns/validns/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/dns/validns/Makefile b/dns/validns/Makefile
index e1cb3d487db0..fcaef1ad0f87 100644
--- a/dns/validns/Makefile
+++ b/dns/validns/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= validns
-PORTVERSION= 0.7
+PORTVERSION= 0.8
CATEGORIES= dns security
MASTER_SITES= http://www.validns.net/download/
@@ -11,18 +11,23 @@ COMMENT= High performance DNS/DNSSEC zone validator
LICENSE= BSD2CLAUSE
-OPTIONS_DEFINE= DOCS
-
LIB_DEPENDS= libJudy.so:${PORTSDIR}/devel/judy
+USE_OPENSSL= yes
+WITH_OPENSSL_PORT=yes
+
ALL_TARGET=
PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz
-OPTIONS_DEFINE= DOCS
+
PORTDOCS= Changes README installation.mdwn notes.mdwn \
technical-notes.mdwn todo.mdwn usage.mdwn
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/