aboutsummaryrefslogtreecommitdiff
path: root/dns/zonecheck
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-10-28 20:05:02 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-10-28 20:05:02 +0000
commite27a8fab447a55eb873521f1ffae93e0a72696c3 (patch)
treeb85257eb9d46989ba6789b80ec448b2579d579af /dns/zonecheck
parent540c3776a2e3badd2bc232bc1e24b93fe7c40a66 (diff)
downloadports-e27a8fab447a55eb873521f1ffae93e0a72696c3.tar.gz
ports-e27a8fab447a55eb873521f1ffae93e0a72696c3.zip
- Convert options to the new format
PR: ports/172556 Submitted by: pgj Approved by: maintainer Feature safe: yes
Notes
Notes: svn path=/head/; revision=306568
Diffstat (limited to 'dns/zonecheck')
-rw-r--r--dns/zonecheck/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/dns/zonecheck/Makefile b/dns/zonecheck/Makefile
index 54269bc0f778..ae301f16ca17 100644
--- a/dns/zonecheck/Makefile
+++ b/dns/zonecheck/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: zonecheck
-# Date created: 10 July 2003
-# Whom: Janos.Mohacsi@bsd.hu
-#
+# Created by: Janos.Mohacsi@bsd.hu
# $FreeBSD$
-#
PORTNAME= zonecheck
PORTVERSION= 3.0.5
@@ -30,13 +26,16 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MAN1= zonecheck.1
DOCS= BUGS INSTALL README TODO
-OPTIONS= ZONECHECK_CGI "Install with CGI support" off
+OPTIONS_DEFINE= CGI
+OPTIONS_DEFAULT=
-.include <bsd.port.pre.mk>
+CGI_DESC= Install with CGI support
+
+.include <bsd.port.options.mk>
ZONECHECK_TARGET= common cli
-.if defined(WITH_ZONECHECK_CGI)
+.if ${PORT_OPTIONS:MCGI}
ZONECHECK_TARGET+= cgi
PLIST_SUB+= ZONECHECK_CGI=""
.else
@@ -49,10 +48,10 @@ do-install:
-DETCDIST='-dist' -DRUBY="${RUBY}" -DPREFIX="${PREFIX}" \
-DWWWDIR="${PREFIX}/www/${PORTNAME}"
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>