aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-01-21 13:12:27 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-01-21 13:12:27 +0000
commit0cd2bc005dcbe8905333da59f7f6ef1086420f41 (patch)
treef3f9fb6effb739d4535a46106fb7c0de20da5498 /dns
parent14996e001e199fee3f9d6488c8fdae23ca73d505 (diff)
downloadports-0cd2bc005dcbe8905333da59f7f6ef1086420f41.tar.gz
ports-0cd2bc005dcbe8905333da59f7f6ef1086420f41.zip
New port: dns/py-tld
Extract the top level domain (TLD) from the URL given. List of TLD names is taken from Mozilla. WWW: https://github.com/barseghyanartur/tld
Notes
Notes: svn path=/head/; revision=459604
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-tld/Makefile22
-rw-r--r--dns/py-tld/distinfo3
-rw-r--r--dns/py-tld/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 4589c6661d0f..9dd2893c778b 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -187,6 +187,7 @@
SUBDIR += py-pycares
SUBDIR += py-pydnstable
SUBDIR += py-pywdns
+ SUBDIR += py-tld
SUBDIR += py-tldextract
SUBDIR += radns
SUBDIR += rbldnsd
diff --git a/dns/py-tld/Makefile b/dns/py-tld/Makefile
new file mode 100644
index 000000000000..9a1e57c5b1b8
--- /dev/null
+++ b/dns/py-tld/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= tld
+PORTVERSION= 0.7.9
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Extract the top level domain (TLD) from the URL given
+
+LICENSE= MPL11 GPLv2 LGPL21
+LICENSE_COMB= multi
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${FLAVOR}
+
+NO_ARCH= yes
+USES= python shebangfix
+USE_PYTHON= autoplist concurrent distutils
+SHEBANG_FILES= src/tld/bin/update-tld-names
+
+.include <bsd.port.mk>
diff --git a/dns/py-tld/distinfo b/dns/py-tld/distinfo
new file mode 100644
index 000000000000..127a1e0a5f0a
--- /dev/null
+++ b/dns/py-tld/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1515568446
+SHA256 (tld-0.7.9.tar.gz) = e78e31ee3d48af1c0473110f6c477c01244f2106d77186f56f027977a5b760a2
+SIZE (tld-0.7.9.tar.gz) = 147753
diff --git a/dns/py-tld/pkg-descr b/dns/py-tld/pkg-descr
new file mode 100644
index 000000000000..5fbb9cac534a
--- /dev/null
+++ b/dns/py-tld/pkg-descr
@@ -0,0 +1,4 @@
+Extract the top level domain (TLD) from the URL given. List of TLD names is
+taken from Mozilla.
+
+WWW: https://github.com/barseghyanartur/tld