aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2010-06-18 05:41:26 +0000
committerDoug Barton <dougb@FreeBSD.org>2010-06-18 05:41:26 +0000
commit250f5e070c8bf28b2d6f071b31b2686359d284d2 (patch)
treebbf4f1305bd2f6d282a512ed6441591be4c7a6a1 /dns
parent6ad618313d6b92877bc1ab4efd46da90ea6c610f (diff)
downloadports-250f5e070c8bf28b2d6f071b31b2686359d284d2.tar.gz
ports-250f5e070c8bf28b2d6f071b31b2686359d284d2.zip
Turns out that the bind.keys.h file is not a new dependency, so my previous
fix was too hasty. Employ a more robust fix that removes the _perl_ dep for both this file and bind9.xsl.h. The pre-generated versions of these files are identical to the newly generated ones, which is why this perl issue never came up previously. I still have reservations about baking the ISC DLV key into named, but given that this was already done in 9.7.0+ at least this way we don't violate POLA.
Notes
Notes: svn path=/head/; revision=256641
Diffstat (limited to 'dns')
-rw-r--r--dns/bind97/Makefile4
-rw-r--r--dns/bind97/files/patch-bind-keys-h53
2 files changed, 4 insertions, 53 deletions
diff --git a/dns/bind97/Makefile b/dns/bind97/Makefile
index 33c04559a4e4..41a60f406658 100644
--- a/dns/bind97/Makefile
+++ b/dns/bind97/Makefile
@@ -204,6 +204,10 @@ post-patch:
@${MV} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.Dist
@${SED} -e 's#.*bind\.keys.*##' ${WRKSRC}/Makefile.in.Dist > \
${WRKSRC}/Makefile.in
+ @${MV} ${WRKSRC}/bin/named/Makefile.in ${WRKSRC}/bin/named/Makefile.in.Dist
+ @${SED} -e 's/$${PERL}/#/' -e 's/bind.keys.h/#/g' -e 's/bind9.xsl.h/#/g' \
+ ${WRKSRC}/bin/named/Makefile.in.Dist > \
+ ${WRKSRC}/bin/named/Makefile.in
post-install:
${INSTALL_DATA} ${WRKSRC}/bin/rndc/rndc.conf \
diff --git a/dns/bind97/files/patch-bind-keys-h b/dns/bind97/files/patch-bind-keys-h
deleted file mode 100644
index 749f539c0656..000000000000
--- a/dns/bind97/files/patch-bind-keys-h
+++ /dev/null
@@ -1,53 +0,0 @@
---- bin/named/Makefile.in.orig 2009-12-05 15:31:40.000000000 -0800
-+++ bin/named/Makefile.in 2010-06-17 19:08:13.000000000 -0700
-@@ -118,10 +118,7 @@
- -DNS_LOCALSTATEDIR=\"${localstatedir}\" \
- -DNS_SYSCONFDIR=\"${sysconfdir}\" -c ${srcdir}/main.c
-
--bind.keys.h: ${top_srcdir}/bind.keys
-- ${PERL} ${srcdir}/bindkeys.pl < ${top_srcdir}/bind.keys > $@
--
--config.@O@: config.c bind.keys.h
-+config.@O@: config.c
- ${LIBTOOL_MODE_COMPILE} ${CC} ${ALL_CFLAGS} \
- -DVERSION=\"${VERSION}\" \
- -DNS_LOCALSTATEDIR=\"${localstatedir}\" \
-@@ -143,7 +140,7 @@
- rm -f ${MANOBJS}
-
- clean distclean maintainer-clean::
-- rm -f ${TARGETS} ${OBJS} bind.keys.h
-+ rm -f ${TARGETS} ${OBJS}
-
- bind9.xsl.h: bind9.xsl ${srcdir}/convertxsl.pl
- ${PERL} ${srcdir}/convertxsl.pl < ${srcdir}/bind9.xsl > bind9.xsl.h
---- bin/named/config.c.orig 2010-05-14 16:49:18.000000000 -0700
-+++ bin/named/config.c 2010-06-17 19:10:31.000000000 -0700
-@@ -47,8 +47,6 @@
- #include <named/config.h>
- #include <named/globals.h>
-
--#include "bind.keys.h"
--
- /*% default configuration */
- static char defaultconf[] = "\
- options {\n\
-@@ -237,18 +235,6 @@
- database \"_builtin id\";\n\
- };\n\
- };\n\
--"
--"#\n\
--# Default trusted key(s) for builtin DLV support\n\
--# (used if \"dnssec-lookaside auto;\" is set and\n\
--# sysconfdir/bind.keys doesn't exist).\n\
--#\n\
--# BEGIN MANAGED KEYS\n"
--
--/* Imported from bind.keys.h: */
--MANAGED_KEYS
--
--"# END MANAGED KEYS\n\
- ";
-
- isc_result_t