aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2009-03-24 20:00:21 +0000
committerDoug Barton <dougb@FreeBSD.org>2009-03-24 20:00:21 +0000
commit389960986f611e3bb222b4757f6f7558bb52f810 (patch)
tree911b60b93a78402873b64af8049c4e365c77129d /dns
parentd31cadffee9652bba4aed758b08c36d8bd083aad (diff)
downloadports-389960986f611e3bb222b4757f6f7558bb52f810.tar.gz
ports-389960986f611e3bb222b4757f6f7558bb52f810.zip
Fix CONFLICTS (again). The previous example didn't work at all for ports
other than plain bind9 since the real PORTNAMEs for the other ports are bind9[456]. This fix has the added advantage of covering REPLACE_BASE.
Notes
Notes: svn path=/head/; revision=230905
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9/Makefile2
-rw-r--r--dns/bind94/Makefile2
-rw-r--r--dns/bind95/Makefile2
-rw-r--r--dns/bind96/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/dns/bind9/Makefile b/dns/bind9/Makefile
index d67286735b06..c09110d01b47 100644
--- a/dns/bind9/Makefile
+++ b/dns/bind9/Makefile
@@ -33,7 +33,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--with-randomdev=/dev/random
-CONFLICTS= bind9-9.[456].* bind9-sdb-* host-*
+CONFLICTS= bind9*-9.[456].* bind9-sdb-* host-*
OPTIONS= SSL "Building without OpenSSL removes DNSSEC" on \
REPLACE_BASE "Replace base BIND with this version" off \
diff --git a/dns/bind94/Makefile b/dns/bind94/Makefile
index 6b38c0f8920a..c4051159d998 100644
--- a/dns/bind94/Makefile
+++ b/dns/bind94/Makefile
@@ -33,7 +33,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--with-randomdev=/dev/random
-CONFLICTS= bind9-9.[356].* bind9-sdb-* host-*
+CONFLICTS= bind9*-9.[356].* bind9-sdb-* host-*
OPTIONS= SSL "Building without OpenSSL removes DNSSEC" on \
REPLACE_BASE "Replace base BIND with this version" off \
diff --git a/dns/bind95/Makefile b/dns/bind95/Makefile
index a97476ca0e81..297fc8ce5a51 100644
--- a/dns/bind95/Makefile
+++ b/dns/bind95/Makefile
@@ -33,7 +33,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--with-randomdev=/dev/random
-CONFLICTS= bind9-9.[346].* bind9-sdb-* host-*
+CONFLICTS= bind9*-9.[346].* bind9-sdb-* host-*
OPTIONS= SSL "Building without OpenSSL removes DNSSEC" on \
XML "Support for xml statistics output" on \
diff --git a/dns/bind96/Makefile b/dns/bind96/Makefile
index 9c5aa6eeca41..c12ca2acd9a7 100644
--- a/dns/bind96/Makefile
+++ b/dns/bind96/Makefile
@@ -33,7 +33,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--with-randomdev=/dev/random
-CONFLICTS= bind9-9.[345].* bind9-sdb-* host-*
+CONFLICTS= bind9*-9.[345].* bind9-sdb-* host-*
OPTIONS= SSL "Building without OpenSSL removes DNSSEC" on \
XML "Support for xml statistics output" on \