aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-20 00:21:04 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-20 00:21:04 +0000
commit3ff7677ce7e576f5471357bc8df3eedf1d61c476 (patch)
tree1eae6745358228b97112a19c1e33d0c9d46d42e1 /dns
parent9564fa460c6d4dd109e15c66ee58c131a8017f7a (diff)
downloadports-3ff7677ce7e576f5471357bc8df3eedf1d61c476.tar.gz
ports-3ff7677ce7e576f5471357bc8df3eedf1d61c476.zip
scavenge is a utility to audit DNS records within an IP address range.
It scans the range and classifies its findings into 4 categories: - Missing A records - Missing PTR records - Mismatched A/PTR records - Stale PTR records PR: ports/80119 Submitted by: Mark Foster <mark@foster.cc> Approved by: adamw (mentor)
Notes
Notes: svn path=/head/; revision=133717
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/scavenge/Makefile25
-rw-r--r--dns/scavenge/distinfo2
-rw-r--r--dns/scavenge/pkg-descr12
4 files changed, 40 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 1a5be82c11c1..3216c17e8689 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -78,6 +78,7 @@
SUBDIR += py-twistedNames
SUBDIR += rbldnsd
SUBDIR += rbllookup
+ SUBDIR += scavenge
SUBDIR += sheerdns
SUBDIR += skadns
SUBDIR += sleuth
diff --git a/dns/scavenge/Makefile b/dns/scavenge/Makefile
new file mode 100644
index 000000000000..955a3e0d062a
--- /dev/null
+++ b/dns/scavenge/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: scavenge
+# Date created: 13 April 2005
+# Whom: mark@foster.cc
+#
+# $FreeBSD$
+
+PORTNAME= scavenge
+PORTVERSION= 1.3
+CATEGORIES= dns
+MASTER_SITES= http://mark.foster.cc/pub/scavenge/
+
+MAINTAINER= mark@foster.cc
+COMMENT= Discover/audit forward and reverse DNS records
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
+ nmap:${PORTSDIR}/security/nmap
+
+PLIST_FILES= bin/scavenge
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/scavenge ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/dns/scavenge/distinfo b/dns/scavenge/distinfo
new file mode 100644
index 000000000000..9f80a439e3f3
--- /dev/null
+++ b/dns/scavenge/distinfo
@@ -0,0 +1,2 @@
+MD5 (scavenge-1.3.tar.gz) = 5a49dc865f589bab03da2b51660408eb
+SIZE (scavenge-1.3.tar.gz) = 2030
diff --git a/dns/scavenge/pkg-descr b/dns/scavenge/pkg-descr
new file mode 100644
index 000000000000..f8a752b4e0e4
--- /dev/null
+++ b/dns/scavenge/pkg-descr
@@ -0,0 +1,12 @@
+scavenge is a utility to audit DNS records within an IP address range.
+It scans the range and classifies its findings into 4 categories:
+
+ - Missing A records
+ - Missing PTR records
+ - Mismatched A/PTR records
+ - Stale PTR records
+
+WWW: http://mark.foster.cc/pub/scavenge/
+
+- mdf
+mark@foster.cc