aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2013-09-20 04:10:21 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2013-09-20 04:10:21 +0000
commit4387ee26f25c3caea3200829b293417c215dbcb2 (patch)
tree463539066b261fab590f28ba258cb8f8b180831d /dns
parent73aadfabb8d0b56d65f894bf51359f31ac707b2a (diff)
downloadports-4387ee26f25c3caea3200829b293417c215dbcb2.tar.gz
ports-4387ee26f25c3caea3200829b293417c215dbcb2.zip
- Update to 1.10.0
PR: ports/182179 Submitted by: Allan Jude <ports@scaleengine.com> (maintainer)
Notes
Notes: svn path=/head/; revision=327654
Diffstat (limited to 'dns')
-rw-r--r--dns/gdnsd/Makefile11
-rw-r--r--dns/gdnsd/distinfo4
-rw-r--r--dns/gdnsd/files/gdnsd.in28
-rw-r--r--dns/gdnsd/pkg-plist6
4 files changed, 27 insertions, 22 deletions
diff --git a/dns/gdnsd/Makefile b/dns/gdnsd/Makefile
index f95acfe52653..e947ac246071 100644
--- a/dns/gdnsd/Makefile
+++ b/dns/gdnsd/Makefile
@@ -1,8 +1,8 @@
-# Created by: Stefan Caunter <stef@scaleengine.com>
+# Created by: Allan Jude <ports@scaleengine.com>
# $FreeBSD$
PORTNAME= gdnsd
-PORTVERSION= 1.9.0
+PORTVERSION= 1.10.0
CATEGORIES= dns
MASTER_SITES= http://downloads.gdnsd.net/ \
http://gdnsd.scaleengine.net/gdnsd/
@@ -12,7 +12,7 @@ COMMENT= Authoritative-only GeoIP-aware DNS server
LICENSE= GPLv3
-LIB_DEPENDS= ev:${PORTSDIR}/devel/libev
+LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev
OPTIONS_DEFINE= GEOIP
@@ -40,4 +40,9 @@ GROUPS?= gdnsd
RUN_DEPENDS+= ${LOCALBASE}/share/GeoIP/GeoIP.dat:${PORTSDIR}/net/GeoIP
.endif
+post-install:
+ ${MKDIR} ${PREFIX}/var/run/gdnsd
+ ${MKDIR} ${PREFIX}/etc/gdnsd/zones
+ ${TOUCH} ${PREFIX}/etc/gdnsd/zones/.keep-me
+
.include <bsd.port.mk>
diff --git a/dns/gdnsd/distinfo b/dns/gdnsd/distinfo
index afc4071c9835..912335b11879 100644
--- a/dns/gdnsd/distinfo
+++ b/dns/gdnsd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gdnsd-1.9.0.tar.xz) = 050e52eda89d819ed340ec8cf49210de35c112ee993116906e13c4d2be19d38d
-SIZE (gdnsd-1.9.0.tar.xz) = 620632
+SHA256 (gdnsd-1.10.0.tar.xz) = 43c1c50cf58bc7a5dacb7379bf39276c5f4ebb2b4697d25dba228953015db3af
+SIZE (gdnsd-1.10.0.tar.xz) = 622584
diff --git a/dns/gdnsd/files/gdnsd.in b/dns/gdnsd/files/gdnsd.in
index 95062d168abc..a7a7b05b8d0a 100644
--- a/dns/gdnsd/files/gdnsd.in
+++ b/dns/gdnsd/files/gdnsd.in
@@ -12,37 +12,33 @@
#
# gdnsd_enable (bool): Set to NO by default.
# Set it to YES to enable gdnsd.
-# gdnsd_config (path): Set to %%PREFIX%%/etc/gdnsd/config
-# by default.
+# gdnsd_flags (str): Set to "" by default
+# Extra command line argument flags
. /etc/rc.subr
name="gdnsd"
-rcvar=`set_rcvar`
-command="%%PREFIX%%/sbin/gdnsd"
+rcvar=gdnsd_enable
# set defaults
load_rc_config $name
: ${gdnsd_enable:="NO"}
-: ${gdnsd_config="%%PREFIX%%/etc/gdnsd/config"}
-: ${gdnsd_pidfile="%%PREFIX%%/var/run/gdnsd.pid"}
+: ${gdnsd_flags:=""}
-required_files=${gdnsd_config}
-command_args="-c ${gdnsd_config} start"
+command="%%PREFIX%%/sbin/gdnsd"
+command_args="${gdnsd_flags} start"
procname=${command}
-extra_commands="checkconf"
-checkconf_cmd="gdnsd_checkconf"
-
-stop_postcmd=stop_postcmd
-
-stop_postcmd()
+reload_cmd="gdnsd_reload"
+configtest_cmd="gdnsd_checkconf"
+extra_commands="reload configtest"
+gdnsd_reload()
{
- rm -f ${gdnsd_pidfile}
+ ${command} ${gdnsd_flags} reload
}
gdnsd_checkconf()
{
- ${command} -c ${gdnsd_config} checkconf
+ ${command} ${gdnsd_flags} checkconf
}
run_rc_command "$1"
diff --git a/dns/gdnsd/pkg-plist b/dns/gdnsd/pkg-plist
index 6bf7600b9fed..6455c3abb778 100644
--- a/dns/gdnsd/pkg-plist
+++ b/dns/gdnsd/pkg-plist
@@ -70,6 +70,10 @@ sbin/gdnsd
%%DOCSDIR%%/gdnsd_manual.pod
%%DOCSDIR%%/gdnsd_manual.txt
@dirrm %%DOCSDIR%%
-@exec mkdir -p %D/%%ETCDIR%%/gdnsd
+@exec mkdir -p %D/var/run/gdnsd
+@dirrmtry var/run/gdnsd
+etc/gdnsd/zones/.keep-me
+@exec mkdir -p %D/%%ETCDIR%%/gdnsd/zones
+@dirrmtry etc/gdnsd/zones
@dirrmtry etc/gdnsd
@stopdaemon gdnsd