aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
commit642be1b81d8342d3a3323f43bcf5a0bd87a5d363 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /dns
parentbcaced2c93b58d27ca266602f4049df6ba6becb3 (diff)
downloadports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.tar.gz
ports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.zip
- Make ports use the libc provided iconv implementation on 10-CURRENT
after r254273 - Fix a bunch of ports to properly work after this - Mark converters/libiconv as IGNORE for systems with iconv in libc Reviewed by: bapt Approved by: portmgr (bapt) Discussed with: bapt, bsam (who both contributed ideas and code)
Notes
Notes: svn path=/head/; revision=326307
Diffstat (limited to 'dns')
-rw-r--r--dns/idnkit2/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/dns/idnkit2/Makefile b/dns/idnkit2/Makefile
index d73faffe0dcf..9b27efe4ae79 100644
--- a/dns/idnkit2/Makefile
+++ b/dns/idnkit2/Makefile
@@ -20,7 +20,6 @@ USE_AUTOTOOLS= libtool
USES= iconv
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libiconv=${LOCALBASE}
USE_LDCONFIG= yes
@@ -33,4 +32,16 @@ MAN3= idn_checkname.3 idn_comparenames.3 idn_comparenames2.3 \
MAN5= idn2.conf.5 idn2rc.5 idnalias.conf.5 idnlang.conf.5
MANCOMPRESSED= no
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS= --with-libiconv=/usr
+.else
+CONFIGURE_ARGS= --with-libiconv=${LOCALBASE}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-liconv|${ICONV_LIB}|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>