aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-07 10:41:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-07 10:41:01 +0000
commit680dc2055165441cce1d551d6d2c19265da20c2f (patch)
tree72099355e1c9053aaa4f1248c3d44877d0c6d65b /dns
parentbd0e534ff23c92eb8ed702cfc08db99afec2f81d (diff)
downloadports-680dc2055165441cce1d551d6d2c19265da20c2f.tar.gz
ports-680dc2055165441cce1d551d6d2c19265da20c2f.zip
dns/knot-resolver: Update to 2.1.1
Port changes: * Changed to DISTVERSION * Added USES=ncurses * Updated the list of stripped files * Added the patch PR: 226410 Submitted by: Leo Vandewoestijne <freebsd@dns-lab.com> (maintainer) Approved by: tcberner (mentor, implicit)
Notes
Notes: svn path=/head/; revision=463786
Diffstat (limited to 'dns')
-rw-r--r--dns/knot-resolver/Makefile10
-rw-r--r--dns/knot-resolver/distinfo6
-rw-r--r--dns/knot-resolver/files/patch-contrib_ucw_mempool-fmt.c11
-rw-r--r--dns/knot-resolver/pkg-plist25
4 files changed, 35 insertions, 17 deletions
diff --git a/dns/knot-resolver/Makefile b/dns/knot-resolver/Makefile
index 50ad3f67d7da..efcec390ec3f 100644
--- a/dns/knot-resolver/Makefile
+++ b/dns/knot-resolver/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= knot-resolver
-PORTVERSION= 1.5.3
-PORTREVISION= 0
+DISTVERSION= 2.1.1
CATEGORIES= dns ipv6
MASTER_SITES= https://secure.nic.cz/files/knot-resolver/ \
https://dns.company/downloads/knot-resolver/
@@ -27,7 +26,7 @@ MAKE_ARGS+= MANDIR=${PREFIX}/man
MAKE_ARGS+= PKGCONFIGDIR=${PREFIX}/libdata/pkgconfig
MAKE_ARGS+= lmdb_CFLAGS=-I${PREFIX}/include lmdb_LIBS=-llmdb
-USES= gmake libedit libtool pkgconfig tar:xz
+USES= gmake libedit libtool ncurses pkgconfig tar:xz
USE_LDCONFIG= yes
OPTIONS_DEFINE= COOKIES DNSTAP DOXYGEN GO MEMCACHED REDIS TRUSTANCHOR
@@ -73,7 +72,7 @@ REDIS_MAKE_ARGS_ON= HAS_hiredis=yes
REDIS_MAKE_ARGS_OFF= HAS_hiredis=no
REDIS_PLIST_FILES= lib/kdns_modules/redis.so
-TRUSTANCHOR_DESC= Trust anchor bootstrapping and stats
+TRUSTANCHOR_DESC= Trust anchor bootstrapping and stats
TRUSTANCHOR_USES= lua
TRUSTANCHOR_MAKE_ARGS_ON= HAS_ltn12=yes HAS_ssl.https=yes
TRUSTANCHOR_MAKE_ARGS_OFF= HAS_ltn12=no HAS_ssl.https=no
@@ -87,7 +86,8 @@ PORTDOCS= AUTHORS COPYING CodingStyle README.md
STRIP_TARGETS= sbin/kresd \
sbin/kresc \
- lib/libkres.so.3 \
+ lib/libkres.so.6 \
+ lib/kdns_modules/ahocorasick.so \
lib/kdns_modules/cookies.so \
lib/kdns_modules/dnstap.so \
lib/kdns_modules/hints.so \
diff --git a/dns/knot-resolver/distinfo b/dns/knot-resolver/distinfo
index 7d9cfb014762..e4413294281e 100644
--- a/dns/knot-resolver/distinfo
+++ b/dns/knot-resolver/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1520032733
-SHA256 (knot-resolver-1.5.3.tar.xz) = ceecd3bad06156f5f6e21aa2be9a9ce7cf1c2bc42d5f769531c962f37f014b0f
-SIZE (knot-resolver-1.5.3.tar.xz) = 1434804
+TIMESTAMP = 1520372546
+SHA256 (knot-resolver-2.1.1.tar.xz) = 0b9caee03d7cd30e1dc8fa0ce5fafade31fc1785314986bbf77cad446522a1b3
+SIZE (knot-resolver-2.1.1.tar.xz) = 1490064
diff --git a/dns/knot-resolver/files/patch-contrib_ucw_mempool-fmt.c b/dns/knot-resolver/files/patch-contrib_ucw_mempool-fmt.c
new file mode 100644
index 000000000000..f51157a6b8e1
--- /dev/null
+++ b/dns/knot-resolver/files/patch-contrib_ucw_mempool-fmt.c
@@ -0,0 +1,11 @@
+--- contrib/ucw/mempool-fmt.c.orig 2018-03-06 23:36:10 UTC
++++ contrib/ucw/mempool-fmt.c
+@@ -11,7 +11,7 @@
+ #include <ucw/lib.h>
+ #include <ucw/mempool.h>
+
+-#include <alloca.h>
++#include "alloc.h"
+ #include <stdio.h>
+ #include <string.h>
+
diff --git a/dns/knot-resolver/pkg-plist b/dns/knot-resolver/pkg-plist
index 0e3b96f4adbe..d1049259a434 100644
--- a/dns/knot-resolver/pkg-plist
+++ b/dns/knot-resolver/pkg-plist
@@ -1,14 +1,17 @@
-etc/kresd/config.cluster
-etc/kresd/config.isp
-etc/kresd/config.personal
-etc/kresd/config.splitview
-etc/kresd/icann-ca.pem
-etc/kresd/root.hints
+%%ETCDIR%%/config.cluster
+%%ETCDIR%%/config.isp
+%%ETCDIR%%/config.personal
+%%ETCDIR%%/config.splitview
+%%ETCDIR%%/icann-ca.pem
+%%ETCDIR%%/root.hints
+include/libkres/api.h
include/libkres/array.h
-include/libkres/cache.h
-include/libkres/cdb.h
+include/libkres/cdb_api.h
include/libkres/cdb_lmdb.h
+include/libkres/defines.h
include/libkres/dnssec.h
+include/libkres/impl.h
+include/libkres/iterate.h
include/libkres/layer.h
include/libkres/lru.h
include/libkres/map.h
@@ -16,6 +19,7 @@ include/libkres/module.h
include/libkres/nsec.h
include/libkres/nsec3.h
include/libkres/nsrep.h
+include/libkres/pack.h
include/libkres/resolve.h
include/libkres/rplan.h
include/libkres/set.h
@@ -52,6 +56,7 @@ lib/kdns_modules/http/selectize.bootstrap3.min.css
lib/kdns_modules/http/selectize.min.css
lib/kdns_modules/http/selectize.min.js
lib/kdns_modules/http/topojson.js
+lib/kdns_modules/http_trace.lua
lib/kdns_modules/kres.lua
lib/kdns_modules/kres-gen.lua
lib/kdns_modules/policy.lua
@@ -59,7 +64,9 @@ lib/kdns_modules/predict.lua
lib/kdns_modules/priming.lua
lib/kdns_modules/prometheus.lua
lib/kdns_modules/renumber.lua
+lib/kdns_modules/serve_stale.lua
lib/kdns_modules/stats.so
+lib/kdns_modules/ta_sentinel.lua
lib/kdns_modules/ta_signal_query.lua
lib/kdns_modules/trust_anchors.lua
lib/kdns_modules/version.lua
@@ -67,7 +74,7 @@ lib/kdns_modules/view.lua
lib/kdns_modules/workarounds.lua
lib/kdns_modules/zonefile.lua
lib/libkres.so
-lib/libkres.so.4
+lib/libkres.so.6
libdata/pkgconfig/libkres.pc
man/man8/kresd.8.gz
sbin/kresc