aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-07-25 17:45:09 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-07-25 17:45:09 +0000
commit8e2084427b6beb3d7a5458f5c7fcea080ddbb9b2 (patch)
tree17b7739cec5c8bd24318f8970c77d5508f40b335 /dns
parent72f2f983e22b1d65c479ff810e3f1d974b5932ad (diff)
downloadports-8e2084427b6beb3d7a5458f5c7fcea080ddbb9b2.tar.gz
ports-8e2084427b6beb3d7a5458f5c7fcea080ddbb9b2.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Notes
Notes: svn path=/head/; revision=323655
Diffstat (limited to 'dns')
-rw-r--r--dns/sleuth/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/dns/sleuth/Makefile b/dns/sleuth/Makefile
index e40a43baa46b..81b582cdee5d 100644
--- a/dns/sleuth/Makefile
+++ b/dns/sleuth/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sleuth
-# Date created: Jun 15, 2001
-# Whom: Mark Pulford <mark@kyne.com.au>
-#
+# Created by: Mark Pulford <mark@kyne.com.au>
# $FreeBSD$
-#
PORTNAME= sleuth
PORTVERSION= 1.4.4
@@ -16,12 +12,14 @@ COMMENT= A tool for checking DNS zones
RUN_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
USE_PERL5= yes
+USES= shebangfix
+SHEBANG_FILES= sleuth
PLIST_FILES= bin/sleuth etc/sleuth.conf.sample
post-patch:
- ${PERL} -pi -e "s|/etc/sleuth.conf|${PREFIX}/etc/sleuth.conf|g; \
- s|#!/usr/bin/perl|#!${PERL}|g;" ${WRKSRC}/sleuth
+ @${REINPLACE_CMD} -i '' -e 's|/etc/sleuth.conf|${PREFIX}/etc/sleuth.conf|' \
+ ${WRKSRC}/sleuth
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/sleuth ${PREFIX}/bin