aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-07-16 15:52:08 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-07-16 15:52:08 +0000
commit9367e535db3ef2d530f797f409d0816f00cdd533 (patch)
treef4205d562174918e8e7d8ae14b3dd8204c223713 /dns
parent211b706b0b29c3f264def36a44e7f3cabbe5aac6 (diff)
downloadports-9367e535db3ef2d530f797f409d0816f00cdd533.tar.gz
ports-9367e535db3ef2d530f797f409d0816f00cdd533.zip
Update to 9.16.5.
Notes
Notes: svn path=/head/; revision=542365
Diffstat (limited to 'dns')
-rw-r--r--dns/bind-tools/pkg-plist2
-rw-r--r--dns/bind916/Makefile2
-rw-r--r--dns/bind916/distinfo6
-rw-r--r--dns/bind916/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind916/files/patch-configure8
-rw-r--r--dns/bind916/pkg-plist2
6 files changed, 19 insertions, 15 deletions
diff --git a/dns/bind-tools/pkg-plist b/dns/bind-tools/pkg-plist
index 27461571644b..4902ad275ef8 100644
--- a/dns/bind-tools/pkg-plist
+++ b/dns/bind-tools/pkg-plist
@@ -33,12 +33,14 @@ bin/nsupdate
%%MANPAGES%%@comment man/man8/filter-aaaa.8.gz
%%MANPAGES%%@comment man/man8/named-checkconf.8.gz
%%MANPAGES%%@comment man/man8/named-checkzone.8.gz
+%%MANPAGES%%@comment man/man8/named-compilezone.8.gz
%%MANPAGES%%man/man8/named-journalprint.8.gz
%%MANPAGES%%@comment man/man8/named-nzd2nzf.8.gz
%%MANPAGES%%@comment man/man8/named.8.gz
%%MANPAGES%%man/man8/nsec3hash.8.gz
%%MANPAGES%%@comment man/man8/rndc-confgen.8.gz
%%MANPAGES%%@comment man/man8/rndc.8.gz
+%%MANPAGES%%@comment man/man8/tsig-keygen.8.gz
sbin/dnssec-cds
%%PYTHON%%sbin/dnssec-checkds
%%PYTHON%%sbin/dnssec-coverage
diff --git a/dns/bind916/Makefile b/dns/bind916/Makefile
index f414c6dea53b..1cfb622803e7 100644
--- a/dns/bind916/Makefile
+++ b/dns/bind916/Makefile
@@ -41,7 +41,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl tar:xz
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.16.4
+ISCVERSION= 9.16.5
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind916/distinfo b/dns/bind916/distinfo
index 25b23444bbd0..8ee7d886ef39 100644
--- a/dns/bind916/distinfo
+++ b/dns/bind916/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1592316528
-SHA256 (bind-9.16.4.tar.xz) = 7522088d3daac8bcabaae37998178e09139ef5ccae6631cb1d8a625b770f370a
-SIZE (bind-9.16.4.tar.xz) = 3465172
+TIMESTAMP = 1594913262
+SHA256 (bind-9.16.5.tar.xz) = 6378b3e51fef11a8be4794dc48e8111ba92d211c0dfd129a0c296ed06a3dc075
+SIZE (bind-9.16.5.tar.xz) = 3474044
diff --git a/dns/bind916/files/extrapatch-bind-min-override-ttl b/dns/bind916/files/extrapatch-bind-min-override-ttl
index 3bd85c832d18..0eebb6d5eb7b 100644
--- a/dns/bind916/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind916/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2020-06-10 21:01:43 UTC
+--- bin/named/config.c.orig 2020-07-03 10:44:14 UTC
+++ bin/named/config.c
@@ -179,6 +179,7 @@ options {\n\
notify-source *;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2020-06-10 21:01:43 UTC
+--- bin/named/server.c.orig 2020-07-03 10:44:14 UTC
+++ bin/named/server.c
-@@ -4328,6 +4328,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4330,6 +4330,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2020-06-10 21:01:43 UTC
+--- lib/dns/include/dns/view.h.orig 2020-07-03 10:44:14 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2020-06-10 21:01:43 UTC
+--- lib/dns/resolver.c.orig 2020-07-03 10:44:14 UTC
+++ lib/dns/resolver.c
-@@ -6247,6 +6247,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6256,6 +6256,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-06-10 21:01:43 UTC
+--- lib/isccfg/namedconf.c.orig 2020-07-03 10:44:14 UTC
+++ lib/isccfg/namedconf.c
@@ -1990,6 +1990,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
diff --git a/dns/bind916/files/patch-configure b/dns/bind916/files/patch-configure
index 007c65a9943a..f4c473335473 100644
--- a/dns/bind916/files/patch-configure
+++ b/dns/bind916/files/patch-configure
@@ -1,8 +1,8 @@
Fixup gssapi and db detection.
---- configure.orig 2020-06-10 21:01:43 UTC
+--- configure.orig 2020-07-03 10:44:14 UTC
+++ configure
-@@ -17602,27 +17602,9 @@ done
+@@ -17604,27 +17604,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -32,7 +32,7 @@ Fixup gssapi and db detection.
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -17665,47 +17647,7 @@ $as_echo "no" >&6; } ;;
+@@ -17667,47 +17649,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -81,7 +81,7 @@ Fixup gssapi and db detection.
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23208,7 +23150,7 @@ $as_echo "" >&6; }
+@@ -23213,7 +23155,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind916/pkg-plist b/dns/bind916/pkg-plist
index f3e47834ffad..1d23175959d0 100644
--- a/dns/bind916/pkg-plist
+++ b/dns/bind916/pkg-plist
@@ -300,6 +300,7 @@ lib/named/filter-aaaa.so
%%MANPAGES%%man/man8/filter-aaaa.8.gz
%%MANPAGES%%man/man8/named-checkconf.8.gz
%%MANPAGES%%man/man8/named-checkzone.8.gz
+%%MANPAGES%%man/man8/named-compilezone.8.gz
%%MANPAGES%%@comment man/man8/named-journalprint.8.gz
%%MANPAGES%%%%LMDB%%man/man8/named-nzd2nzf.8.gz
%%MANPAGES%%man/man8/named.8.gz
@@ -310,6 +311,7 @@ lib/named/filter-aaaa.so
%%MANPAGES%%%%NATIVE_PKCS11%%man/man8/pkcs11-tokens.8.gz
%%MANPAGES%%man/man8/rndc-confgen.8.gz
%%MANPAGES%%man/man8/rndc.8.gz
+%%MANPAGES%%man/man8/tsig-keygen.8.gz
sbin/ddns-confgen
sbin/named
sbin/named-checkconf