aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2019-06-25 12:52:20 +0000
committerMathieu Arnold <mat@FreeBSD.org>2019-06-25 12:52:20 +0000
commit9638a2aa6220f36c5e99b9ecbe22a2703336e9af (patch)
tree90535cd7f00fb0895a7a3f7ee4a10c27d88135e7 /dns
parent0848388a9e8d7cab83fde510b9594261f41bfb6a (diff)
downloadports-9638a2aa6220f36c5e99b9ecbe22a2703336e9af.tar.gz
ports-9638a2aa6220f36c5e99b9ecbe22a2703336e9af.zip
Update to latest commit.
Notes
Notes: svn path=/head/; revision=505086
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile6
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind9-devel/files/patch-configure8
-rw-r--r--dns/bind9-devel/pkg-plist2
5 files changed, 16 insertions, 18 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 97fd93b41153..1cc1e59e1f58 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -41,13 +41,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.15.0a0.2019.06.17
+ISCVERSION= 9.15.0a0.2019.06.25
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= ea054d024a196a7196d786ba7d8fda2456eed194
+GL_COMMIT= 32fc6c85f403ec26aa71ba403607f0032b373859
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -57,7 +57,7 @@ CPE_UPDATE= ${ISCVERSION:C/.*-//:tl}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
- --with-libxml2=${LOCALBASE} \
+ --with-libxml2 \
--with-readline="-L${LOCALBASE}/lib -ledit" \
--with-dlopen=yes \
--with-openssl=${OPENSSLBASE} \
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index def2d0779f8e..d4faef347433 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1560801587
-SHA256 (isc-projects-bind9-ea054d024a196a7196d786ba7d8fda2456eed194_GL0.tar.gz) = 73b91c68d9c2f91ad6bf255f9b0affac33111249a6c21849d12b3f06a19ef4e6
-SIZE (isc-projects-bind9-ea054d024a196a7196d786ba7d8fda2456eed194_GL0.tar.gz) = 6309814
+TIMESTAMP = 1561460029
+SHA256 (isc-projects-bind9-32fc6c85f403ec26aa71ba403607f0032b373859_GL0.tar.gz) = a77d6b168606b0a01c0e6192f2699a35e425fe9983061680f1af2fc21b71b65a
+SIZE (isc-projects-bind9-32fc6c85f403ec26aa71ba403607f0032b373859_GL0.tar.gz) = 6325417
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index e1d4f4738996..19139f502104 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2019-06-17 13:35:58 UTC
+--- bin/named/config.c.orig 2019-06-25 10:23:15 UTC
+++ bin/named/config.c
@@ -172,6 +172,7 @@ options {\n\
notify-source *;\n\
@@ -8,9 +8,9 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2019-06-17 13:35:58 UTC
+--- bin/named/server.c.orig 2019-06-25 10:23:15 UTC
+++ bin/named/server.c
-@@ -4226,6 +4226,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4225,6 +4225,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -22,7 +22,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2019-06-17 13:35:58 UTC
+--- lib/dns/include/dns/view.h.orig 2019-06-25 10:23:15 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -32,7 +32,7 @@
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2019-06-17 13:35:58 UTC
+--- lib/dns/resolver.c.orig 2019-06-25 10:23:15 UTC
+++ lib/dns/resolver.c
@@ -6048,6 +6048,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
@@ -47,7 +47,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2019-06-17 13:35:58 UTC
+--- lib/isccfg/namedconf.c.orig 2019-06-25 10:23:15 UTC
+++ lib/isccfg/namedconf.c
@@ -1910,6 +1910,7 @@ view_clauses[] = {
#endif
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index ad94169b6ce9..d16177c6a1c3 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2019-06-10 04:29:24 UTC
+--- configure.orig 2019-06-25 10:23:15 UTC
+++ configure
-@@ -16660,27 +16660,9 @@ done
+@@ -16771,27 +16771,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16723,47 +16705,7 @@ $as_echo "no" >&6; } ;;
+@@ -16834,47 +16816,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -21311,7 +21253,7 @@ $as_echo "" >&6; }
+@@ -22097,7 +22039,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index a07d83f71408..e36c15084eb9 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -156,7 +156,6 @@ include/isc/ht.h
include/isc/httpd.h
include/isc/interfaceiter.h
include/isc/iterated_hash.h
-include/isc/json.h
include/isc/lang.h
include/isc/lex.h
include/isc/lfsr.h
@@ -218,7 +217,6 @@ include/isc/tm.h
include/isc/types.h
include/isc/util.h
include/isc/version.h
-include/isc/xml.h
include/isccc/alist.h
include/isccc/base64.h
include/isccc/cc.h