aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-11-20 16:10:14 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-11-20 16:10:14 +0000
commitadfa184b9d477719254f362a88c239b117225b5f (patch)
tree15a7deb6b9f989a3211482f93b8c7eb00811d48b /dns
parent7fca44ad87894c306eb0eb06cc7a046f8c8f92a6 (diff)
downloadports-adfa184b9d477719254f362a88c239b117225b5f.tar.gz
ports-adfa184b9d477719254f362a88c239b117225b5f.zip
Update to latest commit.
Notes
Notes: svn path=/head/; revision=485433
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl44
-rw-r--r--dns/bind9-devel/files/patch-configure8
4 files changed, 21 insertions, 41 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index ee45bd065fd3..982f155d58ce 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -40,13 +40,13 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.1a0.2018.11.12
+ISCVERSION= 9.13.1a0.2018.11.20
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 62a92b7784a6fb5a1b29bce398d18e892a62846b
+GL_COMMIT= 380ab3b39f4ea99f7cfe0e9ce065594f3e697ab7
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 55090375db1b..f571d4663ef1 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1542017471
-SHA256 (isc-projects-bind9-62a92b7784a6fb5a1b29bce398d18e892a62846b_GL0.tar.gz) = 9d15143db25acb78d332574251bd92932b8c2e72610483f2d2c85882840ea616
-SIZE (isc-projects-bind9-62a92b7784a6fb5a1b29bce398d18e892a62846b_GL0.tar.gz) = 7273651
+TIMESTAMP = 1542725919
+SHA256 (isc-projects-bind9-380ab3b39f4ea99f7cfe0e9ce065594f3e697ab7_GL0.tar.gz) = 52e89b51cf997279a65390e16fb99325c8797da1a4b44e87e639f3732be0d273
+SIZE (isc-projects-bind9-380ab3b39f4ea99f7cfe0e9ce065594f3e697ab7_GL0.tar.gz) = 6535535
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index da4f49888a6b..caa3388fb896 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,13 +1,6 @@
---- bin/named/config.c.orig 2018-11-12 07:12:04 UTC
+--- bin/named/config.c.orig 2018-11-19 17:02:41 UTC
+++ bin/named/config.c
-@@ -174,12 +174,14 @@ options {\n\
- max-recursion-queries 75;\n\
- max-stale-ttl 604800; /* 1 week */\n\
- message-compression yes;\n\
-+ min-cache-ttl 0; /* no minimal, zero is allowed */\n\
- # min-roots <obsolete>;\n\
- minimal-any false;\n\
- minimal-responses no-auth-recursive;\n\
+@@ -182,6 +182,7 @@ options {\n\
notify-source *;\n\
notify-source-v6 *;\n\
nsec3-test-zone no;\n\
@@ -15,9 +8,9 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2018-11-12 07:12:04 UTC
+--- bin/named/server.c.orig 2018-11-19 17:02:41 UTC
+++ bin/named/server.c
-@@ -4109,6 +4109,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -4116,6 +4116,11 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -26,28 +19,22 @@
+ view->overridecachettl = cfg_obj_asuint32(obj);
+
+ obj = NULL;
-+ result = named_config_get(maps, "min-cache-ttl", &obj);
-+ INSIST(result == ISC_R_SUCCESS);
-+ view->mincachettl = cfg_obj_asuint32(obj);
-+
-+ obj = NULL;
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-11-12 07:12:04 UTC
+--- lib/dns/include/dns/view.h.orig 2018-11-19 17:02:41 UTC
+++ lib/dns/include/dns/view.h
-@@ -153,6 +153,8 @@ struct dns_view {
+@@ -153,6 +153,7 @@ struct dns_view {
bool requestnsid;
bool sendcookie;
dns_ttl_t maxcachettl;
-+ dns_ttl_t mincachettl;
+ dns_ttl_t overridecachettl;
dns_ttl_t maxncachettl;
- uint32_t nta_lifetime;
- uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2018-11-12 07:12:04 UTC
+ dns_ttl_t mincachettl;
+ dns_ttl_t minncachettl;
+--- lib/dns/resolver.c.orig 2018-11-19 17:02:41 UTC
+++ lib/dns/resolver.c
-@@ -5952,6 +5952,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
+@@ -5967,6 +5967,12 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
/*
@@ -57,23 +44,16 @@
+ rdataset->ttl = res->view->overridecachettl;
+
+ /*
-+ * Enforce the configure minimum cache TTL.
-+ */
-+ if (rdataset->ttl < res->view->mincachettl)
-+ rdataset->ttl = res->view->mincachettl;
-+
-+ /*
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-11-12 07:12:04 UTC
+--- lib/isccfg/namedconf.c.orig 2018-11-19 17:02:41 UTC
+++ lib/isccfg/namedconf.c
-@@ -1921,6 +1921,8 @@ view_clauses[] = {
+@@ -1921,6 +1921,7 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
+ { "override-cache-ttl", &cfg_type_ttlval, 0 },
-+ { "min-cache-ttl", &cfg_type_ttlval, 0 },
{ "max-cache-ttl", &cfg_type_ttlval, 0 },
{ "max-clients-per-query", &cfg_type_uint32, 0 },
{ "max-ncache-ttl", &cfg_type_ttlval, 0 },
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index 08a1f5b33671..cb700e4445a7 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-11-12 07:12:04 UTC
+--- configure.orig 2018-11-19 17:02:41 UTC
+++ configure
-@@ -16389,27 +16389,9 @@ done
+@@ -16386,27 +16386,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16452,47 +16434,7 @@ $as_echo "no" >&6; } ;;
+@@ -16449,47 +16431,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -21032,7 +20974,7 @@ $as_echo "" >&6; }
+@@ -21015,7 +20957,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).