aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-17 06:28:07 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-17 06:28:07 +0000
commitb15e495041a4fd2f9fafcc7d9540759c4c22a610 (patch)
treea2818cc36d7e06c4c64a53b943d25f7b90c450f3 /dns
parent46c6877a4a150b8a708675a333110c1effbc512e (diff)
Convert to new perl framework
Convert from USE_GMAKE to USES=gmake
Notes
Notes: svn path=/head/; revision=327451
Diffstat (limited to 'dns')
-rw-r--r--dns/ddclient/Makefile3
-rw-r--r--dns/dnscheckengine/Makefile3
-rw-r--r--dns/opendnssec/Makefile2
-rw-r--r--dns/opendnssec13/Makefile2
-rw-r--r--dns/p5-Net-RBLClient/Makefile12
-rw-r--r--dns/p5-POE-Component-Resolver/Makefile9
6 files changed, 13 insertions, 18 deletions
diff --git a/dns/ddclient/Makefile b/dns/ddclient/Makefile
index 4615a6e82d09..20b5378daf08 100644
--- a/dns/ddclient/Makefile
+++ b/dns/ddclient/Makefile
@@ -13,7 +13,8 @@ COMMENT= Update dynamic DNS entries
LICENSE= GPLv2
USE_BZIP2= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
USE_RC_SUBR= ${PORTNAME}
diff --git a/dns/dnscheckengine/Makefile b/dns/dnscheckengine/Makefile
index 9ce9e32b446c..e9dc160946fe 100644
--- a/dns/dnscheckengine/Makefile
+++ b/dns/dnscheckengine/Makefile
@@ -25,7 +25,8 @@ BUILD_DEPENDS= p5-Crypt-OpenSSL-Random>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-
p5-Mail-RFC822-Address>=0:${PORTSDIR}/mail/p5-Mail-RFC822-Address \
p5-MIME-Lite>=0:${PORTSDIR}/mail/p5-MIME-Lite
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_SCRIPT+= Makefile.PL INSTALLSITESCRIPT=${PREFIX}/libexec/dnscheck
WRKSRC= ${WRKDIR}/engine
diff --git a/dns/opendnssec/Makefile b/dns/opendnssec/Makefile
index 64f19d39abfa..f19581db49be 100644
--- a/dns/opendnssec/Makefile
+++ b/dns/opendnssec/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= ldns:${PORTSDIR}/dns/ldns
GNU_CONFIGURE= yes
USE_RC_SUBR= opendnssec
USE_GNOME= libxml2
-USE_PERL5= yes
+USES= perl5
USE_OPENSSL= yes
USE_LDCONFIG= yes
diff --git a/dns/opendnssec13/Makefile b/dns/opendnssec13/Makefile
index 6a8a0f679ab5..fd412bab3e02 100644
--- a/dns/opendnssec13/Makefile
+++ b/dns/opendnssec13/Makefile
@@ -17,7 +17,7 @@ LATEST_LINK= ${PORTNAME}13
GNU_CONFIGURE= yes
USE_RC_SUBR= opendnssec
USE_GNOME= libxml2
-USE_PERL5= yes
+USES= perl5
USE_OPENSSL= yes
USE_LDCONFIG= yes
diff --git a/dns/p5-Net-RBLClient/Makefile b/dns/p5-Net-RBLClient/Makefile
index f728687f68c6..67b09bb19c2e 100644
--- a/dns/p5-Net-RBLClient/Makefile
+++ b/dns/p5-Net-RBLClient/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Net-RBLClient
-# Date created: 2006-07-13
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Net-RBLClient
PORTVERSION= 0.5
@@ -20,10 +16,10 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/RBLCLient-${PORTVERSION}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= spamalyze.1
MAN3= Net::RBLClient.3
-.include <bsd.port.pre.mk>
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/p5-POE-Component-Resolver/Makefile b/dns/p5-POE-Component-Resolver/Makefile
index 7b390a8bfcf1..543c13580ae4 100644
--- a/dns/p5-POE-Component-Resolver/Makefile
+++ b/dns/p5-POE-Component-Resolver/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-POE-Component-Resolver
-# Date created: 21 February 2011
-# Whom: Jase Thew <freebsd@beardz.net>
-#
+# Created by: Jase Thew <freebsd@beardz.net>
# $FreeBSD$
-#
PORTNAME= POE-Component-Resolver
PORTVERSION= 0.921
@@ -22,7 +18,8 @@ BUILD_DEPENDS= p5-POE>=1.311:${PORTSDIR}/devel/p5-POE \
p5-Socket>=2.001:${PORTSDIR}/net/p5-Socket
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Component::Resolver.3 \
POE::Component::Resolver::Sidecar.3