aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-10-14 19:24:46 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-10-14 19:24:46 +0000
commitc11d0beab860d1d9eb0f6e8f6956c7fe67506f1d (patch)
tree35fc638f3ce2485b530c6c1fdbae31c5bcf5f5c6 /dns
parent4faa925e166290ae3a40d9e073acc3c589ae0c58 (diff)
downloadports-c11d0beab860d1d9eb0f6e8f6956c7fe67506f1d.tar.gz
ports-c11d0beab860d1d9eb0f6e8f6956c7fe67506f1d.zip
Add p5-Net-DNS-ZoneCheck, a perl module to validate a DNS zone composed
of RR records.
Notes
Notes: svn path=/head/; revision=119440
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-Net-DNS-ZoneCheck/Makefile26
-rw-r--r--dns/p5-Net-DNS-ZoneCheck/distinfo2
-rw-r--r--dns/p5-Net-DNS-ZoneCheck/pkg-descr3
-rw-r--r--dns/p5-Net-DNS-ZoneCheck/pkg-plist7
5 files changed, 39 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index fc486f4ecd84..b85afa065657 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -56,6 +56,7 @@
SUBDIR += p5-DNS-ZoneParse
SUBDIR += p5-Net-DNS
SUBDIR += p5-Net-DNS-SEC
+ SUBDIR += p5-Net-DNS-ZoneCheck
SUBDIR += p5-Net-DNS-ZoneFile
SUBDIR += p5-Net-DNS-ZoneFile-Fast
SUBDIR += p5-Net-Nslookup
diff --git a/dns/p5-Net-DNS-ZoneCheck/Makefile b/dns/p5-Net-DNS-ZoneCheck/Makefile
new file mode 100644
index 000000000000..b64bfa94c353
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneCheck/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: dns/p5-Net-DNS-ZoneCheck
+# Date created: 14 October 2004
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DNS-ZoneCheck
+PORTVERSION= 0.01
+CATEGORIES= dns perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Validate a DNS zone composed of Net::DNS::RR records
+
+BUILD_DEPENDS= ${SITE_PERL}/Regexp/Common.pm:${PORTSDIR}/textproc/p5-Regexp-Common \
+ ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::DNS::ZoneCheck.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-DNS-ZoneCheck/distinfo b/dns/p5-Net-DNS-ZoneCheck/distinfo
new file mode 100644
index 000000000000..74e63a7f8cd2
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneCheck/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-DNS-ZoneCheck-0.01.tar.gz) = 5447eaa45b4ee79fcaad822529a9d69b
+SIZE (Net-DNS-ZoneCheck-0.01.tar.gz) = 8114
diff --git a/dns/p5-Net-DNS-ZoneCheck/pkg-descr b/dns/p5-Net-DNS-ZoneCheck/pkg-descr
new file mode 100644
index 000000000000..88fdb2f759aa
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneCheck/pkg-descr
@@ -0,0 +1,3 @@
+This module validates DNS zones composed of Net::DNS::RR records.
+
+WWW: http://search.cpan.org/dist/Net-DNS-ZoneCheck
diff --git a/dns/p5-Net-DNS-ZoneCheck/pkg-plist b/dns/p5-Net-DNS-ZoneCheck/pkg-plist
new file mode 100644
index 000000000000..7bbb8514150b
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneCheck/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/DNS/ZoneCheck.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS/ZoneCheck/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS/ZoneCheck 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net/DNS 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true