aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2022-02-09 18:55:01 +0000
committerMatthias Andree <mandree@FreeBSD.org>2022-02-09 18:56:23 +0000
commitc331ef611536bc2e8b2a2d84a0a499d732fd8c2e (patch)
treeb730ed50c8d160c0b1d973ea25bccfa8b8cb99f1 /dns
parentdb43856d1785048b2b71affbfced2cd1af389229 (diff)
downloadports-c331ef611536bc2e8b2a2d84a0a499d732fd8c2e.tar.gz
ports-c331ef611536bc2e8b2a2d84a0a499d732fd8c2e.zip
dns/dnsmasq-devel: update to v2.87test8
new CHANGELOG entries since test7: - Fix problem with binding DHCP sockets to an individual interface. Despite the fact that the system call tales the interface _name_ as a parameter, it actually, binds the socket to interface _index_. Deleting the interface and creating a new one with the same name leaves the socket bound to the old index. (Creating new sockets always allocates a fresh index, they are not reused). We now take this behaviour into account and keep up with changing indexes. - Add --conf-script configuration option.
Diffstat (limited to 'dns')
-rw-r--r--dns/dnsmasq-devel/Makefile2
-rw-r--r--dns/dnsmasq-devel/distinfo6
-rw-r--r--dns/dnsmasq-devel/files/patch-dhcp.c22
3 files changed, 4 insertions, 26 deletions
diff --git a/dns/dnsmasq-devel/Makefile b/dns/dnsmasq-devel/Makefile
index 12717b829706..800a000c2274 100644
--- a/dns/dnsmasq-devel/Makefile
+++ b/dns/dnsmasq-devel/Makefile
@@ -1,7 +1,7 @@
# Created by: Steven Honson
PORTNAME= dnsmasq
-DISTVERSION= 2.87test7
+DISTVERSION= 2.87test8
# Leave the PORTREVISION in even if 0 to avoid accidental PORTEPOCH bumps:
PORTREVISION= 0
PORTEPOCH= 4 # attn - different between -devel and dnsmasq ports!
diff --git a/dns/dnsmasq-devel/distinfo b/dns/dnsmasq-devel/distinfo
index 7c5921bc2557..f2db25c3ecba 100644
--- a/dns/dnsmasq-devel/distinfo
+++ b/dns/dnsmasq-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1644144495
-SHA256 (dnsmasq-2.87test7.tar.xz) = 784462a4fed72b2bcabe2a9fbf428519f10740546a88b4a91432379042320588
-SIZE (dnsmasq-2.87test7.tar.xz) = 558152
+TIMESTAMP = 1644432655
+SHA256 (dnsmasq-2.87test8.tar.xz) = cb7245f4726d5692dd27d8c5f8ece8b88c9995fc0d649fd76d2870f80b852369
+SIZE (dnsmasq-2.87test8.tar.xz) = 558724
diff --git a/dns/dnsmasq-devel/files/patch-dhcp.c b/dns/dnsmasq-devel/files/patch-dhcp.c
deleted file mode 100644
index 4ceeba72fb1d..000000000000
--- a/dns/dnsmasq-devel/files/patch-dhcp.c
+++ /dev/null
@@ -1,22 +0,0 @@
-Taken from upstream git repository
-https://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commitdiff;h=4333d5d93a8fb2c14ef3d9eefb1a13fb6ca8d9d5
-
-Author: Johnny S. Lee (via mailing list)
-
---- ./src/dhcp.c.orig 2022-02-02 18:31:22 UTC
-+++ ./src/dhcp.c
-@@ -458,9 +458,12 @@ void dhcp_packet(time_t now, int pxe_fd)
- else
- {
- #ifdef HAVE_DUMPFILE
-- dest.sin_addr.s_addr = (ntohs(mess->flags) & 0x8000) ? INADDR_BROADCAST : mess->yiaddr;
-+ if (ntohs(mess->flags) & 0x8000)
-+ dest.sin_addr.s_addr = INADDR_BROADCAST;
-+ else
-+ dest.sin_addr = mess->yiaddr;
- dest.sin_port = htons(daemon->dhcp_client_port);
--
-+
- dump_packet(DUMP_DHCP, (void *)iov.iov_base, iov.iov_len, NULL,
- (union mysockaddr *)&dest, daemon->dhcp_server_port);
- #endif